FFE - Frontier: First Encounters - How to solve page fault and run in normal core

Topic actions

  • This topic is locked. You cannot reply or edit posts.

First post, by asq_dak

User metadata
Rank Newbie

Hi All,

I apologise for creating this particular thread, but given all of the previous FFE threads that I found had their last posts in 2004-2009 I thought it was ok to create another thread. Suffice it to say that I got FFE working in dosbox v0.74 normal core and wanted to document it somewhere.

To start, FFE is currently supported by Dosbox v0.74 but only using the Dynamic Core. Alternatively there is JJFFE or its descendents to run directly in windows. This is fine for my PC, but for a non-windows device restricted to the normal core it leaves a problem.

If you attempt to run FFE with dosbox normal core it will show the intro. If you hit a key, the intro will restart. If you hit a second key it will throw some kind of page fault error as per the screenshot attachments in this old thread:

Re: Frontier: First encounters on Vista

I actually found this thread recently that got me thinking about this again and trying to get FFE to work in normal core (although I haven't tried either of the 2 dosbox branches indicated in that thread, so they may also run FFE in normal core - I would appreciated it if someone wants to check that out)

Pagefault handling in the normal core

I was a little frustrated and have been messing around on and off for a few months to get it to work in the normal core. During this time I discovered a couple of things that helped.

1. The dos extender used by FFE is 32RTM and allegedly had some issue in some cases expecting interrupt 67h to be set a certain way, which may not necessarily be the case. Discussion here:


Based on this thread, I checked out Japheth's HX dos extender instead (downloads at the bottom of this link)


I had to do the following:
a. set my PATH = %PATH%,c:\hxrt216\bin (or wherever you placed the binaries)
b. run hxldr32.exe
c. then run firstenc.exe from the firstenc folder

Using this I got FFE to run (success!), but without sound (doh!).

2. Months later, this week I was messing around again, running dynamic core vs normal core with hxldr32. I noticed something odd when I went to load my saved game in FFE: the root folder was different. In dynamic core it was entering the in firstenc folder. In my normal core with hxldr32 it was entering in my root drive folder (e.g. c:\ if I was on c drive). So, on a hunch I assumed hxldr32 was referencing the FFE game calls for the sound assets vs c:\, rather than firstenc folder.

So I tried the following:
a. set my PATH = %PATH%,c:\hxrt216\bin (or wherever you placed the binaries)
b. mounted a folder directly to firstenc folder (eg mount f c:\dosdrive\firstenc)
c. selected f:
d. run hxldr32.exe
c. then run firstenc.exe

This time the game ran, with sound and music, no page fault crashes, all in normal core.

If this is of any help to anyone - enjoy! Otherwise at least I have documented my endeavours.

Reply 1 of 2, by gates007ca

User metadata
Rank Newbie

Sorry to necro this thread but I recently install FFE in Miyoo Mini and encountered the same problem as OP posted. I used his solution, copied all files of the Japheth's HX extender into the root directory of the game file (same dir as the firstenc.exe), then I made a batch file to run hxldr32.exe and then firstenc.exe). The game now run in Miyoo Mini portable! Thank you again for the solution but I just want to update this so if someone run into the same problem there is a solution out there!