First post, by Eala

User metadata
Rank Newbie

Hi all. Let me start by saying I'm a complete DOSBox newb 😊. I've read the ReadMe and FAQ things, and I'm probably just going wrong somewhere really obvious, but I still can't get the above game to work! I tried reinstalling (my thinking being to start everything below with a clean install) but at that point the game installer told me my CD rom drive wasn't fast enough.

To start with I got it to install fine. It ran up, but was really slow and jerky, and the sound was way ahead of the video. Tried changing the video res, that just made it crash with weird writing all over it (I took a SS but forgot to copy it to an image programme, sorry!).

So I came here, and saw the wonderful thread on the DOS32A extender changer thingamabob. I did what it said on that thread, (eventually, after some struggles with the bloody cmd window) and it seemed to have worked ok, I had the new olp file. Tried to run the game, and at that point I got a memory error (see the image below).


Anyone have any ideas? I tried changing the core thing in DOSBox to dynamic (as suggested) and that didn't seem to do anything.

Details about my PC / summary of problem (as per the "how to post stuff here thread):

Motherboard: Erm, don't know. Where can I find that out?
Proc: Intel Pentium 4 2.8GHZ HT
RAM: 2GB (2 x 1GB sticks, I *think* it's DDR2 but don't quote me on that).
Gfx card: Nvidia GeForce 6600 LE, 256MB
Soundboard: Erm?
OS: Win XP Home Edition, SP2 (fully up-to-date)
Game name: Star Trek: The Next Generation - A Final Unity
Original problem: Jerky graphics in both cutscene and normal play, not in sync with the sound. Very sluggish mouse and keyboard responses.
Current problem: Game will not run up, says I have not enough memory on exec.
Reproductibility: Always.
Soundboard: Erm? again
Video Mode: Not really sure, it went on about VEGA / VESA drivers or something in the installer.
Version of Emulator: DOSBox 0.65

I think I detailed the steps I've tried above, but if you need more info, np.

I might try doing a complete uninstall and reinstall again, maybe it'll see my damned CD drive after a reboot? 😖

Thanks in advance for any advice anyone has!

Reply 3 of 8, by Qbix

User metadata
Rank DOSBox Author
DOSBox Author

open dosbox.conf (it's in your startmenu in the dosbox folder)
look for the memsize option
change that one. (probably to 32 or 😎
save the file and start dosbox and try again

Water flows down the stream
How to ask questions the smart way!

Reply 4 of 8, by Eala

User metadata
Rank Newbie

Thanks 😀 Now the game loads up, to a certain point!

The cut scene graphics are still very choppy - sort of obvious low FPS if you know what I mean? But at least the opening credit scene finished at the same time as the music.

However now my problem is that it just stops with a black screen after the opening credits. I can hear the sound of the bridge, but nothing at all happens, I don't actually get the bridge scene coming up. (Before I could play it, but very very very sluggish, practically impossible).

I'd been using the DOS32A thing, and did all the making the sttng.new the sttng.ovl and so on. (as per this VOGON stickied thread. I tried changing it back to the original OVL and I can get to the bridge and play the game again.

So... I'm kinda back where I was 🤣. Mouse seems to take 2 to 3 sweeps across the mousemat to move half an inch, graphics are sluggish / gameplay is slow. The sound is a bit crackly but I can live with that, as it subtitles it anyway 😀.

Sorry for all this hassle, just really want to play this darned game again hehe.

Reply 6 of 8, by Eala

User metadata
Rank Newbie

Thanks 😀 I just changed it to 300, and upped the CPU thingie to about 9500 and it runs like a dream (mostly) now.

I occasionally get crashes at the Tactical screen (when going into battle from the Bridge) but it's livable with.

Thanks very much all for your help 😀

Reply 8 of 8, by cmw

User metadata
Rank Newbie

Last time I checked, STTNG ran far more stable without dos32a applied so you might try it without. (This statement is true for CVS builts, not for 0.65)

Also try to run the game in "normal" core mode (given that you have a powerful machine and can set the cycles high enough to get enough frames out of it).