VOGONS


First post, by rotaxt

User metadata
Rank Newbie
Rank
Newbie

hi folks!

another day another problem 😉

currently i am adding day by day some games to fantastic dbgl fontend to create a collection of my personal favourites.
so far everything is working fine but with indy 4 i have trouble. i tried to solve it within the last hours by myself but without success so
i hope you guys have a hint for me.

problem: soundfont ist not loading - i use dbgl with dosbox daum.

like for example in sam and max i chose in audio tab midi device = synth and put 8mbgm_enhanced18.sf2 in config of dbgl.

in setup of the game itself i chose combination of midi & blaster, midiport 330.

sam and max loads up with soundfont, but indy ignores soundfont. indy loads up only with "normal" midi i guess, but it is definately not the soundfont.
if i put the same game in scummvm i can add the soundfont and it works.

but why not in dbgl? i don't have a clue what to change anymore. same settings like with max or tentacle, but only in this game soundfont will not load 🙁

hope for your help.

best regards and thanks

Reply 2 of 9, by rotaxt

User metadata
Rank Newbie
Rank
Newbie

Xelasarg i don't understand. in the sound config of indy (i play the talkie version) i can choose between roland and midi, so why should it not support midi??

as i wrote via scummvm midi is working if i choose fluidsynth and load a soundfont.

https://www.youtube.com/watch?v=qbXT7Vv6A8Q

so i think i should be able to load up a soundfont in dosbox also?

Reply 3 of 9, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

First daum's Dosbox is not supported here. 2nd you probably need to manually edit daum's conf for it to use Fluidsynth and the soundfont instead of the default midi device

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox
DOSBox SVN snapshot for macOS (10.4-11.x ppc/intel 32/64bit) notarized for gatekeeper

Reply 4 of 9, by PhilsComputerLab

User metadata
Rank Hardware Mod
Rank
Hardware Mod
Xelasarg wrote:

Indy 4 doesn't support General Midi, use MT32 instead.

+1

The game doesn't support General MIDI at all. Roland MT-32 is what you want, just use the Munt emulator.

YouTube, Facebook, Website

Reply 6 of 9, by PhilsComputerLab

User metadata
Rank Hardware Mod
Rank
Hardware Mod
rotaxt wrote:

hm. okay but if i choose fluidsynth in scummvm and load up soundfont SGM V2.01 for example indy sounds much, much better than using mt32.
is using a soundfont via fluidsynth no midi?

I don't know what and how you configured things. This is how a real MT-32 sounds like: https://youtu.be/-3wywTErcyk

YouTube, Facebook, Website

Reply 7 of 9, by Xelasarg

User metadata
Rank Member
Rank
Member
rotaxt wrote:

hm. okay but if i choose fluidsynth in scummvm and load up soundfont SGM V2.01 for example indy sounds much, much better than using mt32.
is using a soundfont via fluidsynth no midi?

It's a matter of taste. I use SGM V2.01 whenever it's possible, but as a rule of thumb, MT32 music tends to sound a bit strange when it's played through a GM soundfont. If you like GM midi better, simply stick to it. You need to configure your Daum dosbox.conf like this:
mpu401=intelligent
mididevice=synth
midiconfig=SGM-V2.01.sf2

One additional note: Daum doesn't accept spaces in filenames. If your file is labelled "SGM V2.01.sf2", you have to rename it to something like "SGM-V2.01.sf2" in order to make it work.

*Edit*: OK, I googled a bit and it seems the talkie version does indeed support General Midi. Interesting...
Anyway, make sure to exlude spaces from your soundfont's filename, else it won't work. Apart from that, Daum suffers from another issue: the midi gain is set too high, so midi music can become severely distorted (e.g. in Warcraft 2). You can adjust synth.gain in MagicDosbox (Android port), but I haven't figured out yet how to do so in Daum.

"What's a paladin?!"

Reply 8 of 9, by collector

User metadata
Rank l33t
Rank
l33t

If MT-32 sounds bad with a game that supports MT-32 it is almost certainly because it has been setup wrong, like using MT-32/Munt when you have the game set to use GM. In other words, you are doing it wrong.

The Sierra Help Pages -- New Sierra Game Installers -- Sierra Game Patches -- New Non-Sierra Game Installers

Reply 9 of 9, by Xelasarg

User metadata
Rank Member
Rank
Member

Yep, MT32 sounds strange when it's played through GM midi and vice versa. The sound banks are different, so you may experience anything from wrong instruments to weird noises playing. Personally, I like GM midi with SGM V2.01 soundfont better than MT32, so I prefer it whenever there's a General Midi option, like e.g. in DOTT. But I haven't found a single MT32-only game so far that sounds better with GM. Still, you can try, if only for the sake of curiosity. 😉

"What's a paladin?!"