VOGONS


Absolute Zero - Division by Zero Crash

Topic actions

  • This topic is locked. You cannot reply or edit posts.

First post, by Novachen

User metadata
Rank Newbie
Rank
Newbie

Heyya all,

a few days ago i started to play the Sci-Fi Flight Simulation "Absolute Zero", which is marked as "supported" in the compatibility list.

After i figured out a few minutes ago, that i seem to played this game with totally wrong settings (wrong output make some missions barely playable due to slowdowns) i encountered a problem, where i do not find a solution so far.

After the Mission "Boiling Point 2", which is the 12nd mission of the game, the game crashes with a "Division by Zero" error, when i try to read the new personal log of one of the characters.
This crash is reproducible, even i can play the next mission without the reading of any new personal log, it makes no much sense, because this game is very story-driven, so you will miss most of the story. And the crash will occur the next time i go into this menu.

This game is a laserlok copy-protected game, so i use dos32/a instead of the original dos4gw.exe, even the use a laserlok-rid dos4gw.exe leads to the same error, divide by zero.

Actually i do not have many knowledge about DOS and it's errors.
In some other threads in this forum i read some hints that helped at their specific games.

But in my case, neither the change of the memsize, nor the core=normal setting helps. Only "DYNX86: cannot run code in this page" messages dissappear with the latter.

For normal use, i use the 3dfx capable SVN Daum Branch (because of this i had the wrong output setting i guess), but i also tried this with the original DosBox as well the latest SVN.
But nothing helps.

Any ideas?

Attachments

  • Absolute Zero Crash.png
    Filename
    Absolute Zero Crash.png
    File size
    144.1 KiB
    Views
    532 views
    File comment
    Crash Error
    File license
    Fair use/fair dealing exception

Reply 2 of 2, by Novachen

User metadata
Rank Newbie
Rank
Newbie

Yeah, that is exactly one of the topics i checked earlier for some ideas.

But the solutions there, did not help for this game, unfortunately.
So i tried another Dos4GW.exe, used Dos32a, changed in the configuration file to a normal CPU and also tried several fixed cycles and also a svn build.