First post, by FeedingDragon

User metadata
Rank Oldbie

Got to another game that gives me issues during install 🙁

It will not recognize Disk 2 in the physical drive or as an image with imgmount. The disks work fine in another emulator, and the game runs (though very poorly.) I tried copying the install directory (before running it after install,) but it then reports error 70 (the game, not DOSBox,) and locks up. Is there a work around to get the disks to install correctly in DOSBox, and would that fix the error 70 issue as well?

Thank you.

Feeding Dragon

Reply 1 of 1, by ripsaw8080

User metadata
Rank DOSBox Author
DOSBox Author

Some game installers are problematic because they use low-level access. In the case of Dark Seed, it is INT 25h.
For such cases it can be necessary to boot real DOS, which you are no doubt doing for the other emulator.

I tested the following with Darkseed v1.5 disk images, and it worked okay:

imgmount c hd20.img -t hdd -size 512,32,2,640
boot dos622.ima ds1.ima ds2.ima ds3.ima ds4.ima ds5.ima

Press Ctrl-F4 to switch floppies as needed and go through the process of installing the game to C:\DARKSEED

Once installed, copy the game directory structure and files out of the image onto a local drive.