VOGONS


First post, by Lazar81

User metadata
Rank Member
Rank
Member

Hello,
After playing around with newer catalyst driver (12.8 ) I managed to get back to pixel perfect in DOSBox ECE. It looks like every game runs as it should. Except scrolling - in pinball fantasies it is extremely obvious... It's a pain. I can't get rid of that damn tearing when a table scrolls up and down. I set double buffer true. It looks like this is an OpenGL problem - the tearing does not appear with surface or ddraw. But when using these output methods I don't have pixel perfect anymore.

486-VIP-IO | CYRIX 5x86 | 16MB | MACH32 VLB | CT1740 | 4GB CF
-
6VIA5T | PIII-S 1400 | 512MB | GF4Ti4600 | TT GOLD 16/96 | 120GB SSD
-
GA-EP45 DS4 | X5470 | 4GB | RADEON HD 5870 | SB0220 | 1TB SSD
-
ROLAND MT-32 | ROLAND CM-32L | YAMAHA S-YXG50

Reply 1 of 2, by jmarsh

User metadata
Rank Oldbie
Rank
Oldbie

Vsync is disabled for OpenGL output since it causes issues when games try to output frames at 70Hz and the display only supports up to 60Hz.
Pinball games are particularly susceptible to this because (unlike most games) they do actually generate 70 unique frames a second without any duplication.

Reply 2 of 2, by Lazar81

User metadata
Rank Member
Rank
Member

Well then the best way for me at the moment is to get back to previous ATI driver version. In previous version GPU scaling works perfectly - with catalyst 12 it doesn't. Don't know why.

Or is there any chance to get GPU scaling as it was with older drivers working with newer catalyst versions?

486-VIP-IO | CYRIX 5x86 | 16MB | MACH32 VLB | CT1740 | 4GB CF
-
6VIA5T | PIII-S 1400 | 512MB | GF4Ti4600 | TT GOLD 16/96 | 120GB SSD
-
GA-EP45 DS4 | X5470 | 4GB | RADEON HD 5870 | SB0220 | 1TB SSD
-
ROLAND MT-32 | ROLAND CM-32L | YAMAHA S-YXG50