First post, by treeman

User metadata
Rank Oldbie

I am not certain if this is a dosbox issue but when I play blood in higher resolutions 640x480 + the game is not stretched horizontally to fit a a widescreen on my laptop. Before I start the game the dos prompt is stretched to fit the screen but as soon as I start the game it is not. In 320x200 it is full wide screen however. The reason I think it is not the game because when I play exactly the same blood files and setup on a true dos 6 it is stretched to a wide screen monitor in 640x480.

I set the dosbox config file to 640x480 manually as well

Reply 1 of 2, by Kalle

User metadata
Rank Newbie


on my laptop there's a key (or better said, the key combination Fn + F7) that toggles scaling. Or you could look in the options of the graphics driver, there should also be an option as to how an image should be scaled.

I don't think there's a DOSBox option for it, but you can look in its config file in %localappdata%\DOSBox.

Just for some background info, neither your DOS prompt nor your 320x200 game gets scaled to fit your screen. It just happens to appear that way as back in the day pixels weren't necessarily square. But when treating them as square (which DOSBox does with the "aspect" option set to "false"), 320x200 happens to be 16:10. Same with the DOS Prompt. Normally it's 720x400, but I think DOSBox displays it as 640x400, which also results in a 16:10 image when assuming square pixels.
640x480 is 4:3 with square pixels already, hence it stays 4:3 unless you stretch it.

Last edited by Kalle on 2021-10-07, 09:38. Edited 1 time in total.