VOGONS


First post, by nad53

User metadata
Rank Newbie
Rank
Newbie

Greetings fellows. I have had this little issue since I was very kid with the 90s computers and playing DOS games back then, but even nowadays with DOSBox as well.

Just like the title says: I have encountered SOME DOS games that do NOT have a keyboard hotkey to return back to DOS (or DOSBox nowadays). The most common sense would be to have ESC key to return back to DOS, if there's NO game-menu option to do so, but I have had this little issue with them since I was a kid but nowadays as well. Only thing in DOSBox I can think of is just turning off DOSBox and re-open it. Pretty much like if you press Reset or Power-off buttons on your computer case. I just remember pressing reset button back then in late 90s and early 2000s to just stop playing some DOS game, 🤣.

Examples I can remember of right now are Paper Boy 2 and Robocod games.

If there's some modern way to fix this issue with classic DOS games, I would appreciate to know it.

Thanks for your time and for any help you can ever bring.

Reply 1 of 3, by LSS10999

User metadata
Rank Member
Rank
Member

I don't think it's trivial. Some games indeed did not have options to return to DOS as the program was designed that way.

On the other hand, there are games like Nova 9 actually handles the CTRL-ALT-DEL key combination for exiting. If you press CTRL-ALT-DEL in that game, instead of rebooting your PC, you'll be asked whether to quit to DOS or not. Don't know if there are other titles that use CTRL-ALT-DEL for exiting...

Reply 3 of 3, by Errius

User metadata
Rank l33t
Rank
l33t

You need to dig up the manual. Sometimes games use unusual keys for this. (Populous uses CTRL+ESC, which is problematic in Windows... Xenon 2 and Alien Breed use F10)

However, a lot of games back then were booters that didn't run on top of DOS. Later, crackers converted such games to run in DOS. Sometimes they added a routine to quit to DOS, but often they didn't.

Remember to try CTRL+C as well as CTRL+BREAK. (Frontier uses the first but ignores the second.)

Also try CTRL+X (Outrun) and CTRL+Q

“I like to dissect PCs. Don't you know I'm utterly insane?"