VOGONS

Common searches


DirectSerial patch

Topic actions

Reply 281 of 353, by dieter-erich

User metadata
Rank Newbie
Rank
Newbie

Hi, first my apologies for not reading all through...

I have now tried a number of things and want to share the results with you:

1. After installing DOSBox 0.7 build with serial debugging enabled and all the DLLs downloaded from h-a-l-9000's homepage my sensors seemed to work (I received data) BUT the data were wrong (i.e. temperature approximately correct but humidity much too high). I checked this with the program running on the PC booted under DOS.

2. I then tried DOS under VMWare. Testing was not extensive but as far as I can tell, I did not receive any data from the sensor.

3. I then tried Win98 (just the basic OS from a boot disk) under Viirtual-PC. I received data, but again they were wrong (much too high values for the humidity still worse than those from DOSBox).

I conclude that neither of the emulators gave reliable results most probably because of timing problems (as suggested by hal9000). It also appears to me that the data finally output by the program depend on the CPU load (the higher the load the worse are the data). Unfortunately, I do not know the structure of the data being received by the serial port and can thus not explain what is really happening. So, only way is to go on using Win98.......
Thanks a lot for trying to help particularly to h-a-l-9000, D-E

Reply 283 of 353, by dieter-erich

User metadata
Rank Newbie
Rank
Newbie

Hi h-a-l-9000,
here is the log file. I recorded it until the first data showed up in the program (it needs some time to initialize) but then it was already 14 MB long. I thus cut off the trailing end because the data structure seem to be always the same. Thanks for willing to help, cheers, D-E

Attachments

  • Filename
    dosbox_000.serlog.txt
    File size
    9.32 KiB
    Downloads
    5 downloads
    File comment
    log file of serial connection
    File license
    Fair use/fair dealing exception

Reply 286 of 353, by MiniMax

User metadata
Rank Moderator
Rank
Moderator

I believe the bps setting is controlled by your host OS.

DOSBox 0.73 ReadMe | DOSBox Wiki | DOSBox 60 seconds guide | How to ask questions
_________________
Lenovo M58p | Core 2 Quad Q8400 @ 2.66 GHz | Radeon R7 240 | LG HL-DT-ST DVDRAM GH40N | Win 10 Pro

Reply 288 of 353, by h-a-l-9000

User metadata
Rank DOSBox Author
Rank
DOSBox Author

I believe the bps setting is controlled by your host OS.

Nope it's controlled by the app running in DOSBox or by freedos mode.com (go hunt for it).

Alfaend:
Did you try to increase DOSBox speed?

1+1=10

Reply 298 of 353, by tijeff

User metadata
Rank Newbie
Rank
Newbie

I've just finish reading thru all this tread, but I’ve never been able to go to the h-a-l-9000 web page. I got a connection has timed out on : home.arcor.de/h-a-l-9000/ . Is the problem on my side ?

So far I’ve not been able to try any patch, but i’m using Dosbox 0.72. does it worth to try to find any new patch you released? , or they are already included in the 0.72 version ?

My settup is so ugly , you can’t event imagine. I have to run 2 dos-box emulator simultaneously

I got a first software using com1 to get data in , it does some process and throw it back in com2. My first Dosbox does a great job on this with 2 usb-serial adaptors.

Second software get data back on com3 (physical loop-back between com2 and com3) and try to output it on com4. My second dosbox emulator doesn’t work, I’ve assign my physical real uart for those just to be shure. Here is what I got :

DOSBox version 0.72
Copyright 2002-2007 DOSBox Team, published under GNU GPL.
---
CONFIG:Loading primary settings from config file dosbox.conf
Maximum memory size is 63 MB
MIDI:Opened device:win32
Serial3: Opening com1
Serial4: Opening com2
Serial3: Warning: Tried to activate FIFO.
Serial4: Warning: Tried to activate FIFO.
Serial3: Errors occured: Framing 0, Parity 0, Overrun 159 (IF0:5), Break 0
Serial3: Errors occured: Framing 0, Parity 0, Overrun 243 (IF0:2), Break 0
Serial3: Errors occured: Framing 0, Parity 0, Overrun 130 (IF0:3), Break 0

I think we can’t emphasise more on the fact we appreciate allot you’re job on this !
Sorry for my bad English.