Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Discussion about old PC hardware.

Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Elia1995 » 2016-5-01 @ 10:23

Yesterday I was using the file sharing just fine to transfer files from my main Windows 7 PC to my Windows 98, then I urgently had to format my main computer due to me being stupid and having launched Aston (which is a Windows 9x software to replace the Explorer with another one with more fancy themes) on Windows 7.... but whatever.

I formatted and today I wanted to access my C on Windows 98 like I did yesterday to transfer more games, but it isn't in the Network anymore ! I checked the workgroup and it's obviously the same, I checked the IP to prevent conflicts and they're different on each PC (my main is 192.168.0.34 manually assigned as usual due to port mapping on my router and the Windows 98 is 192.168.0.100 automagically assigned), file sharing is enabled in Windows 98, I didn't modify anything.... I dunno.

I couldn't access shared folders on Windows 7 from Windows 98 and couldn't find a workaround, but I got it working the other way around: sharing folders on Windows 98 and accessing them from here, I could do that just fine and now it disappeared from my Network... and yes, before you ask, the cables are all the way in... :evil:

Image
Image
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 651
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Jo22 » 2016-5-01 @ 10:43

That's a known problem.. Also happens when you connect WFW and Win7.
Don't have everything at hand, right now. But has to do with lan manager settings.
Check your "ntlm authentication" levels.
Make sure you use a low encryption strength (40/56 bit encryption), and have "LmCompatibilityLevel" set to "1"
On 9x you can also install "Active Directory Client Extension", maybe that helps.


https://support.microsoft.com/en-us/kb/239869
https://support.microsoft.com/en-us/kb/954387
"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//
User avatar
Jo22
l33t
 
Posts: 3984
Joined: 2009-12-13 @ 07:06
Location: Europe

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Elia1995 » 2016-5-01 @ 10:48

That's how I had already set it:

Image

I can't find those "ntlm authentication" levels you talked about :neutral:

I'll now check those 2 Microsoft support links you sent :neutral:

EDIT: Ok, I checked them and they say to modify a value I don't have at all, I don't know if creating it from scratch would work at all... " LMCompatibilityLevel"

Image
Last edited by Elia1995 on 2016-5-01 @ 10:53, edited 1 time in total.
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 651
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Jo22 » 2016-5-01 @ 10:50

Regedit. HKLM\SYSTEM\CurrentControlSet\Control\Lsa

Edit : Forgot, something.. Don't use homegroup settings, use workgroup. Enable passwords, but use low encryption.
Yes, create that setting as DWORD.

Edit2: Make sure both are in the same "Workgroup".

Edit3: And don't use "simple filesharing". Win2k or 9x can't do that.
Last edited by Jo22 on 2016-5-02 @ 08:09, edited 2 times in total.
"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//
User avatar
Jo22
l33t
 
Posts: 3984
Joined: 2009-12-13 @ 07:06
Location: Europe

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Elia1995 » 2016-5-01 @ 11:33

An interesting thing is that the shared folders themselves don't appear anymore in the network on Windows 98 itself aswell... yesterday both "Elia1995-PC" (Windows 7, unaccessible, but it appeared anyway) and "WINDOWS-98" were there...

Image
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 651
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby candle_86 » 2016-5-01 @ 12:14

And this is why filezilla server with filezilla client make it so nice. Just setup an FTP and forget about workgroups
Ryzen 5 1600 - Gigabyte B350 Gaming - 16gb DDR4 3200 - 240GB M.2 - Windows 10 Pro
Core i3 3470 - Dell B75 Mobo - 4gb DDR3 1333 - 500gb HDD - Windows XP
Opteron 180 - Epox EP-9NPA+SL - 2gb DDR500 - 320GB HDD - Windows XP
User avatar
candle_86
l33t
 
Posts: 2263
Joined: 2010-8-06 @ 01:04
Location: Fort Worth, Republic of Texas

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Elia1995 » 2016-5-01 @ 12:16

Is there a filezilla version compatible with 98 ? That would be much better... I could even browse the folders off my main directly on Windows 98 at that point...

I wonder how I didn't think about FTP in the first place :confused:
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 651
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby candle_86 » 2016-5-01 @ 12:18

Elia1995 wrote:Is there a filezilla version compatible with 98 ? That would be much better... I could even browse the folders off my main directly on Windows 98 at that point...

I wonder how I didn't think about FTP in the first place :confused:


You need filezilla client 2.2.2
FileZilla_2_2_2_setup.exe
(3.02 MiB) Downloaded 21 times


For the server side just grab it from
https://filezilla-project.org/download.php?type=server
Ryzen 5 1600 - Gigabyte B350 Gaming - 16gb DDR4 3200 - 240GB M.2 - Windows 10 Pro
Core i3 3470 - Dell B75 Mobo - 4gb DDR3 1333 - 500gb HDD - Windows XP
Opteron 180 - Epox EP-9NPA+SL - 2gb DDR500 - 320GB HDD - Windows XP
User avatar
candle_86
l33t
 
Posts: 2263
Joined: 2010-8-06 @ 01:04
Location: Fort Worth, Republic of Texas

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Elia1995 » 2016-5-01 @ 12:19

I just tried installing the server here on Windows 7 and I got a TLS error

My concern is: will I be able to do all of that LAN only ???

I don't want to connect the Windows 98 to the external Internet, because there aren't updated antiviruses for Windows 98 and it would die immediately :depressed:
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 651
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby candle_86 » 2016-5-01 @ 12:24

Elia1995 wrote:I just tried installing the server here on Windows 7 and I got a TLS error

My concern is: will I be able to do all of that LAN only ???

I don't want to connect the Windows 98 to the external Internet, because there aren't updated antiviruses for Windows 98 and it would die immediately :depressed:


yes it works fine on lan only
Ryzen 5 1600 - Gigabyte B350 Gaming - 16gb DDR4 3200 - 240GB M.2 - Windows 10 Pro
Core i3 3470 - Dell B75 Mobo - 4gb DDR3 1333 - 500gb HDD - Windows XP
Opteron 180 - Epox EP-9NPA+SL - 2gb DDR500 - 320GB HDD - Windows XP
User avatar
candle_86
l33t
 
Posts: 2263
Joined: 2010-8-06 @ 01:04
Location: Fort Worth, Republic of Texas

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Elia1995 » 2016-5-01 @ 12:26

Well... I can't get past this error, it's useless currently.

Image


EDIT: WTF ? I tried to connect to the Windows 98 PC just typing its name in the address bar and it did it... even though it isn't showing among the computers in the Network window... what the hell ?!

By the way, I'm still interested in the FTP method, that way I can also do the opposite: browsing specific folders on my Windows 7 from the Windows 98 PC which I can't currenly do with classic Workgroup.
Last edited by Elia1995 on 2016-5-01 @ 12:30, edited 1 time in total.
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 651
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby candle_86 » 2016-5-01 @ 12:30

Elia1995 wrote:Well... I can't get past this error, it's useless currently.

Image


install
https://support.microsoft.com/en-us/kb/2533623
Ryzen 5 1600 - Gigabyte B350 Gaming - 16gb DDR4 3200 - 240GB M.2 - Windows 10 Pro
Core i3 3470 - Dell B75 Mobo - 4gb DDR3 1333 - 500gb HDD - Windows XP
Opteron 180 - Epox EP-9NPA+SL - 2gb DDR500 - 320GB HDD - Windows XP
User avatar
candle_86
l33t
 
Posts: 2263
Joined: 2010-8-06 @ 01:04
Location: Fort Worth, Republic of Texas

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Elia1995 » 2016-5-01 @ 12:31

candle_86 wrote:
Elia1995 wrote:Well... I can't get past this error, it's useless currently.

Image


install
https://support.microsoft.com/en-us/kb/2533623


Ok, I'll try that, thanks

Ok, I set up the server, user and other stuff, but I can't connect to it from the Windows 98 PC...

EDIT: Nevermind, I managed to connect via FTP from the Windows 98 PC, it was just Windows 7's firewall that I forgot to turn off lol
Yeah, much better via FTP than workgroup, now I can do "both ways" :D
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 651
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Jo22 » 2016-5-02 @ 07:56

Hi, sorry, for the late response, was busy, did a PC repair for a customer. ¬_¬

I'm glad you can now copy files, at least! :-D

But normally SMB should work. The issue you have is similar to the one those Power Macs had got
when they accessed an older PC, I think. (The AFP issue is another story and more of a Mac-Mac problem.)


Long story short: The whole story started, when Vista came along with SMB2/NTLMv2 and Samba wasn't ready for it.

After this, a lot of confusion started when people used their computers in a heterogeneous network environment.

Later Versions of OS X then got SMB2 and probably broke compatibility with Win9x, too (have to check that). ;-)


However, it is possible to have them talking to each other happily.
Just takes a bit of care and patience.

If there's still some interest, let me know!
- I will setup my virtual machines then and write down the necessary steps.


Here I found a few articles, they're loosely related to this, but fun to read.

Sharing files between a Windows XP PC and a Mac running OS 10.4.x

OS X Mavericks switches to SMB2 networking

Delay When Viewing Shares on a Windows 9x-Based Computer

Networking WfW and Windows 8.1
"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//
User avatar
Jo22
l33t
 
Posts: 3984
Joined: 2009-12-13 @ 07:06
Location: Europe

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Elia1995 » 2016-5-02 @ 08:08

Well, if there could be a way to access the shared folders on my Windows 7 PC FROM the Windows 98 one (which I currently can't do, I can only do the other way around: share folders on 98 and access them from 7), that interests me.
Although I can use FTP, it's still not quite handful, I have to download the folders from there to there and I can't use them "right away" from the shared folders.

Well, for example: let's say I have a "games" folder in an hardisk in my main Windows 7 PC which I share, I'd have to download it from FTP from 98 to use it, instead with "workgroup" I could just browse there and run the games off my hardisk right from Windows 98 without having to copy files and cluster the Windows 98 PC's hardisk. (well.. I hope you understand what I wanted to say lol)
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 651
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Jo22 » 2016-5-02 @ 08:38

Yup, I do. And FTP is fine for filetransfer, btw, just as candle_86 said.
Reminds me of the times when I was using File Maven on a serial connection.

Btw, I did a few edits (I marked them as edits), hope thats okay. :blush:

So, there a few things which we should have a look at:
0) Is TCP/IP correctly installed and are all services loaded ?
a) Are both computers in the same "Workgroup" ?
b) Are the IP adresses right (same subnet mask, same IP range; or both as DHCP) ?
c) Is simple filesharing set to "no simple filesharing" ?
d) Is "public folder sharing" disabled ?
e) Is "homegroup" disabled ?
f) Does the Win7 PC use low encryption strenght (40/56bit) ?
g) Is the DWORD entry "LmCompatibilityLevel" set to "1" (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa)
h) Are passwords enabled ?
i) Did you try to disable IPv6 on Win7 ?
x) Where both computers restartet after this ?

That's all I can remeber for now, maybe that helps to find the problem. Or maybe not. I'll setup my VMs later on then.
Do you plan to add other OSes to your network later ? Like OS/2 or WFW ? Maybe I can include them in my virtual network for testing.
"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//
User avatar
Jo22
l33t
 
Posts: 3984
Joined: 2009-12-13 @ 07:06
Location: Europe

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Elia1995 » 2016-5-02 @ 08:45

Well, as I get a bigger hardisk in that retro system (currently there's just a single 8 GB one), I'll certainly make it dual boot with XP, I also have an OS/2 CD, but I dunno if I can install it in that computer.
Although I've never tried OS/2, it would be my first time experimenting with it since I can't emulate it on vmware, it seems :neutral:

I'll now check all those stuff and report later.

-------------------------------------

Ok, so here's everything (or at least what I could check):

#0 I'm using TCP/IPv4 on Windows 7, I ain't sure how to check on 98 Image
#1 Yes, both computers are in the exact same WORKGROUP, in fact I can access the shared folders on Windows 98 without problems from 7, but I can't access the shared folders on 7 from 98, that's the point now...
#2 As I said some posts ago, I set the IP manually for my main PC (Windows 7) as "192.168.0.34" and subnet "255.255.255.0", Windows 98 has it automatic, being currently "192.168.0.100" and subnet "255.255.255.0", both computers are plugged in in the same router and, obviously, have the same IP range.
#3 Are you referring to simple filesharing on 7 or 98 ? I didn't understand this one :confused:
#4 Yes, I just disabled it on 7.
#5 Yes, I also disabled homegroup on 7, leaving it on Workgroup only.
#6 Yeah, I changed that yesterday from 128-bit encryption to 40.
#7 Yes, I made that DWORD myself since it was missing and I set it to "1" and then restarted.
#8 No, I read that passwords would give problems for 98, so I disabled them on 7, I don't need them anyway, it's just these 2 computers that I both use myself...
#9 I've never used IPv6 in first place lol
#10 restarted after what ? Most of the things I already changed yesterday anway.
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 651
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Jo22 » 2016-5-02 @ 11:29

1) Ah, okay. Can you post an error message ? Looks like an permission issue. At least they see each other.
3) Yes, the 7. Simple filesharing was introduced with Win XP, but it causes trouble if you have older PCs in a network, running 98SE or 2000. Professional network administrators don't like it, I heard.

See here:

What is Simple File Sharing and How to Turn It Off

Windows 7 – Disable Simple File Sharing

9) Ah, okay then. Just said that, 'cause since Vista there's this hybrid network stack.. where IPv6 is on by default.
10) Restart both computers after you changend some vital settings, like the workgroup name or the IP addresses.


Sorry, If it takes a while until I respond, but I'm quite busy today, too.
Preparing stuff for someones birthday.. Already made muffins this morning. :)

I'll be back in a few hours. Maybe others have ideas in the meantime.


I wish you lots of luck!
"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//
User avatar
Jo22
l33t
 
Posts: 3984
Joined: 2009-12-13 @ 07:06
Location: Europe

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Elia1995 » 2016-5-02 @ 13:14

This is the error message I get when I try to access the shared folders on my Windows 7 PC from Windows 98:

Image

Which means:
Code: Select all
 Impossible to access to \\Elia1995-pc.
Request not supported by the network.
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 651
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Windows 98 PC suddenly stopped appearing in the Network on my main (Windows 7) PC

Postby Jo22 » 2016-5-02 @ 17:12

Alright, thank you. That was what I was looking for! :)

Seems it's indeed a permission issue. Or a bunch of them.

Just a few ideas..

On your Win7 machine, set the permission for those folders to "everyone".

If that's still not enought, create an user account on your Win7 PC that has the same name
as your Win98 user account and give it full permission to these folders (so basically making a copy of that account).

User Tripredacus at msfn.org explained it.

Read his post here.

He also menetions the fact, that Win98 has guest mode enabled by default, but Win7 has not.
So that's why you can see the files on your 98 rig..


Oh, and that thread also talks about NetBIOS.. Maybe it has to be enabled on your Win7 machine (isn't it ?).


There's a MS article about it. NetBIOS over TCP/IP



Elia1995, I wish you all the best getting it working, but I still have to finish that birthday stuff..

Maybe I'm around tomorrow (in the evening) or the day after tomorrow.


Best Regards,
Jo22
"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//
User avatar
Jo22
l33t
 
Posts: 3984
Joined: 2009-12-13 @ 07:06
Location: Europe

Next

Return to General Old Hardware

Who is online

Users browsing this forum: danijelm, Deksor, Repo Man11 and 24 guests