VOGONS


First post, by thepirategamerboy12

User metadata
Rank Member
Rank
Member

I'm trying to play The Adventures of Willy Beamish CD on my NEC Ready 7022, which is a 100mhz Pentium running Windows 95 in PhilsComputerLab's DOS Mode with an Opti930 sound chipset in Sound Blaster Pro mode. I install the game, but whenever I run the batch file I keep getting a message saying "Unable to initialize hds. mode=4 port=544..." Does anyone have an idea on how to fix this? I can't find anything about this issue on real vintage hardware online. Thanks.

Reply 1 of 2, by skitters

User metadata
Rank Member
Rank
Member

I found a 2006 post about that problem here
http://www.vintage-sierra.net/forum2/viewtopi … .php?f=3&t=1525

The answer from "Xenon Explosion" was

Are you playing the disk version or the CD-ROM version? Sometimes I've had trouble off and on playing some CD games from DosBox like Laura Bow, Ecoquest and Willy Beamish. I think it's because I actually have a DVD-Rom, not a true CD-Rom, and it's getting confused somewhere. Copying all the files from the CD to your game directory on your hard drive solves that problem.

He mentions DOSBox, but it may not be a DOSBox problem.
It may be something that happened on old computers too.

Reply 2 of 2, by Jorpho

User metadata
Rank l33t++
Rank
l33t++

Indeed, there are many Google hits for "initialize hds". The old thread at Willy Beamish CD-ROM ultimately suggests you should take a look at http://sierrahelp.com/Utilities/SoundUtilities/GOSiERRA.html .