VOGONS


First post, by GeorgeMan

User metadata
Rank Oldbie
Rank
Oldbie

Hello fellow VOGONerS!

I have problem trying to get a Gravis Gamepad Pro (gameport edition) working in my Win98SE retro machine.

I attach it to the gameport of my Soundblaster Pro 2 (CT1600), that works good under Windows. I have set the jumpers to SB classic (IRQ7 etc) and disabled LPT port in BIOS.
Everything in control panel seems to work OK (OPL3 ok, no sound issues, no IRQ conflicts reported).

The drivers of the gamepad install just fine (I don't think they do any search that you have indeed the gamepad plugged in).
But then, it simply does not work. Neither in GrIP mode, nor in standard mode. I tried setting "keyboard key presses" emulation in its setup program, but nothing seems to work.

This particular gamepad works OK with an SB Live in another PC (and Creative drivers installed).

So, what to do? 😕 😕 I have not installed any SB drivers, just what installation picked up automatically.
Please help me! 😊

Retro1: Athlon XP 3200+ @Arctic cooler | ASUS A7V600 | Radeon 9800XXL 128MB | SB Audigy 2 ZS | 160GB IDE HDD | Win98SE & XP
Retro2: under construction with a PIII 933 or a Tualatin Celeron 1200 and a GF2 GTS 32MB

Reply 1 of 4, by GeorgeMan

User metadata
Rank Oldbie
Rank
Oldbie

Anyone please help? 😢

Should I install SB Pro2 drivers? But everything I find is floppies for DOS... But in the device manager there is a gameport showing up with no exclamation marks.

Retro1: Athlon XP 3200+ @Arctic cooler | ASUS A7V600 | Radeon 9800XXL 128MB | SB Audigy 2 ZS | 160GB IDE HDD | Win98SE & XP
Retro2: under construction with a PIII 933 or a Tualatin Celeron 1200 and a GF2 GTS 32MB

Reply 2 of 4, by Jo22

User metadata
Rank l33t++
Rank
l33t++

Do you have two sound cards installed into that particular machine ?
IMHO the normal Gavis Gamepad uses both joysticks/button pairs on the gameport.

Sorry, can't really help. I do neither own a SB Pro II, nor a Gravis Pro. 🙁
(Maybe it's a speed problem, though ? Early gameports had no speed-compensation.)

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//

Reply 3 of 4, by red_avatar

User metadata
Rank Oldbie
Rank
Oldbie

From experience, sometimes the oddest errors occur when certain hardware is used in combination even if you do everything right but more often, it's a more global error that is at the root of the problem.

First thing to do in such cases, is to determine the source of the problem. Is the problem only caused by your Gravis or does it affect ALL gamepads/joysticks? In other words, do any other joysticks work on that same gameport?

Retro game fanatic.
IBM PS1 386SX25 - 4MB
IBM Aptiva 486SX33 - 8MB - 2GB CF - SB16
IBM PC350 P233MMX - 64MB - 32GB SSD - AWE64 - Voodoo2
PIII600 - 320MB - 480GB SSD - SB Live! - GF4 Ti 4200
i5-2500k - 3GB - SB Audigy 2 - HD 4870

Reply 4 of 4, by GeorgeMan

User metadata
Rank Oldbie
Rank
Oldbie

Thank you for your answers.

I don't have any other sound cards installed in that machine and I don't want to install any other. Maybe I should try one for test, but I think it'll be alright, as is in the other machine.

I also don't have another gameport gamepad, so I can't really test the functionality of the gameport. 🙁 The only thing that I can confirm is that when you refresh the status of the gamepad in the "Controllers" menu of windows 98SE, it shows an "OK" after a second or so. But I don't think it really tests anything there too.

Maybe I need drivers to be installed and the card doesn't like the win98se default ones? I'm really stuck here!

PS: In the configuration page of the gravis gamepad pro, it reports that it's either not connected or not functioning properly, even if the win98se status reports the aforementioned "OK".

Retro1: Athlon XP 3200+ @Arctic cooler | ASUS A7V600 | Radeon 9800XXL 128MB | SB Audigy 2 ZS | 160GB IDE HDD | Win98SE & XP
Retro2: under construction with a PIII 933 or a Tualatin Celeron 1200 and a GF2 GTS 32MB