VOGONS


Reply 220 of 222, by polpo

User metadata
Rank Newbie
Rank
Newbie
bjwil1991 wrote on 2021-08-01, 22:40:

I was doing some reflowing on the GUS Max 2.1 card since it would lock up at the detection using the DOS setup program or when I enable it in Windows 95C's device manager. I reflowed the following to see if the issue would get fixed:
[...]
Apparently, the ICS1614 GF1 chip is done for and the card isn't detected any longer (throws an error saying the HW address is in use, the CD drive isn't detected, and so on).

The GF1 is almost certainly fried. I had the same symptoms on my original GUS board and replacing the GF1 fixed it. Here's a thread I made about the issue: Bringing a Gravis Ultrasound back from the dead

Reply 221 of 222, by Zerthimon

User metadata
Rank Newbie
Rank
Newbie

Not a retro hardware, but a device helping fixing it ... I recently fried my multi-function tester TC-1 by plugging a charged cap into it 🙁

Reply 222 of 222, by bjwil1991

User metadata
Rank l33t
Rank
l33t
polpo wrote on 2022-01-07, 17:10:
bjwil1991 wrote on 2021-08-01, 22:40:

I was doing some reflowing on the GUS Max 2.1 card since it would lock up at the detection using the DOS setup program or when I enable it in Windows 95C's device manager. I reflowed the following to see if the issue would get fixed:
[...]
Apparently, the ICS1614 GF1 chip is done for and the card isn't detected any longer (throws an error saying the HW address is in use, the CD drive isn't detected, and so on).

The GF1 is almost certainly fried. I had the same symptoms on my original GUS board and replacing the GF1 fixed it. Here's a thread I made about the issue: Bringing a Gravis Ultrasound back from the dead

I have a GUS ACE anyway that'll get tested this Saturday (work schedule is cray). Wish someone in the USA sold the ICS GF1 chips for a good price so I can install the GUS Max 2.1 in another system.

Discord: https://discord.gg/U5dJw7x
Systems from the Compaq Portable 1 to FX-8350
Twitch: https://twitch.tv/retropcuser