First post, by anetanel

User metadata
Rank Member

I spent last night installing an Asus P3B-F (rev 1.04) with a P2-450 CPU, S3 Virge PCI card and a Diamond Monster 3D II 8Mb.
I used a PS/2 mouse and keyboard. Flashed the latest BIOS, installed Win98 SE on an SD card and all seemed pretty good.
I had some problems installing the Voodoo drivers, but I had to go to sleep 😜

This morning I wanted to continue the installations, but windows popped an error message on startup that it could not find a PS/2 mouse.
I tried another PS/2 mouse, and also a PS/2 to serial adapter (that works with this mouse on an 486) but windows could not detect it.
At this point the keyboard still works, so I went into the BIOS settings to look if there is anything PS/2 related to mess with, but found out that the keyboard would not work in the BIOS menus. It did work outside the BIOS, in windows and DOS (and I was able to press DEL to enter BIOS) but not in the BIOS menus.
After a few more minutes, the keyboard stopped working at all. I can't even press DEL to enter BIOS.

Tried another keyboard, but it does not work as well.
Tried a 2 other USB keyboards, but no go.
Clearing CMOS did not help as well.
I removed all of the cards and devices except the CPU, memory and the S3 card, but nothing changed.

I googled around and found that similar issues were fixed by removing a chip (capacitor?) marked C151 from the board. I had hard time finding it but eventually managed to locate it.. It's really tiny 😀

So, (and sorry for the ramble) any ideas before I power up my soldering iron and give it a go?
What does this capacitor do, and why does it hate me?

I'm not sure if it has anything to do with my issues, but the PSU that I used is a rather new one, that does not have a -5v rail. the motherboard did complain, but I disabled the warning...
I tried using another, older PSU with -5v rail, but my problem remained.

Last edited by anetanel on 2018-10-11, 20:10. Edited 1 time in total.

Reply 1 of 6, by anetanel

User metadata
Rank Member

Well, in the meantime I cleaned the motherboard with water, brush and contact cleaner. I let it dry and flashed with an external USB programmer the previous BIOS version.
The good news is that now the keyboard seems to work as before. The mouse on the other hand, is still not working.

Reply 3 of 6, by anetanel

User metadata
Rank Member

Just in case someone will look for It, I'm posting my journey.

A few weeks later the keyboard died again, so I switched to a USB keyboard. Some days later, the computer would start making clicks from the pc speaker, as if the keyboard is pressed and the buffer fills. Eventually that prevented the computer from booting. It would hang before Windows could come up.
I thought maybe another rinse will bring it back to life for some time but it didn't. So I did what I should have done weeks ago. I de-soldered the C151 thingy near the PS2 connectors, and now the computer boots again and the PS2 mouse and keyboard work again.

Reply 6 of 6, by canthearu

User metadata
Rank Oldbie
_UV_ wrote:

My own experience with 2 such mobos: the problem with PS/2 never occur to me until i flashed latest firmware, 1006 never had such issue. So idk is it hardware problem or something else.

Likely a hardware problem.

Either flexing of the motherboard near the PS2 ports, or electrical damage from repeated plugging of PS/2 devices damages the capacitor and causes signal degredation problems with your PS/2 devices.