VOGONS


First post, by Peter z80.eu

User metadata
Rank Newbie
Rank
Newbie

It's so difficult to find *any* driver for a Windows version newer than Windows 98 (means XP, Vista, Windows 7 etc.).
I've seen there was a Driver for Windows NT 4.0 (see attached file sd_nt4e.zip), but naturally the setup.exe does NOT run on Windows 7 x64 for example.
And unfortunately there is no ".INF" file for the driver files (MKEATAPI.SYS and MKEFPD.SYS), just a setup with a "INI.TXT", which is a bit similar to the searched .INF file, but not recognized for driver installation by the device manager in Windows 7.
I tried the NT 4.0 drivers because the Windows 95/98 drivers are far, far away to be usable for Windows XP or above, but the NT 4.0 drivers (or better Windows 2000 drivers) would be really recognized for a driver installation.
I've also found a 4.5MByte setup archive for Windows XP 32bit, but for sure it does NOT work with Windows 7 x64, too. I can upload this setup also, but I need to use it for x64 Windows 🙁

I even tried to use the DOS (LS120.SYS) driver with a bootable CD which starts DOS 7.1 (from Windows 98), the LS120.SYS does not recognize the drive).
This can be related with the ITE8211 parallel ATA/ATAPI controller I am using, but the card itself recognizes at boot-time the LS-120 drive correctly.

The LS-120 drive is also usable with Windows 7 x64 as a 1.44MB floppy drive (if a floppy disk was inserted at boot-time), but the "Eject" function is missing and you can ONLY use 1.44MB floppy disks, NOT any LS-120 media.

May be a BARTPE Windows XP boot CD would help, too, but for this I might need also XP driver (although some web sites claimed XP has integrated LS-120 drive support even for 120MB diskettes).

Attachments

  • Filename
    sd_nt4e.zip
    File size
    772.21 KiB
    Downloads
    51 downloads
    File license
    Fair use/fair dealing exception

Reply 1 of 6, by Koltoroc

User metadata
Rank Member
Rank
Member

I highly doubt that there even is any 64bit driver for the LS120. The LS120 was long dead commercially when 64bit windows came to market and XP 64 in particular had rerally dire driver support for even common hardware. 32 bit XP has a build in driver I believe, but that is as high as it goes for support. On anything newer it is at best a glorified floppy drive.

Reply 3 of 6, by Thermalwrong

User metadata
Rank Oldbie
Rank
Oldbie

I have my LS120 working just fine in Windows 7 x64 over USB. The driver it's using in computer management is sfloppy.sys. Effectively it just sees it as a floppy drive with max 120MB storage.

The one I use on this PC is a compaq multibay IDE > USB 2.0 converter with an LKM FC33 (Slim LS120) drive in it - with that, I've got the eject option and my LS120 disks read & write just fine. It's seeing it as Floppy (B:) because there's another USB floppy taking up A:.
You're sure the drive is okay? Perhaps try without the parallel adapter?

Reply 4 of 6, by Tetrium

User metadata
Rank l33t++
Rank
l33t++

Iirc, some of the internal models were discontinued from 2k onward and the last version of Windows that still had internal drivers for these drives, was the beta3 version of Windows 2k (could be wrong though, it's been a while since I last messed with these drives).

Some other models should work with newer versions of Windows, but as been mentioned before, the maker was long gone and newer drivers were never made. Or at least not by the original manufacturer.

I was also gonna mention that your best chance of getting it to work, is by using an IDE2USB adapter and connecting the construct by USB to your PC.

I know my external 250MB ZIP drive works perfectly fine using Windows 7. I never tried any of my LS-120 drives in such a new rig though.

Whats missing in your collections?
My retro rigs (old topic)
Interesting Vogons threads (links to Vogonswiki)
Report spammers here!

Reply 5 of 6, by Mr. horse

User metadata
Rank Newbie
Rank
Newbie

I had ls-120 drives in xp64 and vista and windows 7 systems and they all worked out of the box. The problem was finding an ide controler card that works with ls-120 drives.

No sir I don't like it!

Reply 6 of 6, by Peter z80.eu

User metadata
Rank Newbie
Rank
Newbie

But in my PC a Matsushia LS-120 drive connected to an ATAPI Controller (ITE8211 based PCI card) is shown *only* as a floppy drive with 1.44MB capacity. The drive is working fine with 1.44MB disks, but I don't have PC formatted LS-120 media to test them, too. But for sure I can't format Macintosh preformatted 120MB disks in my PC, because the format option for higher capacity is not offered.
May be you can use it also with media which are preformatted PC 120MB disks and the 120MB will show up as capacity if such a media is inserted (which I don't have).
Are you really sure you can format the 120MB media in your Win7 PC ????