VOGONS


Reply 780 of 791, by red-ray

User metadata
Rank Oldbie
Rank
Oldbie
lolo799 wrote on 2021-09-07, 10:26:

With the Test-04 version

After pondering [country] I added some debug code. Using the attached SIV32A V5.61 TAPI-04 test SIV please do:

SIV32A -DBGTAPI -save=[country]=country > SIV_DBGOUT.log | more

and post the SIV_DBGOUT.log file once SIV has stalled or completed.

Attachments

  • [country] debug.png
    Filename
    [country] debug.png
    File size
    2.59 KiB
    Views
    150 views
    File comment
    SIV32A -DBGTAPI -save=[country]=country > SIV_DBGOUT.log | more
    File license
    Public domain
Last edited by red-ray on 2021-09-09, 18:06. Edited 1 time in total.

Reply 781 of 791, by lolo799

User metadata
Rank Oldbie
Rank
Oldbie
red-ray wrote on 2021-09-08, 07:48:

Thank you for running the test, but you did not do Menu->File->Save->Save Selected, deselect [Country] and then press [Start] as I asked, please try again.

I did try the Test-04 before you mention the "save selected" option, haven't turned on the PWS since.

I tried Test-04 on my PWS 600au and [country] worked so I am pondering why it stalled on your system. When it stalled what % CPU time was SIV32A using?

I'll check that next time.

SIV did not work as I hoped as think SIVA32.sys was deleted/went missing from C:\SIV32A\, what happened to it? To check all the files are present look at Menu->Help->SIV Lookup which should report similar to as below, further such as [PCI Bus] reported as follows rather than the PCI Device Information because SIV was unable to find it's driver.

I extracted the content of the .zip you posted in your 2nd post, I doubt I deleted SIV32A.sys but I'll recheck that too.

PCMCIA Sound, Storage & Graphics

Reply 783 of 791, by lolo799

User metadata
Rank Oldbie
Rank
Oldbie

Beta04 results:

siv-beta04-miata.png
Filename
siv-beta04-miata.png
File size
21.06 KiB
Views
108 views
File license
Fair use/fair dealing exception
miata-windows.png
Filename
miata-windows.png
File size
23.3 KiB
Views
108 views
File license
Fair use/fair dealing exception
miata-cache.png
Filename
miata-cache.png
File size
20.29 KiB
Views
108 views
File license
Fair use/fair dealing exception

As you can see it has problems identifying the SIV32A.sys file:

miata-siv-lookup.png
Filename
miata-siv-lookup.png
File size
20.09 KiB
Views
108 views
File license
Fair use/fair dealing exception
miata-siv32-dir.png
Filename
miata-siv32-dir.png
File size
40.49 KiB
Views
108 views
File license
Fair use/fair dealing exception

PCMCIA Sound, Storage & Graphics

Reply 784 of 791, by lolo799

User metadata
Rank Oldbie
Rank
Oldbie

Continued:

miata-gpu.png
Filename
miata-gpu.png
File size
16.64 KiB
Views
105 views
File license
Fair use/fair dealing exception

Got this error a few times while trying the save- selected menu and selecting some network related things on the last column:

siv-beta04-miata-workgrouperror.png
Filename
siv-beta04-miata-workgrouperror.png
File size
12.17 KiB
Views
105 views
File license
Fair use/fair dealing exception

Taskmanager when SIV freezes:

miata-services.png
Filename
miata-services.png
File size
11.63 KiB
Views
105 views
File license
Fair use/fair dealing exception

The logs, with [country] unchecked and the one with the debug output you asked for, you'll be disappointed by the latter...

Attachments

PCMCIA Sound, Storage & Graphics

Reply 785 of 791, by red-ray

User metadata
Rank Oldbie
Rank
Oldbie
lolo799 wrote on 2021-09-12, 11:06:

As you can see it has problems identifying the SIV32A.sys file:

Thank you for running the tests and posting the results.

  1. For some strange/unknown reason the SIV driver does not start, but it did start and run OK in the files you posted on posted on 2021-09-03 @ 16:28. SIVA32.sys should be 174 KB (178,432 bytes), is it? Looking in the save file at Menu->Windows->Services->Control SIV I can see that the SIVDriver service Current State is Stopped when it should be Running, does it start if you press [Start]? It not then try pressing [Delete] and see if this helps (SIV should recreate the service). Deleting C:\WINNT\System32\Drivers\SIVA32.sys may also help get the service running.
  2. The reason that [country] get's stuck seems to be that RasGetCountryInfoA() never returns. AFAIK Windows 2000 reads this information from HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Telephony\Country List, can REGEDIT read that part of the registry OK?
  3. I suspect your system does not have the L3 cache module, is this the case? If so the attached SIV32A 5.61 Zero-05 should allow for this, SIV did not as I thought all PWS systems had a 2MB or 4MB L3 cache.
  4. The error 2184 is down to your network not being correctly configured and you need to fix this. The error is returned by NetServerEnum() which is what the net view command also uses, GIYF.

Attachments

  • Filename
    SIV32A V5.61 Zero-05.zip
    File size
    3.95 MiB
    Downloads
    1 download
    File comment
    Test SIV that should allow for there being no L3 cache
    File license
    Public domain
  • PWS600au System Configuration.png
    Filename
    PWS600au System Configuration.png
    File size
    767.37 KiB
    Views
    94 views
    File comment
    System Configuration repots the L3 Cache Size
    File license
    Public domain

Reply 786 of 791, by lolo799

User metadata
Rank Oldbie
Rank
Oldbie
red-ray wrote on 2021-09-12, 14:24:
Thank you for running the tests and posting the results. […]
Show full quote
lolo799 wrote on 2021-09-12, 11:06:

As you can see it has problems identifying the SIV32A.sys file:

Thank you for running the tests and posting the results.

  1. For some strange/unknown reason the SIV driver does not start, but it did start and run OK in the files you posted on posted on 2021-09-03 @ 16:28. SIVA32.sys should be 174 KB (178,432 bytes), is it? Looking in the save file at Menu->Windows->Services->Control SIV I can see that the SIVDriver service Current State is Stopped when it should be Running, does it start if you press [Start]? It not then try pressing [Delete] and see if this helps (SIV should recreate the service). Deleting C:\WINNT\System32\Drivers\SIVA32.sys may also help get the service running.
  2. The reason that [country] get's stuck seems to be that RasGetCountryInfoA() never returns. AFAIK Windows 2000 reads this information from HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Telephony\Country List, can REGEDIT read that part of the registry OK?
  3. I suspect your system does not have the L3 cache module, is this the case? If so the attached SIV32A 5.61 Zero-05 should allow for this, SIV did not as I thought all PWS systems had a 2MB or 4MB L3 cache.
  4. The error 2184 is down to your network not being correctly configured and you need to fix this. The error is returned by NetServerEnum() which is what the net view command also uses, GIYF.
  1. Pressing start didn't do anything, pressing delete followed by start gave me an SIV32A internal error panel.
    Deleting the file by hand and relaunching SIV32A didn't make it start the service either.
  2. No problems browsing through that part of the registry in regedit, 33 is there.
  3. right, there is no L3 cache module on my machine
  4. is trying to fix it easier reinstalling Windows 2000, I'll decide tomorrow evening

New SIV32A log included, country unchecked.
And for fun tried SIV32L:

SIV32L-miata.png
Filename
SIV32L-miata.png
File size
24.06 KiB
Views
80 views
File license
Fair use/fair dealing exception

Got an exception error message from Windows that resulted in a debug log, forgot to copy it, I can provide it tomorrow if you need it.

Attachments

PCMCIA Sound, Storage & Graphics

Reply 787 of 791, by red-ray

User metadata
Rank Oldbie
Rank
Oldbie
lolo799 wrote on 2021-09-12, 17:10:
[…]
Show full quote
  1. Pressing start didn't do anything, pressing delete followed by start gave me an SIV32A internal error panel. Deleting the file by hand and relaunching SIV32A didn't make it start the service either.
  2. No problems browsing through that part of the registry in regedit, 33 is there.
  3. right, there is no L3 cache module on my machine
  4. is trying to fix it easier reinstalling Windows 2000, I'll decide tomorrow evening
  5. And for fun tried SIV32L got an exception error message from Windows that resulted in a debug log, forgot to copy it, I can provide it tomorrow if you need it.

Thank you for checking things out.

  1. Until the driver starts playing ball SIV will not work as it should. Try exiting SIV then from a command window try sc start SIVDriver, does it start and if not what error get's reported? How about sc delete SIVDriver?
  2. I wonder if this is down to the date being 1995. At a guess the CR3032 needs replacing, does it?
  3. The Zero-05 SIV worked as I hoped it would and no L3 cache was reported.
  4. I suspect doing a clean install would be sensible. AFAIK the RC1 + RC2 releases time out after a while (444 days I think) so when I installed back in 2009 I set the year to 2059, did the install and reverted. Thus far it has not timed out.
  5. The issue is with Menu->Help->SIV Manifest and I see the same on my PWS 600au system, but all is OK on this W10 system and P-II NT4 system. I will try and fix this, but the x32 remote debugger is very slow and a PITA.
Last edited by red-ray on 2021-09-12, 20:54. Edited 1 time in total.

Reply 788 of 791, by lolo799

User metadata
Rank Oldbie
Rank
Oldbie
red-ray wrote on 2021-09-12, 18:51:
Thank you for checking things out. […]
Show full quote

Thank you for checking things out.

  1. Until the driver starts playing ball SIV will not work as it should. Try exiting SIV then from a command window try sc start SIVDriver, does it start and if not what error get's reported? How about sc delete SIVDriver?
  2. I wonder if this is down to the date being 1995. At a guess the CR3032 needs replacing, does it?
  3. The Zero-05 SIV worked as I hoped it would and no L3 cache was reported.
  4. I suspect doing a clean install would be sensible. AFAIK the RC1 + RC2 releases time out after a while (444 days I think) so then I installed back in 2009 I set the year to 2059, did the install and reverted. Thus far it has not timed out.
  5. The issue is with Menu->Help->SIV Manifest and I see the same on my PWS 600au system, but all is OK on this W10 system and P-II NT4 system. I will try and fix this, but the x32 remote debugger is very slow and a PITA.

I'll try starting the service from the command line tomorrow.
The battery is new-ish, but I installed Windows without changing the default date in AlphaBIOS first...I did set today's date earlier and I got a prompt to let me know the system would shut down after an hour, so I reverted back to 1995, stuff to take care before reinstalling.
And trying again to install NT4....

Thanks for your program and your quick updates!

PCMCIA Sound, Storage & Graphics

Reply 789 of 791, by red-ray

User metadata
Rank Oldbie
Rank
Oldbie
lolo799 wrote on 2021-09-12, 19:59:

I'll try starting the service from the command line tomorrow.

OK, I have just uploaded SIV 5.61 Beta-05 which should fix the SIV32L Menu->Help->SIV Manifest issue, does it? Doing [Save Local] worked OK on my PWS 600au, but took much longer than SIV32A and reported less information as several x32 system .DLLs are absent.

I feel it would be sensible to check the event logs to see if there are any events logged about SIVDriver or RAS/RasGetCountryInfo().

I wonder if the strange effects are down to your system only having 128MB of memory. I upgraded my system to have 6 x 256MB MT 18LSDT3272DG-10EB1 which work well.

Reply 790 of 791, by lolo799

User metadata
Rank Oldbie
Rank
Oldbie

Reinstalled Win2k, the network works again!

SIV32A-5.61-BETA05_PWS433.png
Filename
SIV32A-5.61-BETA05_PWS433.png
File size
21.51 KiB
Views
30 views
File license
Public domain
SIV32A-5.61-BETA05_PWS433-Lookup.png
Filename
SIV32A-5.61-BETA05_PWS433-Lookup.png
File size
19.12 KiB
Views
30 views
File license
Public domain
SIV32L-5.61-BETA05-PWS433.png
Filename
SIV32L-5.61-BETA05-PWS433.png
File size
21.56 KiB
Views
30 views
File license
Public domain

The [manifest] issue is solved.

red-ray wrote on 2021-09-13, 07:48:

I wonder if the strange effects are down to your system only having 128MB of memory. I upgraded my system to have 6 x 256MB MT 18LSDT3272DG-10EB1 which work well.

It had no problems at first, just when the network stopped working.
And about the memory, I'm going to get rid of the miata, not going to upgrade it to the max.

Attachments

PCMCIA Sound, Storage & Graphics

Reply 791 of 791, by red-ray

User metadata
Rank Oldbie
Rank
Oldbie
lolo799 wrote on 2021-09-14, 20:05:

Reinstalled Win2k, the network works again!

Thank you, all the strange effects have now gone away 😀 I guess we will never know their root cause and I feel they must have been triggered by the previous installation going wonky.

I spotted that SIV32A failed to report the Matrox MGA-1164SG Mystique RAMDAC Clock and think I have fixed this in SIV32A V5.61 Beta-06, have I?

The display was set to 800 x 600 @ 60Hz, but looking at Menu->Machine->Graphics it looks like it can manage 1280 x 1024 @ 60Hz, can it?

When you generate the new save files may I have both SIV_PWS433.dmi (binary dump of what [Machine] reports) + SIV_PWS433.txt as SIV works better in test mode when I have both.