VOGONS


First post, by respect2759

User metadata
Rank Newbie
Rank
Newbie

Hi guys, I have a 386 40MHZ Soyo 019R1 board. Upgraded the ram from 4 to 8mb, has a Trident 512kb graphics card. It runs DOS and Win 3.1
Last 2-3 days I am trying to add a CD rom. My oldest one is a 16x Mitsumi from 1997. IDE is on IO card, no ports on the board. I am struggling to get it working, system dont recognise it. I dont know the jumper setting of the IO card, found PT 606E and PT 606G manual, I have a PT 606V... Tried the jumper setting of PT 606E which looks exactly like my card. Also tried to disable IDE master and connected the HDD with an old type of cable which has only 2 ends no connector in the middle and DOS just starts up normally, so I think manual is not good for my card or I am just too dumb to figure it out how to get the CD rom recognized by system... Tried master, slave cable select. Tried both ends of cable. Tried to find it in bios... Waiting for some advices or tips 😊

Attachments

  • 13.JPG
    Filename
    13.JPG
    File size
    1.31 MiB
    Views
    446 views
    File license
    Fair use/fair dealing exception
  • 12.JPG
    Filename
    12.JPG
    File size
    1.07 MiB
    Views
    446 views
    File license
    Fair use/fair dealing exception
  • 5.JPG
    Filename
    5.JPG
    File size
    1.22 MiB
    Views
    446 views
    File license
    Fair use/fair dealing exception

Soyo 019R1 AM386DX 40MHz, 8Mb ram, 512Kb Trident 9000 Graphics
S26361-D756-X Intel i486DX 33MHz, 4Mb ram, 512Kb - 1Mb graphics on board

Reply 1 of 13, by derSammler

User metadata
Rank l33t
Rank
l33t

The IDE port probably does not support ATAPI. There's a reason why most CD-ROMs up to 1994 used a proprietary interface (or SCSI). IDE without ATAPI does not support anything else than hard disks.

Reply 2 of 13, by Anonymous Coward

User metadata
Rank l33t
Rank
l33t

Are you loading the CD-ROM drivers?

"Will the highways on the internets become more few?" -Gee Dubya
V'Ger XT|Upgraded AT|Ultimate 386|Super VL/EISA 486|SMP VL/EISA Pentium

Reply 3 of 13, by respect2759

User metadata
Rank Newbie
Rank
Newbie
Anonymous Coward wrote:

Are you loading the CD-ROM drivers?

A CD rom needs drivers?

Soyo 019R1 AM386DX 40MHz, 8Mb ram, 512Kb Trident 9000 Graphics
S26361-D756-X Intel i486DX 33MHz, 4Mb ram, 512Kb - 1Mb graphics on board

Reply 4 of 13, by PTherapist

User metadata
Rank Oldbie
Rank
Oldbie
respect2759 wrote:
Anonymous Coward wrote:

Are you loading the CD-ROM drivers?

A CD rom needs drivers?

Yes.

Try writing a DOS bootdisk that has CD support and boot from that to test if the drive is being detected correctly. Then you'd just need to copy the driver & executable (ie. mscdex) over to your C drive and configure them in config.sys & autoexec.bat

Reply 5 of 13, by Anonymous Coward

User metadata
Rank l33t
Rank
l33t

The windows 98 bootdisk has ATAPI CD-ROM drive support, but all you need is the OAKCDROM.SYS driver and you can stick that in the config.sys of a regular DOS bootdisk.

"Will the highways on the internets become more few?" -Gee Dubya
V'Ger XT|Upgraded AT|Ultimate 386|Super VL/EISA 486|SMP VL/EISA Pentium

Reply 6 of 13, by maxtherabbit

User metadata
Rank Oldbie
Rank
Oldbie

BIOSes in pre pentium systems do not detect CDROMs and, here's the important part - it doesn't matter

The DOS CDROM driver (I recommend VIDE-CDD.SYS) will scan master and slave on both channels and pick up the drive.

The BIOS 100% doesn't matter

Reply 7 of 13, by JudgeMonroe

User metadata
Rank Member
Rank
Member
maxtherabbit wrote:

BIOSes in pre pentium systems do not detect CDROMs and, here's the important part - it doesn't matter

The DOS CDROM driver (I recommend VIDE-CDD.SYS) will scan master and slave on both channels and pick up the drive.

The BIOS 100% doesn't matter

This is correct. ATAPI is implemented by the driver; the BIOS doesn't need to detect the drive. Some drivers support as many as 4 IDE interfaces when looking for an attached drive. The reason SCSI and proprietary interfaces were common in this era was because the systems didn't necessarily even have available IDE ports. ATAPI support in BIOS enabled "detecting" CD-ROMs (mostly cosmetic, since you still need a driver) as a coincidence along with supporting larger modern hard drives.

Reply 8 of 13, by respect2759

User metadata
Rank Newbie
Rank
Newbie

Thanks for advices, I found a soundcard with IDE and its compatible with Mitsumi, so I will try that. I am a hardware guy, so its easier for me this way 😀

Soyo 019R1 AM386DX 40MHz, 8Mb ram, 512Kb Trident 9000 Graphics
S26361-D756-X Intel i486DX 33MHz, 4Mb ram, 512Kb - 1Mb graphics on board

Reply 9 of 13, by GigAHerZ

User metadata
Rank Oldbie
Rank
Oldbie
respect2759 wrote:

Thanks for advices, I found a soundcard with IDE and its compatible with Mitsumi, so I will try that. I am a hardware guy, so its easier for me this way 😀

You still need a driver to be loaded in dos...

"640K ought to be enough for anybody." - And i intend to get every last bit out of it even after loading every damn driver!

Reply 10 of 13, by jesolo

User metadata
Rank Oldbie
Rank
Oldbie
respect2759 wrote:

Thanks for advices, I found a soundcard with IDE and its compatible with Mitsumi, so I will try that. I am a hardware guy, so its easier for me this way 😀

Under DOS, regardless which interface you use, you still require a device driver to recognise the CD-ROM drive.
Since your CD-ROM is from 1997, it most certainly is an IDE interface but, could possibly also be SCSI?.
Just be careful in hooking up your 1997 Mitsumi IDE drive to an older sound card from 1991-1992 that still used the proprietary Mitsumi interface. They are not compatible with each other.

Reply 11 of 13, by Matth79

User metadata
Rank Oldbie
Rank
Oldbie

The separate Panasonic / Sony / Mitsumi interfaces died out with 4x drives, if I recall... connecting an IDE drive to an old style interface may damage one or both.

If the CDROM has options of master/slave it is definitely IDE.
You may have problems with older IDE hard drives which predate standardisation of Master/Slave - some have options for different standards, or require a specific setting for "slave present"

Reply 12 of 13, by respect2759

User metadata
Rank Newbie
Rank
Newbie
Matth79 wrote:

The separate Panasonic / Sony / Mitsumi interfaces died out with 4x drives, if I recall... connecting an IDE drive to an old style interface may damage one or both.

If the CDROM has options of master/slave it is definitely IDE.
You may have problems with older IDE hard drives which predate standardisation of Master/Slave - some have options for different standards, or require a specific setting for "slave present"

The HDD has no jumper settings its an old quantum fireball

Soyo 019R1 AM386DX 40MHz, 8Mb ram, 512Kb Trident 9000 Graphics
S26361-D756-X Intel i486DX 33MHz, 4Mb ram, 512Kb - 1Mb graphics on board

Reply 13 of 13, by Anonymous Coward

User metadata
Rank l33t
Rank
l33t

Err, pretty much all IDE drives had jumper settings as far as I recall. I've owned fireballs, and all of them had at least a jumper to control master/slave.

The separate Panasonic / Sony / Mitsumi interfaces died out with 4x drives, if I recall... connecting an IDE drive to an old style interface may damage one or both.

Pretty much. There were 3X drives, but I think only NEC made them and they were all SCSI. I've only ever seen 1X and 2X drives with a proprietary interface. What really throws me off are those obscure 2X drives that had an ATAPI interface.

"Will the highways on the internets become more few?" -Gee Dubya
V'Ger XT|Upgraded AT|Ultimate 386|Super VL/EISA 486|SMP VL/EISA Pentium