VOGONS


First post, by Xanarki

User metadata
Rank Newbie
Rank
Newbie

I've been working on an old circa 2003 Dell Latitude (Win98 se). Whenever I play a game on it, most of them, will have a second stutter every so often when a new action is performed. Despite having a 1.5ghz cpu and a 32MB ATI card, even older games (pre-2001) have this issue.

After doing some research, it seems the problem is with Dell's hard drives. Apparently, their hard drives by default runs under a "power saving mode" of sorts. Every time a pagefile is accessed, the hard drive "wakes up" and spins.

I saw a suggestion to use a tool called Notebook Hardware Control to disable this, but it doesn't mention supporting Win98, plus, I can find very little info online about it, and don't wanna fry my hard drive because of an unknown program.

Anyone got other advice?

Edit: I also made sure my hard disks were set to "never" turn off in "Power Management Properties" btw.

Reply 1 of 10, by Horun

User metadata
Rank l33t
Rank
l33t

Have you checked the BIOS ? There may be some power saving features you can disable (my old Vostro has a few in BIOS that I disabled)

Hate posting a reply and then have to edit it because it made no sense 😁 First computer was an IBM 3270 workstation with CGA monitor.

Reply 3 of 10, by darry

User metadata
Rank l33t
Rank
l33t

There might be a way to modify the default power management behavior of the drive using hdat2 .

Are you able to try with a non Dell drive ?

Another option is using a Compact Flash card with a passive adapter instead of the original drive . If the BIOS allows bigger drives, an SSD with an adapter could be an option too .

Last edited by Stiletto on 2020-05-12, 04:29. Edited 1 time in total.

Reply 4 of 10, by Xanarki

User metadata
Rank Newbie
Rank
Newbie

I searched within the manual of hdat2 and didn't find any options for altering power saving but maybe it's worded differently?

I haven't tried another hard drive. That was gonna be my last resort, as it took awhile to get my current configuration to be stabilized. Just wanted to note, this particular laptop was shipped with XP, I got 98 on it after using compatible drivers etc.

Reply 5 of 10, by darry

User metadata
Rank l33t
Rank
l33t
Xanarki wrote on 2020-05-10, 20:18:

I searched within the manual of hdat2 and didn't find any options for altering power saving but maybe it's worded differently?

I haven't tried another hard drive. That was gonna be my last resort, as it took awhile to get my current configuration to be stabilized. Just wanted to note, this particular laptop was shipped with XP, I got 98 on it after using compatible drivers etc.

Power management and standby timer are probably what you are looking for .

Reply 7 of 10, by Xanarki

User metadata
Rank Newbie
Rank
Newbie

@darry again thanks for the suggestion. By any chance, do you (or anyone lurking) know how to save this setting? Because after powering down, it reverts to default (enabled). I tried looking in the registry and I also tried modifying/saving the DCO (DCO area is not enabled though so it made no difference).

Reply 8 of 10, by darry

User metadata
Rank l33t
Rank
l33t
Xanarki wrote on 2020-05-12, 01:14:

@darry again thanks for the suggestion. By any chance, do you (or anyone lurking) know how to save this setting? Because after powering down, it reverts to default (enabled). I tried looking in the registry and I also tried modifying/saving the DCO (DCO area is not enabled though so it made no difference).

The only time I used hdat2 to disable APM, it was on a much newer drive . I used the procedure below . I have no idea if it would work on your drive .
https://silentpcreview.com/forums/viewtopic.php?f=7&t=68760

Reply 10 of 10, by darry

User metadata
Rank l33t
Rank
l33t

There also exists an IBM/Hitachi feature tool that does work on some third party drives (if you use an older version of the tool, like the one linked, I believe) .

https://hddguru.com/software/2006.01.20-Hitac … e-Feature-Tool/