First post, by morgul12

User metadata
Rank Newbie


I have built a 486 with a VIP motherboard that has the Opti 82C895 chipset and an Enhanced AMD 486 DX4-100 CPU (8KB write-back cache).

I don't know the brand of the motherboard, but it is quite similar to an Edom MP032 motherboard for which I found a manual and diagram online. The layout is nearly identical, but my board lacks some of the jumpers that the MP032's manual describes (they're *on* my motherboard but are either open solder points or hardwired).

One other difference between the Edom MP032 and my VIP motherboard is the BIOS (MP032 manual mentions that the motherboard has Award BIOS). Well, my motherboard came with Phoenix PCI BIOS, which was an absolute headache; I found an image of MR BIOS for a similar motherboard here on Vogons, burned it onto an EPROM, and have been successfully using it for a few weeks.

Everything is stable; ran the Doom benchmark 15 times in a row with no errors. But I've been doing this with 16MB of RAM.. a couple of Centon 72-pin 8MB SIMMs.

This is where I'm running into trouble. I want to upgrade the RAM on this system. The MP032 manual specifies that the motherboard can handle up to 128MB of RAM (by installing two 16M*36 SIMMs). For reference, the motherboard has 4 30-pin slots and 2 72-pin slots, with a jumper determining whether to use the 30-pin slots + 1 72-pin slot or to use 2 72-pin slots. I've been using only the 72-pin slots with the jumper set appropriately.

So... from what I understand, the manual mentioning "16M*36" indicates that Parity memory is needed. The Centon modules that I've used make no mention of EDO, and I actually made the mistake of buying EDO RAM before I learned what EDO was... and those modules failed in this 486. So I figure that FPM is the way to go.. FPM Parity 72-pin SIMMs.

I ordered 2 64MB FPM Parity modules from MemoryMasters. As far as I know, these are brand new and presumably good quality. I don't have experience with MemoryMasters, but they seem to have a good rep on ebay, anyway.

The sticker says this, specifically: 64MB FPM PARITY SIMM 5V

Unless there's something different about voltage between various SIMMs, I really thought I bought the right modules.

However, whenever I plug either one of these SIMMs into the motherboard (or both at the same time), bad things happen.

1. Inserting only one of these 64MB modules generally seems to work, except that the memory count at POST is 16MB, and that is all that is available when the machine boots. I've run through the Doom benchmark a couple of times without problem.
2. Inserting 2 modules (whether it's both 64MB modules or one 64MB + one 8MB) will result in MR BIOS beeping "LH-LLLL", which means "Memory bank 0 pattern test failure". Pressing the Reset button will actually make the system POST, and while it will perform a memory count, it will never get beyond a total of 16MB. Sometimes the count will fail at 1MB or 4MB, with a message on-screen about bad pattern. The system will then boot and will seem to work with however much RAM was counted during POST (sometimes 1MB, sometimes 4MB, sometimes 16MB).

At any time, I can insert both of the 8MB modules, and the machine will work just fine.

It really just seems like there's something in this motherboard that is limiting the total possible RAM to 16MB, although I wonder why the craziness happens when 2 modules that total > 16 MB are inserted.

I'm attaching pics of the motherboard and the modules (Centon 8MB and MemoryMasters 64MB).

Any insight you have is appreciated. I'm out of ideas and am just thinking that this motherboard doesn't match the Edom MP032 motherboard closely enough to support the same amount of memory (should be 128MB).

However, I also wonder if I made a mistake and ordered the wrong 64MB modules.

Note: I've tried all this, also, with the Phoenix BIOS that came with the motherboard; I get similar results, with error messages during POST about memory tests failing.

Another note: I couldn't figure out, for sure, if my Centon modules are actually 8MB or if they are 16MB. One person online has tried to sell similar modules as 16MB modules. I think they're 8, but it is possible that I'm wrong.

Thank you; I just can't seem to get it right regarding the RAM.


Reply 1 of 4, by weedeewee

User metadata
Rank l33t

your 8MB modules are 8MB, four chips : KM416C1200J-7 Fast Page DRAM, 1MX16, 70ns, CMOS, PDSO42, the other eight are for parity.
your 64MB modules are 64MB, eight chips KM44C16100AK-6 , Fast Page DRAM, 16MX4, 60ns, CMOS, PDSO32, the other four are for parity

Why it doesn't work?
Might just be your bios that doesn't support the module size and wrongly configures the chipset.
Could be the motherboard that isn't wired for the 64MB modules.
From the datasheet https://cdn.datasheetspdf.com/pdf-down/8/2/C/ … pti.pdf#page=34 , It looks like 2x 64MB should be supported.

I guess with the datasheet and some programming/debugging you might be able to figure out if it's the bios, hardware or both... ymmv.

Right to repair is fundamental. You own it, you're allowed to fix it.
How To Ask Questions The Smart Way
Do not ask Why !

Reply 2 of 4, by Ydee

User metadata
Rank Oldbie

Have similar weird problem with memory and OPTI chipset, only I have no parity module Shuttle HOT-419 problem with RAM. Currently I use one doublesided 8MB FPM and 1 singlesided 4MB FPM 72pin module - nothing more cannot my board recognize. Weird:(

Reply 3 of 4, by Deksor

User metadata
Rank l33t

This seems to be your motherboard. Maybe you can find details about your problem in the manual ?

Can you dump the BIOS please ?

Trying to identify old hardware ? Visit The retro web - Project's thread The Retro Web project - a stason.org/TH99 alternative

Reply 4 of 4, by morgul12

User metadata
Rank Newbie

Thank you all for the insights.

So it sounds like I ordered the right type of memory; must be some incompatibility with the motherboard.

Regarding the PCPartner Opti VIP motherboard, that does look like the same layout; in similar fashion to the MP032, this one also has some jumpers that, in mine, were replaced by solder points.. and the BIOS is AMI, while the BIOS that came with my motherboard is Phoenix. Thank for the link to the manual for this one; I had found diagrams of 3 other motherboards with similar layout but not this one. I'll be reading its manual to look for ideas.

I'm wondering whether I could install header pins onto the various solder points and actually use them (ex: JP11, JP12).. not for resolution of this memory problem but to try to make an AMD 5x86-133 to work in this board. I have a 5x86-133 CPU but couldn't even get the system to POST; I eventually switched to a 486DX4-100 and left it there. I'd wondered, though (given that manuals for these motherboards with nearly identical layouts but some extra jumpers for CPU settings while mine has solder points), whether I might get that 5x86-133 to work if I added header pins...

Now I'm distracting myself.. back to the current problem. I've attached the Phoenix BIOS that originally came with my motherboard and the MR BIOS that I found on Vogons (in some past thread) that I have been using in its place.

Thanks again!