VOGONS


First post, by Chadti99

User metadata
Rank Member
Rank
Member

So I discovered that if I use the BIOS from a Biostar 8443 in a Gigabyte GA486AM it works quite well and enables Bus Mastering for PCI, perfect for a Rendition Verite and Vquake. I assume it works almost without issue as both motherboards use the UMC chipset.

One problem however is that it won't enable an IRQ for a VGA adapter, which prevents me from using a Riva 128. I have the hardware to read and write the BIOS EEPROM's and was curious if anyone could give any pointers on how to try modding either the original GA486AM bios to enable Bus Mastering or mod the 8443 Bios to assign a VGA IRQ? I think the former might be easier.

Also curious if either could be modded to support larger hard drives?

Thanks for any help!

Last edited by Chadti99 on 2021-07-22, 07:40. Edited 1 time in total.

Reply 3 of 9, by jakethompson1

User metadata
Rank Oldbie
Rank
Oldbie
Chadti99 wrote on 2021-07-21, 00:00:

Thanks, I’ll check this out. Can you elaborate on what you think might be happening between these two different bios files?

Assuming you already know about MODBIN?
And it's a deeper issue than enabling Assign IRQ for VGA under PCI/green setup (disabled by default in the UUD bios)?

Reply 4 of 9, by Chadti99

User metadata
Rank Member
Rank
Member
jakethompson1 wrote on 2021-07-21, 00:21:
Chadti99 wrote on 2021-07-21, 00:00:

Thanks, I’ll check this out. Can you elaborate on what you think might be happening between these two different bios files?

Assuming you already know about MODBIN?
And it's a deeper issue than enabling Assign IRQ for VGA under PCI/green setup (disabled by default in the UUD bios)?

I’ve heard mention of MODBIN so def need to check this out. But yah while using the Biostar BIOS in the Gigabyte MOBO, having “Assign IRQ” enabled doesn’t seem to be doing its job. Maybe due to a slight difference in chipset model?

Reply 5 of 9, by jakethompson1

User metadata
Rank Oldbie
Rank
Oldbie
Chadti99 wrote on 2021-07-21, 00:28:
jakethompson1 wrote on 2021-07-21, 00:21:
Chadti99 wrote on 2021-07-21, 00:00:

Thanks, I’ll check this out. Can you elaborate on what you think might be happening between these two different bios files?

Assuming you already know about MODBIN?
And it's a deeper issue than enabling Assign IRQ for VGA under PCI/green setup (disabled by default in the UUD bios)?

I’ve heard mention of MODBIN so def need to check this out. But yah while using the Biostar BIOS in the Gigabyte MOBO, having “Assign IRQ” enabled doesn’t seem to be doing its job. Maybe due to a slight difference in chipset model?

Modbin will let you un-hide options in BIOS setup. I assume you haven't narrowed it down to any particular option for this PCI DMA issue. In addition, there are "chipset registers default" which appear to differ between the two BIOSes:

Attachments

  • Filename
    chipsetB.png
    File size
    11.15 KiB
    Downloads
    No downloads
    File license
    Public domain
  • Filename
    chipsetA.png
    File size
    11.18 KiB
    Downloads
    No downloads
    File license
    Public domain

Reply 6 of 9, by Chadti99

User metadata
Rank Member
Rank
Member
jakethompson1 wrote on 2021-07-21, 00:50:
Chadti99 wrote on 2021-07-21, 00:28:
jakethompson1 wrote on 2021-07-21, 00:21:

Assuming you already know about MODBIN?
And it's a deeper issue than enabling Assign IRQ for VGA under PCI/green setup (disabled by default in the UUD bios)?

I’ve heard mention of MODBIN so def need to check this out. But yah while using the Biostar BIOS in the Gigabyte MOBO, having “Assign IRQ” enabled doesn’t seem to be doing its job. Maybe due to a slight difference in chipset model?

Modbin will let you un-hide options in BIOS setup. I assume you haven't narrowed it down to any particular option for this PCI DMA issue. In addition, there are "chipset registers default" which appear to differ between the two BIOSes:

Thanks for the register comparison! I tried adjusting all the values to match the Biostar bios but still no dice on bus master dma. I have found that I can enable Bus Mastering on the VGA card via TweakBios, and it works. So it’s def an option that should be editable in the bios file but I don’t see anything obvious for changing bus mastering within modbin.

Attachments

Reply 7 of 9, by Chadti99

User metadata
Rank Member
Rank
Member
maxtherabbit wrote on 2021-07-20, 16:51:

You need to use AWDBEDIT to manually edit the IRQ routing table

Or you could just move the graphics card to another slot

When I open the bios file in AWDBEDIT it didn’t seem to recognize much if anything to edit. I’ve also read you can’t save settings with AWDBEDIT, but maybe this info is outdated? Also I’ve tried moving the card to another slot as suggested but no luck.

Reply 8 of 9, by maxtherabbit

User metadata
Rank Oldbie
Rank
Oldbie
Chadti99 wrote on 2021-07-22, 07:43:
maxtherabbit wrote on 2021-07-20, 16:51:

You need to use AWDBEDIT to manually edit the IRQ routing table

Or you could just move the graphics card to another slot

When I open the bios file in AWDBEDIT it didn’t seem to recognize much if anything to edit. I’ve also read you can’t save settings with AWDBEDIT, but maybe this info is outdated? Also I’ve tried moving the card to another slot as suggested but no luck.

Well in reading your subsequent posts, I'm thinking my advice there was off target. I was operating under the assumption that the PCI slots' physical wiring layout on your board did not match the IRQ routing table from the donor BIOS. But it appears instead that your donor BIOS is just deliberately not assigning an IRQ to video card regardless of slot. So forget what I said 🤣.

Reply 9 of 9, by Chadti99

User metadata
Rank Member
Rank
Member
maxtherabbit wrote on 2021-07-22, 14:34:
Chadti99 wrote on 2021-07-22, 07:43:
maxtherabbit wrote on 2021-07-20, 16:51:

You need to use AWDBEDIT to manually edit the IRQ routing table

Or you could just move the graphics card to another slot

When I open the bios file in AWDBEDIT it didn’t seem to recognize much if anything to edit. I’ve also read you can’t save settings with AWDBEDIT, but maybe this info is outdated? Also I’ve tried moving the card to another slot as suggested but no luck.

Well in reading your subsequent posts, I'm thinking my advice there was off target. I was operating under the assumption that the PCI slots' physical wiring layout on your board did not match the IRQ routing table from the donor BIOS. But it appears instead that your donor BIOS is just deliberately not assigning an IRQ to video card regardless of slot. So forget what I said 🤣.

No worries, I was able to open and modify the Biostar bios with AWDBEDIT, make changes, and save, which is nice. It won’t open the Gigabyte BIOS file though. I tried changing some IRQ’s on the routing table but so far no luck.