First post, by GigAHerZ

User metadata
Rank Oldbie

Hi all!

I've been fighting with my Chaintech 6AIA2 board, more specifically with its bios.
Board info and 2 official bioses are available in UltimateRetro: https://www.ultimateretro.net/en/motherboards/8200
Everything i did, was based on the newer, A26 bios. (working well in un-modified state)

This board currently only works with Celeron 433 cpu that i have. I also have few pentium 3 cpus both with 66 and with 133MHz FSB and one celeron with 11.5x66 speed. None of them boot at all. Debug card shows the motherboard completely dead.
I've tried different SDRAMs, too - from 32MB single sided to 256MB double-sided - no effect.

It also has a jumper for switching between 66MHz and 100MHz fsb. (Bios overclocking is derived from it. In case of 66MHz, i can go up to 83MHz) When i set that to 100MHz, the board, again, is completely dead.
I have confirmed the board working with 100MHz FSB on my 433 celeron under Win98 using SetFSB and CPUID. So my hardware is capable - there must be something going on with bios.

So i started my investigations and found few ways i should be able to modify bios in various ways.

CBROM and related stuff (rom.by)
I tried many-many versions of cbrom and the 3 versions of bios patchers from rom.by webpage. No matter what i did, any modified bios will make the board un-bootable. The board does one long beep and then indefinite amount of short beeps. Basically yelling at me that i have given some crap to this board. 😁
In the end, i tried the bios patcher with manual options and i only let it do one thing - switch default answer from "N" to "Y" when exiting bios. It seemed to be the smallest tinyest thing i could try - and the board yelled at me.

NB! When i tried to open modified bios with awdbedit (more on that later), it yelled at me as well that it can not recognize some stuff anymore. When looking into it, i saw the decompression module missing. (so does cbrom make the bios somewhat incompatible with awdbedit?)

So it seems the cbrom path was not working.

I tried this one as well - theoretically i could switch out cpu microcode and other stuff with that program too and i would not need cbrom.
But unfortunately, that story will be short - anything i would do, the board will yell at my modified bios. For the last test, i just changed the bios string slightly, and even that made it "unedible" for the board.
So that's also not working...

I've been playing around with modbios earlier on pentium 1 era machines. I gave it a go and it was able to read the bios.
So i changed the bios string and tried it, and can you imagine - it works! And i do see the changed bios string during boot time.
Unfortunately, i have no knowledge of modbios being able to update cpu microcode, update bios to support larger harddrives, etc. So it doesn't really fulfill my requirements. But i can at least confirm, that i could use one program, to modify one tiny thing and actually boot it.


Now, why i'm writing this here? I hope some of you will recognize a flaw i've done and can help me. 😀
My goal would be basically to achieve pretty much the same things as the bios patchers do from rom.by website. (with the hope that somehow those patches will make my 66MHz/100MHz jumper setting and other CPUs also work)

So please, ask additional information for what i might have missed in description and maybe, in the end, we can have a "Ultimate Bios" ready and available in Ultimate Retro website as well. 😀

"640K ought to be enough for anybody." - And i intend to get every last bit out of it even after loading every damn driver!

Reply 1 of 3, by Tetrium

User metadata
Rank l33t++

You could try modding the BIOS file using either AWDBEDIT or CBROM, then opening the modded file with MODBIOS, make some trivial change and see if MODBIOS can open + save the file.
Then try that BIOS file if it worked.

Just ftr, I have basically no experience using these programs (or it's been so long that I've forgotten) but this would be one of the first things that I would try.

Whats missing in your collections?
My retro rigs (old topic)
Interesting Vogons threads (links to Vogonswiki)
Report spammers here!

Reply 2 of 3, by Tzk

User metadata
Rank Newbie

I got a bit of general advice for Award bios modding. For AwardMedallion v6.0PG bios files (for ex. Asus A7N8X) i use ModBin v2.01.02 and cbrom v1.98 in CMD of a WinXP VM. That works well. AWDBEdit does also run on W10 x64, so i use it there.

1. If you use AWDBEdit, never save a bios file with it. Only use it to view and extract bios files and modules. I found that the save function is broken for Award 6.0 bios files.
2. Never use "save" in Modbin, always "save as" a new file and keep the filename short (8+3 chars max).
3. If you want to replace a module with cbrom, always extract+release all following modules first, swap the module you want/need and re-add all following modules in the same order. If you need to do this several times for a given bios, create yourself a batch file. Saves a lot of typing.
4. you can use Modbin to change for example the POST message as smallest change possible. If that works, you can work your way from there. Also extracting and re-adding the same modules with cbrom shouldn't break the bios, so that's another test that your workflow is correct.

rom.by usually adds a whole additional module to the bios (usually oem7 module) and sideloads it during POST. This is a bit different to swapping or modding the existing modules. Also not every bios got a microcode module (for ex. Athlon XP usually hasn't), so you'd have to check that first.

I haven't had a look at the bios in question yet, but feel free to ask further questions 😀 I mainly mod v6.0 files, but the workflow for v4.51 is quite similar.

Reply 3 of 3, by GigAHerZ

User metadata
Rank Oldbie

Necroware made a video of successfully using the batcher.
So i used the same CBROM version - 2.07.

And now i have patched bios, too: Re: Ultimate Retro board submissions thread: suggest board edits and/or add new boards here

Unfortunately, the 66MHz/100MHz jumper is still making the machine dead when at 100MHz setting, and all slightly newer socket 370 CPUs i have, also still render the machine dead. (For example Celeron 667/128/66) Only my good old Celeron 433 boots with this machine... 🙁

"640K ought to be enough for anybody." - And i intend to get every last bit out of it even after loading every damn driver!