VOGONS

Common searches


Game Port OS Compatibility

Topic actions

First post, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

This thread is for discussion of game port OS compatibility.
Only ports which have been tested on the OS should be posted, system requirements are not acceptable.

Arx Fatalis

Arx Libertatis
(XP32) v1.1.2

BattleZone II

Unofficial patch
(2000) v1.3.5.1
(XP32) v1.3.6.2
(2000 BWC - Vista32) v1.3.7b131

Blood

BuildGDX
(2000BWC - XP32) v1.15

nBlood
(XP32) v20210314-12176

Raze
(Vista64) v0.9.1

Daggerfall

Daggerfall Unity
(7+)

Descent 1 and 2

D2X-XL
(2000 BWC) v1.18.74

DXX-Rebirth
(95) DXX-Retro v14x5
(2000 BWC - XP32 OneCoreAPI - Vista32) v0.60 weekly 11-08-17
(XP32) 0.58.1
(XP64) v20200116

Diablo

Devilution
(XP32) v0.10.0

DevilutionX
(XP32) v1.1.0

Diablo 1 HD Mod
(2000 BWC - XP32) v1.045

Project Tchenobog
(2000 BWC - XP32) v0.2.0e

The Hell
(2000) v1.205d
(2000 BWC - XP32) v1.235

Doom

BOOM
(DOS) v2.02

Chocolate Doom
(98SE-ME) v2.3.0
(XP32+) v3.0.1
Latest SVN should work last I tested was 10-17-2020
http://latest.chocolate-doom.org/

Crispy Doom
http://latest.chocolate-doom.org/
(2000BWC) v4.3
(XP32+) - v5.1.0.1
Latest SVN should work last I tested was 03-02-2021

Doom+
(DOS) v1.92.2

Doom 3D
(2000) v1.16

Doom Legacy
(DOS) v1.40
(980ME) v1.48.4

Doomsday
(2000) v1.9.0 beta 6
(2000BWC) v1.14.5
Add the following to C:\WINNT\system32\drivers\etc
127.0.0.1 www.dengine.net
(XP32+) v1.15.8
https://sourceforge.net/projects/deng/files/D … 0Engine/1.15.8/
To use this version you'll need to change the Major and Minor versions in the executables to a lower value. Just set them to "4".
(Vista32+) v2.0.3

Doom Retro (XP32+) - v4.0.4
https://www.doomretro.com/

Eternity
(DOS) v3.39.20-7
(XP32+) - v4.02.00-108
Latest SVN should work last I tested was v4.02.00-108
https://devbuilds.drdteam.org/eternity/

FastDoom
https://github.com/viti95/FastDoom/releases
(DOS) v0.666

Gzdoom
https://zdoom.org/downloads
(XP32+) v4.1.3
(Vista32+) v4.4.2
(Vista64) v4.5.0

LZDoom
(2000 BWC - XP32+) v3.87a

MBF
(DOS) v2.04
Doom 'MBF' for DOS, Maintenance release 2.04

PrBoom
(2000) v2.5.0

PrBoom+
https://github.com/coelckers/prboom-plus/releases
(2000) v2.5.1.4
(XP32+) v2.5.1.7
Latest SVN should work but last I tested was v2.5.17
(Vista32+) v2.6

Rude
https://github.com/drfrag666/RUDE/releases
(2000) v2.5.0c
(XP32+) v3.1.0pre11

SMMU
(DOS) v3.30
(Win??)

Vavoom
(2000) v1.33
(DOS) v1.26

ZDoom
(DOS) v1.17c

ZDoom-CL
(95+) v2.1.4a

ZDoom-LE
(95+) v2.8.1f

Doom 3

dhewm3
(XP32) v1.5.1pre1
(Vista32) v1.5.1 RC2

fhDoom
(2000 BWC - XP32) v1.5.2-1414

Deus Ex

GMDX
(2000) v9.0.2
(2000 BWC - XP32) v9.0.3

Duke Nukem

ReDuke
(2000) vBeta4

Duke Nukem 3D

BuildEngineGDX
(2000BWC-XP32) v1.15

eduke32 for DOS
(DOS) v20191025 - Doesn't work.....

eduke32 for Win95
(95) eDuke32 for Win95

eduke32
(2000 - 2000BWC) v20100425-1623
(XP32/64) v20210221-9314

ProASM
(XP32/64) v4.3.2

Raze
(XP64) v0.6.0 - May work with OneCoreAPI - UNTESTED
(Vista64) v0.9.0

Dungeon Keeper

KeeperFX Unofficial
(2000) v0.4.7

Grand Theft Auto 3

re3
(XP32) - Change major and minor subsystem to "4"

Grand Theft Auto Vice City

reVC
(XP32) - Change major and minor subsystem to "4"

Grim Fangango

ResidualVM
(2000 BWC - XP32) SVN from 10-8-2020 works

Heretic

Chocolate Heretic
(98SE-ME) v2.3.0
(XP32) v3.0.1

Hexen

Chocolate Hexen
(98SE-ME) v2.3.0
(XP32) v3.0.1

Hexen II

Hexen II Hammer of Thyrion
(DOS) v1.5.9
(2000) v1.5.9

Quake

Dark Places
(2000) v20110328 beta2 works
(2000 BWC) Unknown how this is versioned. Version from 5-13-2014 works
(XP32+) Unknown how this is versioned. Version from 12-22-2018 works

DirectQ
(2000) v1.8.666b
(2000BWC - XP32+) v1.9

Engoo
(DOS) v2.05
(2000) v2.77

FTEQW
(2000 BWC - XP32+) v5259

Mark V
(2000BWC - XP32+) v1.99

ProQuake 4
(2000) v4.93

QBISM
(DOS)
Re: A modern DOS Quake engine by Qbism
(2000) v288

QuakeWorld for DOS
(DOS) Version dated 10-29-2016 works
(200) Version dated 10-29-2016 works

Quakespasm
(2000) v0.93.2

Quakespasm spiked
(XP32+) v0.93.2ish

vkQuake
(VISTA32) v1.04.1

Quake 2

AprQ2
(2000) v1.211

Berserker Quake 2
(XP32) v146
(Vista32) v147

EGL
(2000) v0.3.1

KMQuake2
(2000) v020_update6
(2000 BWC - XP32) v20_update8_nightly_2020-05-06

Q2DOS
(DOS) version from 11-25-2016 works

Quake2XP
(2000 BWC) quake2xppr8b1
(XP32) v1.26.3 beta 4
This will also work with the textures from v1.26.6
(Vista32) v1269 update 1

Quake 2 Evolved
(2000) v0.40

Quake II RTX
(XP 64) v1.3.0

Yamagi
(2000 BWC - XP32) v5.11
(XP32) v7.30
(Vista32) v7.45

Quake 3

ioQuake3
(2000) v1.35_SVN1286-2.1.x86
(2000BWC) v1.36-3.1
(XP32) version from 6-22-2017 works
(764) Version from 4-14-2020 works

Q3bers
(2000BWC - XP32) v20100926

Quake 3 1.32e
(2000) v20200415

Spearmint
(XP32) v1.0.3

Return to Castle Wolfenstein

iortcw
(2000BWC) v1.42
(XP32) v1.51c

Shadow Warrior

BuildEngineGDX
(2000BWC - XP32) v1.15

eduke32
(XP32) v20210221-9314

Jonof
(2000) v20051009

ProASM
(2000) v4.32
(2000BWC) v4.33b3

Strife

Chocolate Strife
(98SE-ME) v2.3.0
(XP32) v3.0.1

System Shock

Shockolate
(XP32) 0.5.10.4
(Vista32) v0.8.2

Thief 1

TFIX
(2000 BWC - XP32) v1.27

Thief 2

T2Fix
(2000 BWC - XP32) v1.27d
For 2000 BWC and XP32 you'll need to replace ncscript.osm with the v1.26 version.

Thief Deadly Shadows

Sneaky Upgrade
(2000 BWC - XP32) v1.1.6
(Vista32) v1.1.10

Wolfenstein 3D

ECWOLF
(2000) v1.3.3 legacy
(2000BWC - XP32) v1.3.3

Mac-enstein
(2000) v2.03

Wolf4SDL
(2000) v1.7

Last edited by DosFreak on 2021-04-02, 22:40. Edited 5 times in total.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 1 of 20, by hail-to-the-ryzen

User metadata
Rank Member
Rank
Member

OpenTTD has versions that work in early Windows, possibly 9x, such as v1.22 or v1.23. Hint for custom build:
./configure --without-threads --disable-unicode --disable-network --disable-assert --enable-strip --without-lzma --without-liblzo2

It is possible to backport OpenTTD v1.33 to Win95.

Hexen and Heretic will run in the early versions of ZDoom, too.

Here is another game that is compatible with DOS, but the special levels and scenes with moving parts will likely require a P2 cpu or higher:
https://github.com/nextvolume/Sonic-1-2-2013- … tree/nextvolume

Reply 2 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

vkQuake2 - Likely vista+ but need to test
https://github.com/kondrak/vkQuake2/releases

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 3 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

info for lzdoom and windows xp
https://forum.zdoom.org/viewtopic.php?f=231&t … rt=525#p1179451

I've released 3.87c to fix a few serious bugs (mainly the GL graphic glitches with the partial invisibility effect and weapon bob jittering) . I've included the widescreen graphics by Nash this time. And i've also replaced the included 32 bit OpenAL32.dll with a custom 1.20.1 build so to run LZDoom on Windows XP you'd need replace the dll with the older 1.19 version.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 4 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

gzdoom vintage (OpenGL 2.0) Likely XP+
https://devbuilds.drdteam.org/gzdoom-vintage/

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 5 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

https://github.com/NY00123/refkeen

Reflection Keen is a project consisting of source ports of the following titles, all being inspired by the Chocolate Doom port:

Keen Dreams.
Catacomb 3-D (The Descent) and The Catacomb Adventure Series.
Wolfenstein 3D, Spear of Destiny and Super 3-D Noah's Ark (DOS version).

Possibly XP+

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 6 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Haven't tested Gemrb on 9x but noticed the latest released version mentions 9x compatibility was dropped.

Started going through the nightlies and noticed the first mention in "NEWS" was with:
gemrb-win32-250464b.zip 5-11-2020

Which likely means someone reported it as not working. If latest version doesn't work then start from there backwards to identify last working version.

https://sourceforge.net/projects/gemrb/files/Releases/0.8.7/

Release notes […]
Show full quote

Release notes

A C++11 compatible compiler is now required.

Windows 9x compatibility was dropped to enable modern unicode support on Windows.

Throne of Bhaal saves in the mpsave/ folder are automatically migrated back to save/ on startup.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 7 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Modern Ports (Eng's) for Classic Games

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 8 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

vkquake2 1.5.8 works on XP w/OGL and software renderers

https://github.com/kondrak/vkQuake2/releases
Change major and minor subsystem version to 4 and 0

Woof! 6.2.0 works on XP
https://github.com/fabiangreffrath/woof

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 9 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

winevdm
7-13-2021
https://ci.appveyor.com/project/otya128/winev … yb4rf/artifacts
Appears to work on Windows XP

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 10 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Qemu 2.10.1 for Windows XP
https://github.com/tumagonx/XPitory/tree/mast … tatic_port/qemu

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 11 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

GMDX vRSD works on XP
https://rosodudemods.wordpress.com/deus-ex/
Change major and minor subsystem version to 4 and 0

Hmmm may need to change thread title

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 12 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Did some testing on 98 today:

Doom ports
Chocolate Doom 2.3.0
Crispy Doom 3.2
Doom 3D 1.16
Doom Legacy 1.48.8
Doomsday 1.8.6 (May be able to use 1.9 betas but frontend is not working)
Prboom 2.5.0
Prboom+ 2.5.1.4
Rude 2.5.0c
Vavoom 1.27.1
ZDoomLE 2.8.3a
ZDoom32 2.8.5c

If you want the most recently updated ports then Doom Legacy, Rude, ZDoomLE and ZDoom32 are it.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 13 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

More 98 testing

Quake

DarkPlaces darkplacesengine20110328beta2
Engoo 2.77b
ProQuake 4.93
Qbism Super8 Build 288
Quakespasm 0.90.1
Quakeworld for DOS

Quake 2

APRQ2 1.211
KMQUAKE2 v0.20 with update 6

Quake 3

ioquake3-1.35_SVN1286-2.1.x86

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 14 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

98SE-ME w/ KernelEX

Doom

Chocolate Doom
chocolate-doom-20210726-win32

Crispy Doom
crispy-doom-20210725-win32

PrBoom+
prboom-plus-2.5.1.7um-win32

Rude
RUDE-3.1.0pre-win32

Woof!
Woof-6.2.0-win32

Quake

Dark Places
darkplacesengine20140513

FTEQW v5259

Quakespasm Spiked
Git Date: 2021-07-08

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 15 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

98SE-ME w/KernelEX

BuildGDX 1.15

Requires:
psabi3b.7z (replace existing dll in kernelex folder)
Oracle Java
jre-8u231-windows-i586
or
Azule Java
zulu8.54.0.21-ca-jre8.0.292-win_i686

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 16 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

https://msfn.org/board/topic/183038-gzdoom-fo … comment-1206461

Doom ports

DOS
eternity-dos-v33920-7
FastDoom 0.8.7
MBF 2.04

95
Zdoom LE 2.8.1f

98SE-ME
Chocolate Doom 2.3.0
Crispy Doom 3.2
Doom Legacy 1.48.8
PrBoom+ 2.5.1.4
Rude 2.5.0c
ZDoom32 2.8.6

98SE-ME (KernelEX)
chocolate-doom-20210726-win32
crispy-doom-20210725-win32
PrBoom+ 2.5.1.7um
Rude 3.1.0pre
Woof! 6.2.0

2000 (BWC)
Crispy Doom 4.3

2000 (BWC) - XP 32
LZDoom 3.88a 8-8-2021 (change major version)

XP 32bit
chocolate-doom-20211019-win32
crispy-doom-20211019-win32
Doom Retro 4.3 10-15-2021
Eternity-x86-4.03.00-pre-412-g47dcc309 10-18-2021
gzdoom 4.1.3 6-8-2019
PrBoom+ 2.5.1.7um 6-16-2019
Rude 3.1.0pre11 10-31-2020
Woof! 7.0.0 9-27-2021
dsda-doom 0.21.3 8-30-2021

Vista 32bit
gzdoom 4.4.2
k8vavoom 4.1
PrBoom+ 2.6um

Vista 64bit
gzdoom 4.5.0

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 17 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

OpenTTD
9x 1.8.0
XP 1.10.3
Vista+ 12.0

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 18 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Noticed this the other day https://www.doomworld.com/forum/topic/124318- … d-and-packaged/
which got me thinking about if it would make sense for a vogons specific account on github or similar to maintain compatibility with older systems
Problem is it's pretty daunting. Mingw-w64 default binaries can target NT 3.51+ w/ Pentium Pro+ as long as it's Win32 thread. If you use posix then it's XP+ but likely would need to revert a commit for XP support so Vista/7+ with latest binaries.
Obviously a VM environment that could both use the latest mingw-w64 and VS as well as older versions would be preferred, the same thing goes for dependencies.
For the older versions of VS the free versions would have to be used.
For anything not mingw-w64 or VS then those would have to be free as well although possibly the VMs could be duplicated for home use and then non-free compilers could be used to compile those......
Of course this assumes the only issue is the compiler and dependencies breaking things and not the application code itself that may requiresc hanges for that specific OS.
Likely best bet would to just be to identify last known good change for each project and then compile the latest version compatible with each OS and then if anyone is bored attempt to figure out why the newer versions don't work.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 19 of 20, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

New DOS port for Doom. Sounds fishy 😉

COD
https://www.doomworld.com/forum/topic/124850- … cod10src-based/

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline