VOGONS


First post, by holmes

User metadata
Rank Newbie
Rank
Newbie

Hi,

I use DgVoodoo 2.72 to play Battle Gear 4 with Teknoparrot. The graphic improvement is amazing and I am very grateful for it.
I have a problem though: the radar showing the location of the other cars is not displayed.

The problem exists even if the resolution is unforced.

Is there a solution?

Thanks,

Attachments

  • param2.PNG
    Filename
    param2.PNG
    File size
    39.54 KiB
    Views
    425 views
    File license
    Fair use/fair dealing exception
  • param1.PNG
    Filename
    param1.PNG
    File size
    40.02 KiB
    Views
    425 views
    File license
    Fair use/fair dealing exception
  • original.png
    Filename
    original.png
    File size
    81.3 KiB
    Views
    425 views
    File license
    Fair use/fair dealing exception
  • dgvoodoo.png
    Filename
    dgvoodoo.png
    File size
    37.88 KiB
    Views
    425 views
    File license
    Fair use/fair dealing exception

Reply 1 of 10, by Dege

User metadata
Rank l33t
Rank
l33t

Hi,

Finally I figured out how to run this game. I recommend the latest dgVoodoo version (2.75.1). Set output API to D3D12 in the dgVoodoo config. With D3D11 (which is the default) it indeed has rendering glitches, I'll try to fix them.
Also, use the 'GF 5700 Ultra' virtual card otherwise this game seems to have the same rendering issue as an other racing game... (I forgot the name).

Reply 2 of 10, by TheFellowJasper

User metadata
Rank Newbie
Rank
Newbie

I want to chime in that sadly DX12 doesn't do the job. Additionaly 2.73 is the last that works for me. Any newer version has various bugs and terrible performance in race (25fps) and stops rendering 3D after view goes to your car on DX11, same on DX12. on 2.73 DX11 works (with exception of minimap) and DX12 has no map and 3D is pixelated (which actually is the thing if you try to play this game without DgVoodoo, at least on NVIDIA gpu's). I'm playing on GTX 1060 and WIN10 (plus I've switched the game to professional mode where the game is displayed in 1360x768 insted of 800x600 plus gameplay additions (clutch,h-shifter etc.)). Thats with FX5700 Ultra (although it fixed weird thing with loading loop when using Radeon 8500)

PS. If this helps you, original cab uses either 9600 xt or 9800 pro (Standard and Professional respectively)

Attachments

  • 2_73 DX12.png
    Filename
    2_73 DX12.png
    File size
    790.11 KiB
    Views
    322 views
    File license
    Fair use/fair dealing exception
  • 2_73 DX11.png
    Filename
    2_73 DX11.png
    File size
    1.03 MiB
    Views
    322 views
    File license
    Fair use/fair dealing exception

Reply 3 of 10, by Dege

User metadata
Rank l33t
Rank
l33t

I can only run this game through Teknoparrot, and aside from the D3D11 problem I mentioned, I don't experience bad performance and the things you described.

Is there a way/patch to run this game "natively" on Win10? It gets stuck for me right at the startup.

Reply 4 of 10, by TheFellowJasper

User metadata
Rank Newbie
Rank
Newbie

I actually run this game through TP too, and mayby since you dont experience all those problems, mayby they are isolated to game running in Pro Mode. You can switch your game to it by checking 'General - Professional Mode Enable' in Game option in Teknoparrot, it will exit after a moment (IIRC) and then once you start it again it should be running in Pro mode.
Speaking of game running natively, Teknoparrot is needed since it takes cares of fixing some problems (binding 5.1 to stereo on 2 speaker setups, etc.) and emulates JVS I/O needed to control the game. Do you have some sort of error or just black screen?

Reply 6 of 10, by TheFellowJasper

User metadata
Rank Newbie
Rank
Newbie

Ah, forgot that non-Tuned version exists. Not sure what version OP was using but I'm using Tuned. Techwise shoudn't be that much different from non-Tuned (with biggest thing being probably that Professional Mode). Have you tried disabling IntroFix (I assume you tried Windowed setting)?Alternatively, there might be also something wrong with your dump (these arcade game tend to have botched dumps still floating around) Forgot that some games will be stuck at black screen awaiting connection from JVS I/O board, it's most likely the thing here since my game freezes too if I just try to launch it without TP (since it emulates JVS board, its boots and plays normaly)

PS. If you use discord then there's also server hosted by this game community: https://discord.gg/RPzeVqg

Reply 7 of 10, by TheFellowJasper

User metadata
Rank Newbie
Rank
Newbie

Small correction to what I've said ealier, some TTX+ cabs used 7600 gs instead of AMD cards so most likely not an issue with AMD shenanigans.

About running the game natively (as in, launching game directly through game.exe), you could in theory use JConfig, although when the game is run through it, it doesn't set the window to 1360x768 and many 2d elements render as if it was actual resolution when running in Pro Mode (called High resolution there). It's in attachments if you want to try it (High resolution setting sets Professional mode in BG4 Tuned, I think it also only works with BG4 Tuned, not sure)

Additionally, on 2.73, when using DX12 and forcing resolution to something other than 1360x768, the game actually starts to render 3D in that resolution instead of staying at 800x600 (still no minimap however)

Attachments

  • Filename
    BattleGear4_20201212.rar
    File size
    1.58 MiB
    Downloads
    6 downloads
    File license
    Fair use/fair dealing exception

Reply 8 of 10, by holmes

User metadata
Rank Newbie
Rank
Newbie

Indeed my post was about Battle 4 Tuned (I realized I did not mention "Tuned" sorry about that). I also have trouble with recent versions of DgVoodoo.
2.64 is working but not 2.74 or 75. I did not test versions in between .
So no chance to get the mini map? A pity...

Reply 9 of 10, by Dege

User metadata
Rank l33t
Rank
l33t

I forget to tell, that thx for the Tuned version TheFellowJasper!
I tried it but I get the same results as with the vanilla version.

My problem with this game is, it's impossible to debug.
However, I have an other game, RPM Tuning, which seems to be based on the same engine and that also produces an enigmatic symptom with dgVoodoo. Walls and other terrain objects start to disappear after a while.
I think the symptom of BG4 and RPM Tuning have the same common root. RPM Tuning doesn't require TeknoParrot, so that's an easier case, but still not easy because if it's run from the debugger, then everything is normal...🤔

So, I think I'll try to solve it all with RPM but I cannot promise anything.

Reply 10 of 10, by TheFellowJasper

User metadata
Rank Newbie
Rank
Newbie

I see, We'll have to see if thats gonna do something.
Although I recently I have seen a video of someone playing this game on modern setup with AMD card and it worked correctly, assuming he is not messing with wrappers (minimap is covered with cockpit cam but someone else said that his friend with AMD card has minimap too): https://www.youtube.com/watch?v=sL_ywG6EEcQ