VOGONS


First post, by funkerwolf

User metadata
Rank Newbie
Rank
Newbie

Hello everyone and thanks to the author of this wrapper, he really helped and solved a lot of problems associated with rendering in this one old good game, but there is one small problem.
The mass of various settings and the wrapper and the game itself has already been interchanged, but the problem does not disappear unfortunately...
Mouse cursor often flickers over the top of the sight in the game, how to solve this problem? Unfortunately, it's not possible to transfer a screenshot.
Sorry for my broken English, we are from Russia, hello from the team of developers of the mod F.E.A.R. Complete Edition.
Specs: Windows 10 Home N x64 18362.267, G4600+GTX1060 6gb, 435.27v2 video drivers(rollback to an older version of the driver does not solve the problem).
P.S. Can you make an experimental version for Wrapping in DX12?

Reply 1 of 9, by funkerwolf

User metadata
Rank Newbie
Rank
Newbie

https://youtu.be/jNLPTqvbiqo - example of this problem, used dgvoodoo2 2.61 release version and WIP 2.62, 2.63 and no changes....
The problem manifests itself in the entire line of the series of the first part of the game: F.E.A.R. and Extraction Point, Perseus Mandate, Combat.
Of course, the game works fine without wrapper, but on modern systems with Nvidia there are rendering problems, such as flickering textures on the walls and light, as well as the mode of slowing down the time in the game gives image artifacts. On modern Intel integrated graphics and AMD, there is no such problem.
https://youtu.be/kdU32NuYdL8 - used dgvoodoo2
https://youtu.be/27f_rsFD5NQ - without dgvoodoo2 0:43 flickering wall
Turning off the cursor in the game itself does not solve the problem, it still skips in the middle of the screen over the scope. Compatibility modes in the properties of the startup file and other manipulations do not fix the problem either.

Reply 2 of 9, by Dege

User metadata
Rank l33t
Rank
l33t

Did you get that flashing cursor with default dgVoodoo configuration?

dgVoodoo has mouse emulation that can cause such phenomenons but it is only for forced resolution and/or 'stretched, keep AR' scaling modes.
With unspecified scaling mode and unforced resolution, dgVoodoo doesn't chip on mouse handling.

Reply 4 of 9, by funkerwolf

User metadata
Rank Newbie
Rank
Newbie
Dege wrote:

Did you get that flashing cursor with default dgVoodoo configuration?

dgVoodoo has mouse emulation that can cause such phenomenons but it is only for forced resolution and/or 'stretched, keep AR' scaling modes.
With unspecified scaling mode and unforced resolution, dgVoodoo doesn't chip on mouse handling.

Please fix the problem with the cursor over the scope, the settings of the wrapper and the game do not change anything, but there is one thing, but when vertical synchronization is turned on, it disappears ...

Reply 6 of 9, by dr.zeissler

User metadata
Rank l33t
Rank
l33t

DGvoodoo2 and pixelshaderwater?

Retro-Gamer 😀PowerMac 6100-66/Houdini 486/66 - G4 Cube 450/Rage128pro OS9.0.1 - Macintosh LC/Apple IIe Card OS6.0.8 - Acorn A4000 Archimedes - Unisys CWD 486/66 + Aztech Washington

Reply 7 of 9, by funkerwolf

User metadata
Rank Newbie
Rank
Newbie
Dege wrote:

I'm planning to make changes in cursor handling but honestly I don't know if that will help, as I this problem doesn't appear for me.
It's strange it comes for you with default configuration.

I think the problem is associated with too high FPS for the game, because the cursor skips, but when the FPS is not very high or vertical synchronization is turned on, there is no problem.
With the second game in the series, the same thing happens, which F.E.A.R. 2: Project Origin.

Reply 9 of 9, by Yoda1776

User metadata
Rank Newbie
Rank
Newbie

The fix is running the game at the maximum resolution it retailed with in the in game menu 1280x960, THEN forcing whatever resolution you want.

For those interested its going to take a few more months of polish, but im building a sort of workaround fest graphics patch library for windows 10. Stumbled across this thread and saw no one knew the fix.

https://www.youtube.com/watch?v=IWRVFCVFso8&t=88s