VOGONS


First post, by ruthan

User metadata
Rank Oldbie
Rank
Oldbie

Hello,
i started using my old Games machine, i want to run Warcraft I, but when i run it from Windows 98, its starting in fullscreen mode and i have got black screen on my 20" 1600x1200 LCD + Geforce 6600GT - 81.98 drivers,
when i press ALT+ENTER game is running fine in window mode.

In pure DOS 320x240 ganes are running fine, so its running it some other stranger resolution like 320x200 or where is problem? Some Powerstrip porn needed, how to check it?

Last edited by ruthan on 2020-03-07, 01:58. Edited 5 times in total.

Im old goal oriented goatman, i care about facts and freedom, not about egos+prejudices. Hoarding=sickness. If you want respect, gain it by your behavior. I hate stupid SW limits, SW=virtual world, everything should be possible if you have enough raw HW.

Reply 1 of 15, by darry

User metadata
Rank l33t
Rank
l33t

I have essentially the same issue with a 6600gt on 1600x1200 monitor over dvi in Doom in every driver version I have tried. I always believed it was a known issue, so I never inquired about it.

See http://www.flaterco.com/kb/DOS_W98SE_general.html
I seem to recall other references to this elsewhere .

Incidentally, if I Alt-Enter back to full screen I usually get an image . Try it .

By the way, on the same system over DVI, a Quadro FX1100 an FX5900 not not have this issue (both have a Silicon Image TMDS , whereas my 6600GT has an integrated one).

Reply 2 of 15, by ruthan

User metadata
Rank Oldbie
Rank
Oldbie

What about other Geforce 6xxx cards or Geforce 7xxx AGP cards, could someone test it? Im using DVI too, what about VGA?

I just tested Doom is the same.

Im old goal oriented goatman, i care about facts and freedom, not about egos+prejudices. Hoarding=sickness. If you want respect, gain it by your behavior. I hate stupid SW limits, SW=virtual world, everything should be possible if you have enough raw HW.

Reply 3 of 15, by darry

User metadata
Rank l33t
Rank
l33t

What about other Geforce 6xxx cards

I have a non-GT Geforce 6600 that does the same thing .

Geforce 7xxx AGP

No official or beta Windows 9x/ME driver from Nvidia supports anything beyond the Geforce 6xxx . There are patched infs that apparently allow certain members of the Geforce 7 family or higher to somewhat work, but I doubt many people are using them .

what about VGA

I will try it when I get a chance, but by Geforce 6600GT is dual DVI and I do not have any DVI to VGA dongles handy (used to have a ton of them). The 6600 non-GT is somewhere in storage and might have a VGA port.

The best "solution" to the issue is likely to get a Geforce 5 series card (FX) or a Quadro from the same generation with a Silicon Image TMDS , or possibly to try VGA if that works for you .
I do not have any working Geforce 5 series cards without a Silicon Image TMDS on hand to test so I cannot comment on that .

Reply 4 of 15, by ruthan

User metadata
Rank Oldbie
Rank
Oldbie

I just test ATI X800 XL 256 MD and with same OS installation and monitor, Doom 2 and Warcraft are running fine.

Im using Geforce 7 and i know couple of people which are using them, best are 256 MB versions, but there is paid patch to make 512MB versions working.. Its working on 4 my machines, but i had one with AMD970 chipset where i had lots of nvidia dll erros, right from boot in explorer, but games are running fine.

Im old goal oriented goatman, i care about facts and freedom, not about egos+prejudices. Hoarding=sickness. If you want respect, gain it by your behavior. I hate stupid SW limits, SW=virtual world, everything should be possible if you have enough raw HW.

Reply 5 of 15, by darry

User metadata
Rank l33t
Rank
l33t

I just test ATI X800 XL 256 MD and with same OS installation and monitor, Doom 2 and Warcraft are running fine.

I've go an x800 GTO on the way . See [Explained and mostly solved] VESA BIOS works in 1600x1200 in DOS, with LG L246WP, but not with Samsung 204B

Im using Geforce 7 and i know couple of people which are using them

Does it have the same issue ?

Reply 6 of 15, by ruthan

User metadata
Rank Oldbie
Rank
Oldbie

Im not sure if Geforce 7 has this issue, but there are other for example when i start command.com in safe mode i got black screen and there is old shutdown issue, there are patches but they are not working for everymachine.

Im old goal oriented goatman, i care about facts and freedom, not about egos+prejudices. Hoarding=sickness. If you want respect, gain it by your behavior. I hate stupid SW limits, SW=virtual world, everything should be possible if you have enough raw HW.

Reply 7 of 15, by ruthan

User metadata
Rank Oldbie
Rank
Oldbie

Ok i did some testing Geforce 7 / 7600 / 7900 / 7950 - with 256 / 512 MB also has this issue.

Could someone test Geforce 4 / Geforce FX 5200?

Im old goal oriented goatman, i care about facts and freedom, not about egos+prejudices. Hoarding=sickness. If you want respect, gain it by your behavior. I hate stupid SW limits, SW=virtual world, everything should be possible if you have enough raw HW.

Reply 8 of 15, by darry

User metadata
Rank l33t
Rank
l33t

I briefly tested a TI 4200 and it did not have the issue, if I remember correctly .
My guess is still that Nvidia chips using an integrated TMDS will have the issue . If that it is the case, the FX 5200 is likely to be affected (have not tried it, as my FX 5200 and FX 5500 are in storage) .

Reply 9 of 15, by ruthan

User metadata
Rank Oldbie
Rank
Oldbie

Maybe exist some settings to fix it, but with default driver / windows settings is not working.

I also dont know if it is LCD only issue, or it would be same with CRT monitor? My LCD is capable of 75 Hz, at least for some resolution.

I also discovered other issue on ATI side - X800 XL Gigabyte not give picture on LCD HP 24" 1920x1200 60 Hz monitoring at all (from boot black screen), with second DELL 20" 75 Hz is working fine - i have installed lastest Bios.

Reported even on Geforce 4...

Im old goal oriented goatman, i care about facts and freedom, not about egos+prejudices. Hoarding=sickness. If you want respect, gain it by your behavior. I hate stupid SW limits, SW=virtual world, everything should be possible if you have enough raw HW.

Reply 10 of 15, by RayeR

User metadata
Rank Member
Rank
Member

I have similar problem with 7900GT when switching a textmode dos window to fullscreen. Sometimes monitor goes black and show some weird frequency out of sync message. In such case I can press alt+enter to go back windowed and once more alt+enter to fullscreen again and it works then. It's some way random, I dunno maybe 20% of fullscreen swithches go wrong and I have to repeat.

Gigabyte GA-P67-DS3-B3, Core i7-2600K @4,5GHz, 4GB DDR3, 128GB SSD, GTX670(GF7900GT), SB Audigy + YMF724F + DreamBlaster combo

Reply 11 of 15, by ruthan

User metadata
Rank Oldbie
Rank
Oldbie

Hmm, if it would be in 20% of cases, i would be fine, but for me it was 100%..

Im old goal oriented goatman, i care about facts and freedom, not about egos+prejudices. Hoarding=sickness. If you want respect, gain it by your behavior. I hate stupid SW limits, SW=virtual world, everything should be possible if you have enough raw HW.

Reply 12 of 15, by Tiido

User metadata
Rank l33t
Rank
l33t

From my experience this is a nvidia driver issue, with older drivers it doesn't happen but then you cannot use the better cards either...

T-04YBSC, a new YMF71x based sound card & Official VOGONS thread about it
Newly made 4MB 60ns 30pin SIMMs ~
mida sa loed ? nagunii aru ei saa 😜

Reply 13 of 15, by Laaca

User metadata
Rank Newbie
Rank
Newbie

I face this issue for years. It can corfirm it in the GeForce 4MX and GeForce 2 MX400.
It happens with windows drivers 5x.yy.zz and up.
The last drivers without this bug are 45.xx.yy
Unfortunately these drivers lack some functions and can not run f.e. Operation Flashpoint

What is interresting is the fact that in can be avoided if the return from graphic mode into text mode is not just
"mov ax,3; int 10h"
but
"mov bx,3; mov ax, 4F02h; int 10h; mov ax,3; int 10h"

Maybe would be possible to write a small TSR which traps the INT10h/ah=0 and changes it in the way above.

Reply 14 of 15, by RayeR

User metadata
Rank Member
Rank
Member

Yes, for Win9x a such TSR could be loaded from autoexec.bat before win boots and active in every dos session. But not sure if it's not swithced by driver directly so TSR wouldn't have a chance to trap this...

Gigabyte GA-P67-DS3-B3, Core i7-2600K @4,5GHz, 4GB DDR3, 128GB SSD, GTX670(GF7900GT), SB Audigy + YMF724F + DreamBlaster combo

Reply 15 of 15, by ruthan

User metadata
Rank Oldbie
Rank
Oldbie

So we need someone able to hack drivers on Win 9x level, i wonder are there such guys?

Im old goal oriented goatman, i care about facts and freedom, not about egos+prejudices. Hoarding=sickness. If you want respect, gain it by your behavior. I hate stupid SW limits, SW=virtual world, everything should be possible if you have enough raw HW.