First post, by rickee000

User metadata
Rank Newbie

Trying to get this off the wall classic to run and despite install and setup running OK - I get an error message saying there is not enough conventional lower memory.

It needs 570K and looking at 'mem' - I've got 488K free out of 640K (so using 152K).

Mem is saying I've got 0K Upper, 0K reserved, 66,122K Extended (XMS).

Blood's setup utility recognises the Extended Memory but insists I have that minimum 570K conventional. I've tried adding 'NOEMS' and 'RAM' to the end of the EMS line in Autoexec.bat with no luck.

I'm guessing the solution is to try and free up that 152K but my Autoexec and Config files are pretty lean - with everything I can loaded into higher memory.

Any ideas on how to get or free up more conventional memory or otherwise get round this issue?



SET BLASTER=A220 I7 D1 H5 P330 T6



Reply 2 of 6, by rickee000

User metadata
Rank Newbie

Thanks for the reply!

I'm running in DOS mode on Win98SE rather than Dos 6.22 itself so I can't run that command it seems 🙁 Hope this doesn't mean I need to go down that route and have a full dual boot with DOS / Windows!

Reply 4 of 6, by collector

User metadata
Rank l33t

Note that this forum is for DOS games on *modern* systems. For help with old hardware ask in Marvin. Marvin, the Paranoid Android

The Sierra Help Pages -- New Sierra Game Installers -- Sierra Game Patches -- New Non-Sierra Game Installers

Reply 6 of 6, by Malvineous

User metadata
Rank Oldbie

Have you run the "mem" command with the "/c" or "/p" parameter to see what is loading where in memory? This will let you see which programs are using conventional memory instead of UMBs. Only having 488 KB free is pretty bad, you should get way over 500 KB without any issues. Definitely include the RAM parameter to EMM386 so that it creates UMBs, otherwise there will be no space for LOADHIGH/LH to load anything into and it will fall back to using conventional memory.

Have you tried pressing F8 or Shift+F5 during boot, so you can boot to DOS Mode without loading anything?

If I were you I'd look into how you configure multiple profiles in config.sys and autoexec.bat because loading the CD-ROM drivers is probably what's chewing up all the memory. I notice you're not loading MSCDEX high like you are with the mouse driver so it could be that, but you probably don't *always* need the CD drivers. Having a profile that lets you boot to DOS with them, and another without, will probably help a lot.

Of course Windows provides CD-ROM support that uses no conventional memory at all, so there's no reason to load any CD drivers if you're going to boot to Windows. You only need them if you're booting to DOS *and* you want to use the CD drive as well, at the expense of having less memory available. If you load CD drivers like this when you're booting Windows, you'll end up with less conventional memory in all the DOS windows you open up, as these are each effectively a "mirror" of what the DOS environment was before Windows was launched.

BTW in your autoexec.bat, the '@' is meant to go first to hide the command, i.e. "@ECHO OFF"