VOGONS


First post, by tarasque

User metadata
Rank Newbie
Rank
Newbie

I am trying to install Windows 95 on my Olivetti Envision 400
Specs:
486 DX4 (100 MHz-33 MHz system)
Ram: 8mb ram
Hard Disk: CONNER CFS 425 A 420 MB

It tried installing three different versions of Win 95, OSR1, 2, 2.5 and every installation is failing at the second phase (system is freezing at the screen that says "Installing Windows 95 for the first time"). When I try to restart at Normal mode system is freezing at the loading screen while the system is entering Safe Mode normally.

I like the looks of this system and I am really hoping to hook a Roland mt32 on the on-board Midi port but I am out of ideas, any help is very welcome.

Reply 1 of 6, by Caluser2000

User metadata
Rank l33t
Rank
l33t

Try running CheckIt to see if there is a ram issue. 8megs is a bit lean as well. 16megs would be better. 32 ideal.

There's a glitch in the matrix.
A founding member of the 286 appreciation society.
Apparently 32-bit is dead and nobody likes P4s.
Of course, as always, I'm open to correction...😉

Reply 2 of 6, by tarasque

User metadata
Rank Newbie
Rank
Newbie

A small update for this peculiar machine, as it is driving me cRaZy and this might help someone in the future.
This pc has a special feature as it was meant to operate under your TV set in a standby mode. It is supposed to be able to instantly restore the last state of the machine so you can continue whatever it was you were doing by not waiting for it to boot.

It has a on/off power switch on the power supply (in the back of the pc) and it also has a ON/Standby micro switch on the front panel. I found out that my front panel is probably bad as the pc will enter standby mode right after the bios screen (before booting from a disk). Every once in a while it might just work and continue booting but it is very unstable so I decided to disconnect it by unplugging the tiny ribbon cable from the motherboard.

The original keyboard for this pc is wireless and is connected through infrared on the front panel. I don't have the original keyboard and I am just using a PS/2 keyboard and mouse. ( I don't have a clue if this is somehow affecting the strange behaviour). Note that I also checked the memory and it is fine, I even upgraded to 24mb by install a 16mb module. Another useful note is that it has a Goldstar GCD-R540B Cdrom Drive that needs a special driver (windows 95 boot discs will not detect it). The hard disk is a Conner CFS-425A drive 425mb (Cyl 839, Hds 16, Sect 62, Lzone 839, WPcomp 0)

With the front panel unplugged, Windows 95 is only booting in Dos Mode and Safe mode. Normal mode is just freezing. Normal mode is only working when the front panel is connected to the motherboard but as I said the pc rarely passes the bios boot screen with the panel connected.

With the panel disconnected I discovered that if you enter safe mode, go to Control Panel-> Power Option and disable Windows power management the pc manages to boot in Normal mode. My theory is that Windows power managemnt some how conflicts with the "instant on" feature and crashes. I don't have the original discs so maybe there is a special driver or setting that will allow it to co-exist.

For the moment the pc is working fine and I will try to find all the correct drivers and software. If there is any interest I will post more updates.

This is the front panel disconnected:
20191013-201333.jpg

This is the riser card, I have nothing installed as VGA, sound card, MIDI, IDE, even SCART connections are on board.
20191013-201403.jpg

The front panel is connected to the white connector via the ribbon cable,
20191013-201353.jpg

Reply 3 of 6, by Jo22

User metadata
Rank l33t++
Rank
l33t++
Caluser2000 wrote:

Try running CheckIt to see if there is a ram issue. 8megs is a bit lean as well. 16megs would be better. 32 ideal.

Someone could say so. Though in pratice, with anything below 32MiB of RAM, Win95 will likely swap to disk constantly.
- Windows 98SE is much better in this regard (has intelligent memory managment, can execute aligned applications straight from cache).
It will run snappy with 24MiB of RAM, for example. If there wasn't that new explorer, 98SE would have been even better here.
(I guess that's old story, but back in the day my father upgraded his 386DX40, an office PC, to 16MiB of RAM just for Win95 RTM.
And the HDDs were still busy while the PC was idling. Sure, it will boot with 4MiBs, too.. But so will OS/2 Warp. 😉 )

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//

Reply 4 of 6, by Caluser2000

User metadata
Rank l33t
Rank
l33t
Jo22 wrote:
Caluser2000 wrote:

(I guess that's old story, but back in the day my father upgraded his 386DX40, an office PC, to 16MiB of RAM just for Win95 RTM.
And the HDDs were still busy while the PC was idling. Sure, it will boot with 4MiBs, too.. But so will OS/2 Warp. 😉 )

At least OS/2 shipped with IBM Works and PIM so you could do something productive with it instead of just staring at clouds :p Oh my apologies that's right it had Wordpad and Paint. OS/2 also shipped with a 3D Chess game.

There's a glitch in the matrix.
A founding member of the 286 appreciation society.
Apparently 32-bit is dead and nobody likes P4s.
Of course, as always, I'm open to correction...😉

Reply 5 of 6, by 1ST1

User metadata
Rank Newbie
Rank
Newbie

Just found this. Envision 400 and P75 were designed for the first version of Windows 95. But originally Envision comes with a lot of extra drivers. If you need them, I can share. I have working P75 with all what is necessary.

Reply 6 of 6, by zrLCS

User metadata
Rank Newbie
Rank
Newbie
1ST1 wrote on 2021-09-19, 11:57:

Just found this. Envision 400 and P75 were designed for the first version of Windows 95. But originally Envision comes with a lot of extra drivers. If you need them, I can share. I have working P75 with all what is necessary.

Hello 1ST1, Im trying to install Olipilot on my windows 95 Envision P75 but Im not able at all. Could you please tell how to do it? I have "ENV ITA 21" downloaded.