VOGONS


First post, by haker120

User metadata
Rank Member
Rank
Member

I was looking for any glide emulator but I found nothing. I don't know if that's stupid idea or not but I'd like to run Glide games on machines without any iteration of Voodoo. Do any of these exist? I tried only nglide and it did install but run none of Glide games.

Reply 1 of 15, by buckeye

User metadata
Rank Oldbie
Rank
Oldbie

I was looking for the same thing but decided I'll just wait until I build another XP based rig which means less headaches.

Intel D865GL Pentium 4 2.4ghz. 512MB DDR 400 Quadro4 900XGL 128MB SB Live 5.1 500W 98SE
Intel SE440BX P3 450 256MB 40GB Voodoo 3000 16MB SB 32pnp 350W 98SE
MSI x570 Gaming Pro Carbon Ryzen 3700x 32GB DDR4 Zotac RTX 3070 8GB WD Black 1TB 850W

Reply 3 of 15, by Joseph_Joestar

User metadata
Rank l33t
Rank
l33t

nGlide works under Win98 but you need a DX9 capable card and DirectX 9.0c installed.

PC#1: Pentium MMX 166 / Soyo SY-5BT / S3 Trio64V+ / Voodoo1 / OPTi 82C930 / AWE64 Gold / SC-155
PC#2: AthlonXP 1700+ / Abit KT7A / Voodoo3 / SBLive / Vortex2
PC#3: Athlon64 3000+ / Asus K8V-MX / GeForce4 / Audigy1
PC#4: i5-3550P / MSI Z77A-G43 / GTX 650Ti / X-Fi

Reply 7 of 15, by cyclone3d

User metadata
Rank l33t++
Rank
l33t++
leileilol wrote on 2022-05-04, 18:15:

Geforce4Ti does not have DX9's pixel shader 2.0. That came (horribly) with the next series, GeforceFX.

The FX5950U is not bad at all. The lower end ones are sad though... Such as the FX5200 / 5500.

If Nvidia hadn't released the crappy versions, they wouldn't have caught near as much flak for the FX series.

Yamaha YMF modified setupds and drivers
Yamaha XG resource repository - updated November 27, 2018
Yamaha YMF7x4 Guide
AW744L II - YMF744 - AOpen Cobra Sound Card - Install SB-Link Header

Reply 8 of 15, by zyga64

User metadata
Rank Member
Rank
Member

from dgVoodoo 1.50 beta readme:

I. Requirements
---------------

- Windows 95/98/Me/2000/XP for Windows applications
- Wndows 95/98/Me/XP for DOS applications
- DirectX 7.0 or greater
- what else important to write here? Idonnow

http://dege.freeweb.hu/dgVoodoo/dgVoodoo/

Also Glidos should work on Windows 95 and above: https://www.glidos.net/index.html?lang=en

1) VLSI SCAMP /286@20 /4MB /CL-GD5422 /CMI8330
2) i420EX /486DX33 /16MB /TGUI9440 /YMF718+GUS
3) i440BX /P!!!750 /256MB /MX440 /SBLive!+Vibra16s

Reply 9 of 15, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

These are the most compatible:
nglide
Zeckensack
dgvoodoo 1.50 Beta 2

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 10 of 15, by zyga64

User metadata
Rank Member
Rank
Member

If you have a Riva TNT (and probably a TNT2), you can also try Creative Unified wrapper
Unified for TNT2 M64?

1) VLSI SCAMP /286@20 /4MB /CL-GD5422 /CMI8330
2) i420EX /486DX33 /16MB /TGUI9440 /YMF718+GUS
3) i440BX /P!!!750 /256MB /MX440 /SBLive!+Vibra16s

Reply 12 of 15, by akula65

User metadata
Rank Oldbie
Rank
Oldbie

It may be more productive to look for specific wrappers for specific games. As an example, here is an excerpt from the old Wings of Honor WW1 flight sim site concerning OpenGlide for Red Baron II/3D:

OpenGLide Glide Wrapper OpenGLide 0.09 Release Candidate 5 OpenGLide 0.08 OpenGLide 0.07 Beta 5 […]
Show full quote

OpenGLide Glide Wrapper
OpenGLide 0.09 Release Candidate 5
OpenGLide 0.08
OpenGLide 0.07 Beta 5

Date: 08-May-2002
File Size: 35 kByte

OpenGLide is a freeware Glide wrapper to convert Glide calls from 3dfx graphic cards to OpenGL calls. Basically you can play a lot of games programmed for the Glide API on non 3dfx cards as NVidia GeForce series and others. It works well with Red Baron II/3D. Just unzip it and drop the file called 'Glide2x.dll' into your game's main directory to control only this game's GLide setup. Upon first start an 'OpenGLid.ini' file will be created that controls your Glide Wrapper setup for your graphics card.

OpenGLide Version 007 Beta 5 reportedly works better with Red Baron 3D than newer versions but there are other reports stating that OpenGLide 0.09 Release Candidate 5 works great as well. Just find out what is best for you.

ATI graphics card users should change the 'IgnorePaletteChange' setting within this file to the following:

IgnorePaletteChange=1

Red Baron II/3D players with ATI cards should also disable Sun Glare in the game setup options to get the best performance from their ATI cards.

The VOGONS Wrapper Collection Project is a good place to look for specific wrappers if you see them referenced for specific games:
The Wrapper Collection Project

Reply 14 of 15, by akula65

User metadata
Rank Oldbie
Rank
Oldbie

So, for Rayman 2, see Dege's renderer here (looks like you need dxWrapper/DX6 or DGVoodoo (not DGVoodoo2!)):
Re: Rayman 2 DX6 30 FPS drops

You then might try the other titles with DGVoodoo and see how it goes. DGVoodoo can be had at the Wrapper Project given above:
http://www.vogonsdrivers.com/wrappers/files/G … gVoodoo/D3D7-9/