VOGONS


First post, by matze79

User metadata
Rank l33t
Rank
l33t

Hello,

I tried to test my Geoworks Ensemble Pack, unfortunately it doesn't work.
Took out the Escom Blackmate to check the floppy discs.

Installation runs without errors.
Floppys are all fine.

According to the system requirements, only an XT with 512Kb RAM is required.

Running Caldera OpenDOS (7.01)
386SX33 with 2Mb RAM and FPU.

I keep getting the error "Bad handle passed to System"

Also tried Setver to Fake DOS 2.00 to GEOS. 🙁

any clues ?

German:
https://www.shadowcircuit.de/viewtopic.php?p=152#p152

Thanks!

Attachments

  • zip1.jpg
    Filename
    zip1.jpg
    File size
    192.69 KiB
    Views
    419 views
    File license
    Fair use/fair dealing exception
  • zip2.jpg
    Filename
    zip2.jpg
    File size
    107.18 KiB
    Views
    419 views
    File license
    Fair use/fair dealing exception
  • zip3.jpg
    Filename
    zip3.jpg
    File size
    200.46 KiB
    Views
    419 views
    File license
    Fair use/fair dealing exception

https://www.retrokits.de - blog, retro projects, hdd clicker, diy soundcards etc
https://www.retroianer.de - german retro computer board

Reply 1 of 3, by matze79

User metadata
Rank l33t
Rank
l33t

Dosbox also doesnt like it.
Maybe install is corrupt or something.

dosbox.png
Filename
dosbox.png
File size
17.11 KiB
Views
349 views
File license
Fair use/fair dealing exception

https://archive.org/details/geoworks-ensemble/

Disk Images are in vgacopy format.
i think one could just rename them.

https://www.retrokits.de - blog, retro projects, hdd clicker, diy soundcards etc
https://www.retroianer.de - german retro computer board

Reply 2 of 3, by weedeewee

User metadata
Rank l33t
Rank
l33t

As was suggested on the other forum. Try an older dos version.

Just tried it with PCem running dos 3.31 and geos starts normally.

Right to repair is fundamental. You own it, you're allowed to fix it.
How To Ask Questions The Smart Way
Do not ask Why !
https://www.vogonswiki.com/index.php/Serial_port

Reply 3 of 3, by Jo22

User metadata
Rank l33t++
Rank
l33t++

I had similar experience so far. Geoworks v2 was very hard to get running. DOSBox was completely unusable.

MS-DOS 6.x worked, though. There's even a patch included. I had used Virtualbox to run it, I think. With QEMM loaded.

Also tried a later version. VBE graphics modes worked in some modes, but not all. Some colour depths didn't work (garbled graphics).

Hm. Maybe we should scrap benchmarks, MS Flight Simulator and demo scene prods and OS/2 for compatibility testing?
Geoworks seems to be a much harder nut to crack. 😉

Edit: I have an idea, but it's far fetched.
If GEOS has issues with filesystem or file access, it might help to run popular disk chaching programs.
They may filter int13h access or do other things to satisfy the program code.
Again, it's just an idea.

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//