VOGONS


First post, by spystyle

User metadata
Rank Newbie
Rank
Newbie

Hello from Maine,

I have some ISA cards I'm testing out to see if they work.

I have a Pentium 3 I cobbled together with DOS (on one drive), Windows 98se (on a 2nd drive), and Windows 2000 (on a 3rd drive). I can also add Windows XP to another partition on the 3rd drive.

The card I'm currently stuck on is marked Acer Magic S20.

I can't find any good working drivers for it for any OS.

I mean I tried one driver and got "Doom" to play in DOS, but I could only hear the music, not any sound effects.

Can you give me a clue ?

Thanks !
Craig in Maine.

P1100611.jpg
P1100612.jpg
P1100613.jpg
P1100614.jpg
P1100616.jpg

Last edited by spystyle on 2018-03-20, 21:55. Edited 1 time in total.

Reply 2 of 7, by spystyle

User metadata
Rank Newbie
Rank
Newbie

Thanks for the effort skv400, but that driver did not work for me in DOS.

I did more searching, and coincidentally found a working DOS driver, on this forum, 🤣.

Here :

Opti 82C929A - DOS driver anyone please?

Reply 3 of 7, by JK1984

User metadata
Rank Newbie
Rank
Newbie
spystyle wrote on 2018-03-20, 21:54:
Thanks for the effort skv400, but that driver did not work for me in DOS. […]
Show full quote

Thanks for the effort skv400, but that driver did not work for me in DOS.

I did more searching, and coincidentally found a working DOS driver, on this forum, 🤣.

Here :

Opti 82C929A - DOS driver anyone please?

Sorry to revive such an old thread, but can someone point me in the right direction? I haven't worked on a dos/windows 3.1 system in almost 25 years. I have forgotten quite a bit! I'm looking for Windows 3.1 drivers for the AcerMagic S20 (Opti 82C929) I installed the dos drivers linked in this post (which I got working) but this driver package has windows 95 drivers, not windows 3.1? Will the others for dos/win 3.x in the driver database work with my card?

Reply 4 of 7, by PC Hoarder Patrol

User metadata
Rank Oldbie
Rank
Oldbie
JK1984 wrote on 2022-01-15, 07:39:
spystyle wrote on 2018-03-20, 21:54:
Thanks for the effort skv400, but that driver did not work for me in DOS. […]
Show full quote

Thanks for the effort skv400, but that driver did not work for me in DOS.

I did more searching, and coincidentally found a working DOS driver, on this forum, 🤣.

Here :

Opti 82C929A - DOS driver anyone please?

Sorry to revive such an old thread, but can someone point me in the right direction? I haven't worked on a dos/windows 3.1 system in almost 25 years. I have forgotten quite a bit! I'm looking for Windows 3.1 drivers for the AcerMagic S20 (Opti 82C929) I installed the dos drivers linked in this post (which I got working) but this driver package has windows 95 drivers, not windows 3.1? Will the others for dos/win 3.x in the driver database work with my card?

Try here - https://edv-janssen.synology.me/ct_treiber_se … vers/sound/s20/

********** Directory of S20 **********

OS2S20 EXE 57,713 AcerMagic S20 OS/2 Drivers
S20211A1 EXE 547,095 AcerMagic S20 v2.11 DOS/Windows 3.x Drivers 1/2
S20211A2 EXE 72,537 AcerMagic S20 v2.11 DOS/Windows 3.x Drivers 2/2
S20R32A EXE 389,191 Acermagic S20 v3.2a Windows 95 Driver

Reply 6 of 7, by JK1984

User metadata
Rank Newbie
Rank
Newbie
PC Hoarder Patrol wrote on 2022-01-15, 11:25:
Try here - https://edv-janssen.synology.me/ct_treiber_se … vers/sound/s20/ […]
Show full quote
JK1984 wrote on 2022-01-15, 07:39:
spystyle wrote on 2018-03-20, 21:54:
Thanks for the effort skv400, but that driver did not work for me in DOS. […]
Show full quote

Thanks for the effort skv400, but that driver did not work for me in DOS.

I did more searching, and coincidentally found a working DOS driver, on this forum, 🤣.

Here :

Opti 82C929A - DOS driver anyone please?

Sorry to revive such an old thread, but can someone point me in the right direction? I haven't worked on a dos/windows 3.1 system in almost 25 years. I have forgotten quite a bit! I'm looking for Windows 3.1 drivers for the AcerMagic S20 (Opti 82C929) I installed the dos drivers linked in this post (which I got working) but this driver package has windows 95 drivers, not windows 3.1? Will the others for dos/win 3.x in the driver database work with my card?

Try here - https://edv-janssen.synology.me/ct_treiber_se … vers/sound/s20/

********** Directory of S20 **********

OS2S20 EXE 57,713 AcerMagic S20 OS/2 Drivers
S20211A1 EXE 547,095 AcerMagic S20 v2.11 DOS/Windows 3.x Drivers 1/2
S20211A2 EXE 72,537 AcerMagic S20 v2.11 DOS/Windows 3.x Drivers 2/2
S20R32A EXE 389,191 Acermagic S20 v3.2a Windows 95 Driver

Thank you, I'll try these after work today

Reply 7 of 7, by JK1984

User metadata
Rank Newbie
Rank
Newbie

Just wanted to do an update.. All is good now. Those drivers worked! Thank you. Only issue I had was getting the IDE CD-ROM to load correctly at boot. The changes that the install package makes to your autoexc and config.sys initializes the CD-ROM interface but then there’s a separate line right after that disables the interface. Why it does that I dont know? Strange. I REM the line that disabled the interface and all is well.