VOGONS


Sound Blaster 16 Clones

Topic actions

Reply 320 of 333, by AlexZ

User metadata
Rank Member
Rank
Member
Warlord wrote on 2021-09-26, 00:09:

didn't get detected with pnp os on either.

A3config is not capable of configuring DMA/IRQ it seems. I had the same problem with ALS100+ and ALS120. It can only read the configuration, set volume and maybe a few other options. There is Intel ISA PNP tool that may be capable of configuring it and there is also universal config tool floating around on Vogons. With PNP OS ON in Bios setup Windows needs to configure the card before it can be used in DOS.

As far as noise level is concerned my Yamaha SM718 is quite noisy as well and I wouldn't recommend it to anyone to use with earphones.

Pentium III 750E, ECS P6BXT-A+, 384MB RAM, NVIDIA GeForce FX 5600 128MB, Voodoo 2 12MB, 80GB HDD, Yamaha SM718 ISA, 19" AOC 9GlrA
Athlon 64 3400+, MSI K8T Neo V, 1GB RAM, NVIDIA GeForce 7600GT 256MB, 250GB HDD, Sound Blaster Audigy 2 ZS

Reply 321 of 333, by Warlord

User metadata
Rank l33t
Rank
l33t

I was eventially able to cofigure the card in pure dos with no windows install. You can change IRQs and DMAs with the ALS config tool, however if your card isn't detected using dosinit you cannot use config. I don't have any experience with those other tools, maybe I should take a look at them in case I ever need to. I ended up just disabling every onboard device in the bios of the motherboard and reserving IRQs 5 and 9 and DMA 1 and 5 and that did the trick.

I'm considereing making a recording of Jane's AH-64D Longbow (base theme) using the ALS100 I have to compare to the one in this thread here. A List of DOS Games with 16-Bit Sound

Reply 322 of 333, by AlexZ

User metadata
Rank Member
Rank
Member

I tested my ALS100+ and ALS120 today with unisound and it works too. I used PNP OS Yes in BIOS setup.

Pentium III 750E, ECS P6BXT-A+, 384MB RAM, NVIDIA GeForce FX 5600 128MB, Voodoo 2 12MB, 80GB HDD, Yamaha SM718 ISA, 19" AOC 9GlrA
Athlon 64 3400+, MSI K8T Neo V, 1GB RAM, NVIDIA GeForce 7600GT 256MB, 250GB HDD, Sound Blaster Audigy 2 ZS

Reply 323 of 333, by psychofox

User metadata
Rank Newbie
Rank
Newbie
Warlord wrote on 2021-09-27, 02:44:

I was eventially able to cofigure the card in pure dos with no windows install. You can change IRQs and DMAs with the ALS config tool, however if your card isn't detected using dosinit you cannot use config. I don't have any experience with those other tools, maybe I should take a look at them in case I ever need to. I ended up just disabling every onboard device in the bios of the motherboard and reserving IRQs 5 and 9 and DMA 1 and 5 and that did the trick.

I'm considereing making a recording of Jane's AH-64D Longbow (base theme) using the ALS100 I have to compare to the one in this thread here. A List of DOS Games with 16-Bit Sound

I recived the same card couple of weeks ago for my IBM 386. Great card, very low noise level and unisound compatible. No sound bugs. Real OPL sound. I really like the feature of pc speaker input from bus (IBM 386 has no pins for external pc speaker.). Amplified pc speaker sound has its own charm, on some older games i now often prefere pc speaker.

But... there is always some BUT. This card intitialises fine with alsinit or unisound. But no sound after init. Sound will be available only after i run alsconfig, no need to change mixer levels or change interrupts etc. Just run it and exit immediately. Since i really like this card, i have added alsconfig to autoexec.bat. It is quite annoing is to exit every time this app, but i havent found other solution to this problem yet. Any suggestions?

Reply 324 of 333, by keropi

User metadata
Rank l33t++
Rank
l33t++
psychofox wrote on 2021-11-03, 06:37:

I recived the same card couple of weeks ago for my IBM 386. Great card, very low noise level and unisound compatible. No sound bugs. Real OPL sound. I really like the feature of pc speaker input from bus (IBM 386 has no pins for external pc speaker.). Amplified pc speaker sound has its own charm, on some older games i now often prefere pc speaker.

But... there is always some BUT. This card intitialises fine with alsinit or unisound. But no sound after init. Sound will be available only after i run alsconfig, no need to change mixer levels or change interrupts etc. Just run it and exit immediately. Since i really like this card, i have added alsconfig to autoexec.bat. It is quite annoing is to exit every time this app, but i havent found other solution to this problem yet. Any suggestions?

just making sure
when you run ALSCONFIG and you save the settings the program creates an ALS.INI in the ALSCONFIG directory
let's assume that said directory is the default C:\ALSOUND
so you need this line for ALSINIT to use this config: ALSINIT C:\ALSOUND
this does not work for you?

🎵 PCMIDI mpu
🎧 Orpheus soundcard
Action Rewind
MegaCard
💻 WTB Amstrad PC7486SLC-33

Reply 325 of 333, by psychofox

User metadata
Rank Newbie
Rank
Newbie
keropi wrote on 2021-11-03, 07:24:
just making sure when you run ALSCONFIG and you save the settings the program creates an ALS.INI in the ALSCONFIG directory let […]
Show full quote

just making sure
when you run ALSCONFIG and you save the settings the program creates an ALS.INI in the ALSCONFIG directory
let's assume that said directory is the default C:\ALSOUND
so you need this line for ALSINIT to use this config: ALSINIT C:\ALSOUND
this does not work for you?

Yes, alsconfig added this line to autoexec and i havent modified it. Can you tell, what is this [Mute] section on als.ini file?

Is there alternative mixer or init apps available, that work with ALS100 chipset?

Edit: driver package version seems to be v 2.0 (readme.txt), is there newer driver available?

Reply 326 of 333, by keropi

User metadata
Rank l33t++
Rank
l33t++
psychofox wrote on 2021-11-03, 07:56:

Yes, alsconfig added this line to autoexec and i havent modified it. Can you tell, what is this [Mute] section on als.ini file?

Is there alternative mixer or init apps available, that work with ALS100 chipset?

Edit: driver package version seems to be v 2.0 (readme.txt), is there newer driver available?

[Mute] section seems to be the values when you press the MUTE button in some app , no idea really - it's all zeroes as expected from a mute function
Latest Unisound also supports ALS100 , maybe give that a test?

🎵 PCMIDI mpu
🎧 Orpheus soundcard
Action Rewind
MegaCard
💻 WTB Amstrad PC7486SLC-33

Reply 329 of 333, by zapbuzz

User metadata
Rank Oldbie
Rank
Oldbie

How many here I wonder use wireless mice 😀
Wireless mice are notorious for sending interference into sound.
An extension cable helps but nothing better than a wired mouse to ps2 port because theres also an adapter from usb to ps2 but not suitable for wireless.
There is also PCI / PCI-E noise suppression boards on ebay if they are studied then the home engineer can come up with their own solution perhaps also for ISA

Reply 330 of 333, by psychofox

User metadata
Rank Newbie
Rank
Newbie
keropi wrote on 2021-11-03, 21:51:

Dang.... I am all out of ideas 🙁

No problem, i can live with it, i just need to hit ESC on every boot. 😀
My wild guess is, that this card was originally sold with specific driver package and software. There is probably some mute "switch" that needs to be triggered on init.

Reply 331 of 333, by darry

User metadata
Rank l33t
Rank
l33t
zapbuzz wrote on 2021-11-03, 22:25:

There is also PCI / PCI-E noise suppression boards on ebay if they are studied then the home engineer can come up with their own solution perhaps also for ISA

I doubt that would be useful . Have a look at an earlier discussion on the subject .
PCI Power Filter Card - Linus Tech Tips Video

Reply 332 of 333, by zapbuzz

User metadata
Rank Oldbie
Rank
Oldbie
darry wrote on 2021-11-04, 19:35:
zapbuzz wrote on 2021-11-03, 22:25:

There is also PCI / PCI-E noise suppression boards on ebay if they are studied then the home engineer can come up with their own solution perhaps also for ISA

I doubt that would be useful . Have a look at an earlier discussion on the subject .
PCI Power Filter Card - Linus Tech Tips Video

Yeah I did but thats not a retro computer and thats why i am willing to get one and test now.
they came out for late 90's and earlier 2000's pc's and not for conboard audio
I have an old aptiva with shocking chipset sound so i'll use it on that and try pci audio again (it had a hum).
they need to be plugged in next to audio card.

Reply 333 of 333, by darry

User metadata
Rank l33t
Rank
l33t
zapbuzz wrote on 2021-11-05, 00:45:
Yeah I did but thats not a retro computer and thats why i am willing to get one and test now. they came out for late 90's and ea […]
Show full quote
darry wrote on 2021-11-04, 19:35:
zapbuzz wrote on 2021-11-03, 22:25:

There is also PCI / PCI-E noise suppression boards on ebay if they are studied then the home engineer can come up with their own solution perhaps also for ISA

I doubt that would be useful . Have a look at an earlier discussion on the subject .
PCI Power Filter Card - Linus Tech Tips Video

Yeah I did but thats not a retro computer and thats why i am willing to get one and test now.
they came out for late 90's and earlier 2000's pc's and not for conboard audio
I have an old aptiva with shocking chipset sound so i'll use it on that and try pci audio again (it had a hum).
they need to be plugged in next to audio card.

I don't really see how an add-in ISA or PCI card would help with sound card noise in a retro PC for the same reasons as those discussed in the thread about the PCI-E version.

That said, good luck if you do decide to test one and please do share your results (especially if you can do an A-B comparison using an external recorder or recording using another PC) and photos of the card .