VOGONS


Reply 100 of 510, by JazeFox

User metadata
Rank Member
Rank
Member
digistorm wrote on 2020-05-22, 14:32:

I am sorry. I checked again, and it only happens after I first used the EMU synth. And only a cold reboot seems to fix that issue. But the card does the same with the creative drivers so I think my card is partially broken. I didn’t notice before because I hit the reset button to quickly test with the default startup files. So unisound works perfect.

Great. Anyway, one more question... if you run Unisound again (a 2nd time) after the CQM left-channel issue, is it fixed?
I ask that because there is a known issue between most games/programs supporting AWE synth and AWE64 / late SB32/AWE32 cards. After using EMU8K synth in that games/progs, then, FM doesn't sound right (usually, it sounds with cuts/clicks or semi-garbled). That's because almost all of them are programmed for the first EMU8000 chip revision (present in early AWE32 and some SB32 cards). 2nd revision of the chip needs slightly different osc init values (that affects FM sound unfortunately). Unisound detects chip revision and the correct initialization is used.

Reply 101 of 510, by detalite

User metadata
Rank Newbie
Rank
Newbie

I just tested CT4390, CT4500, CT4520 with UNIOSOUND 0.70c and both channels were equally loud with CQM. Same with AWE and digital sound.

But the card does the same with the creative drivers so I think my card is partially broken. I didn’t notice before because I hit the reset button to quickly test with the default startup files. So unisound works perfect.

Sometimes happens that card don't fully work. I have that one myself. FM and MIDI works perfectly, but digital sound just hangs. BTW In Crystal diagnoscic tool (CWDIAG.EXE) works fine. 😀

Reply 102 of 510, by digistorm

User metadata
Rank Member
Rank
Member
JazeFox wrote on 2020-05-22, 15:00:

Great. Anyway, one more question... if you run Unisound again (a 2nd time) after the CQM left-channel issue, is it fixed?
I ask that because there is a known issue between most games/programs supporting AWE synth and AWE64 / late SB32/AWE32 cards. After using EMU8K synth in that games/progs, then, FM doesn't sound right (usually, it sounds with cuts/clicks or semi-garbled). That's because almost all of them are programmed for the first EMU8000 chip revision (present in early AWE32 and some SB32 cards). 2nd revision of the chip needs slightly different osc init values (that affects FM sound unfortunately). Unisound detects chip revision and the correct initialization is used.

Wow, it works😊. That’s great, now I can switch between adlib and AWE32 games without a reboot. It is true that I also noticed garbled sound after a while, I thought my AWE64 was fried somehow.

Reply 103 of 510, by detalite

User metadata
Rank Newbie
Rank
Newbie

About AD186 GM, I continue researching...
Do you know if the original drivers use a TSR for internal WT MIDI or not?

Digital data from external wavetable synthesizer goes on port I2S(1) of the AD1816 chip to internal DAC. In driver mixer I2S(1) has its own volume control. Maybe its muted? MPU401 volume control is probably only for WBH analog signal.

aLP1kCtm.jpg

Reply 104 of 510, by JazeFox

User metadata
Rank Member
Rank
Member
detalite wrote on 2020-05-23, 14:39:
Digital data from external wavetable synthesizer goes on port I2S(1) of the AD1816 chip to internal DAC. In driver mixer I2S(1) […]
Show full quote

Digital data from external wavetable synthesizer goes on port I2S(1) of the AD1816 chip to internal DAC. In driver mixer I2S(1) has its own volume control. Maybe its muted? MPU401 volume control is probably only for WBH analog signal.

aLP1kCtm.jpg

I sent you a PM (private message) yesterday with new details and a new version to test (To avoid flooding the thread with a lot of testing stuff...), I see you didn't see it yet... can you check it and test? Thanks.

Reply 105 of 510, by detalite

User metadata
Rank Newbie
Rank
Newbie

We are sorry, but you are not authorised to use this feature. You may have just registered here and may need to participate more in discussions to be able to use this feature.

Looks like i need to SPAM some more posts to send PM. You can send me massage.

new version to test

Unfortunately this time doesn't work either.

ES1869 - Only GM and digital sound. I tried with FM first and few second delay betwen switching with no difference.
AD1816 - Same as ealier, GM don't work.

Finally I found ES962 datasheet, and auto-detect mode is possible using SysEX command 4

You mean that?

p7WkgyXm.png

Reply 106 of 510, by hard1k

User metadata
Rank Oldbie
Rank
Oldbie

I'm trying to make UNISOUND work with the DOSBOX-X GUS PnP emulation, and have no luck yet, UNISOUND just doesn't list any PnP card (however it does find an emulated "SB16"). Could anyone test it?
On another point, would it be possible to display the ROM size on the real GUS PnP? As there is a ongoing ARGUS ROM DB project, it would come very handy to visualize that (as there is no original tool to quickly see the amount of ROM installed).

Fortex, the A3D & XG/OPL3 accelerator (Vortex 2 + YMF744 combo sound card)
AWE64 Legacy
Please have a look at my wishlist (hosted on Amibay)

Reply 107 of 510, by JazeFox

User metadata
Rank Member
Rank
Member
hard1k wrote on 2020-05-25, 23:19:

I'm trying to make UNISOUND work with the DOSBOX-X GUS PnP emulation, and have no luck yet, UNISOUND just doesn't list any PnP card (however it does find an emulated "SB16"). Could anyone test it?

I didn't use DOSBOX-X previously, but I checked it today... It seems PnP emulation is not complete? (at least in DOS, maybe it is for Win9x), or GUS PnP is not completely implemented (at least PnP part, I don't see any vID assignation nor PnP EEPROM emulation in the source code for this card. Anyway I used github search in the repository, I could miss something).
Anyway, if you try any other PnP tool (like ICU, CTCU, isapnptools, dump tools...), they don't work either, no card is recognized, so I think it's not Uniosund's fault. (I configured doxbox-x.conf properly with guspnp settings).

About SB16 being detected... it's normal. that is happening because SB16 emulation is enabled in DOSBOX and it identifies itself as a legit SB16, including the Copyright strings read from DSP commands. Unisound always try to check for a non-PNP SB16/AWE if no PnP cards are found previously.

On another point, would it be possible to display the ROM size on the real GUS PnP? As there is a ongoing ARGUS ROM DB project, it would come very handy to visualize that (as there is no original tool to quickly see the amount of ROM installed).

Yes, It is possible, I can add it, but I have to rely on the ROM contents, Header must be correct, at least: INTRWAVE string, rom size bytes and checksum byte. As there is no reliable method to retrieve it without correct header, it is mandatory that the ROM contents are properly done. I guess the ROMs created for ARGUS ROM DB project take that into account.

About ARGUS card , it could to be treated uniquely in Unisound, if you (or the creator/s) want. Does it have a custom PnP EEPROM?: an special PnP vID or name, special resource assignations... In that case I can add it to Unisound specifically...

Reply 108 of 510, by hard1k

User metadata
Rank Oldbie
Rank
Oldbie

Thanks a lot for the comments! Totally clear on that DOSBOX-X topic.

Yes, ARGUS ROM DB project implies the correct working ROM contents. That would be great, thanks a lot!
I'll make a cross post in the ARGUS thread quoting your message, we'll see what shock__ and other guys think about it, maybe someone would volunteer to program a custom EEPROM firmware. IIRC the EEPROM topic has never been discussed in detail so far, everyone just uses the original GUS EEPROM utility (p20disk3.zip) or the GUS PnP XSS InterWave EEPROM Toolz 1.3 (http://www.vogonsdrivers.com/getfile.php?fileid=100).

Fortex, the A3D & XG/OPL3 accelerator (Vortex 2 + YMF744 combo sound card)
AWE64 Legacy
Please have a look at my wishlist (hosted on Amibay)

Reply 109 of 510, by _Rob

User metadata
Rank Member
Rank
Member

FWIW DOSBox-X has two ISA PnP sound card options.
- Gravis Ultrasound PnP
- SoundBlaster 16 Vibra

Which can be enabled by setting

[gus]
gustype=interwave

or

[sblaster]
sbtype=sb16vibra

Note, it does not emulate PnP functionality properly, it is basically there such that Win9x will automatically detect a soundcard. The resources are not set through PnP, but rather by setting them in the config file. Yes this should be enhanced such that there is proper PnP support...

The autodetect with the default non-PnP SB16 is flaky. Sometimes it finds the card during Win9x installation, other times it does not and you need to go and run a second detect manually afterwards. Once it detected the SB16 as a "Adlib Gold".

Also the emulated sb16vibra does not emulate the CQM, instead it uses the OPL3 emulation. The sb16vibra is also automatically initialised by DOSBox-X, so there is no need to run something like UNISOUND.

Reply 110 of 510, by FreddyV

User metadata
Rank Oldbie
Rank
Oldbie

Hi,
This Week end I tested UniSound on my Amstrad PC1512 (8086)
It worked with an ESS ES1869, an AZTech board (Don't remember the model), a realtech chip and a SB AWE64 Gold

FM and SB output work for all, except the AWE64 having no FM Sound.

Reply 111 of 510, by JazeFox

User metadata
Rank Member
Rank
Member

Tool updated to v0.71c

Changelog:

  • Enable on-board WaveTable sound on ES186x cards with ES689/ES69x WT ICs
  • Enable on-board WaveTable sound on AD181x cards with YMF704/QS1000 WT ICs
  • Now /VF switch also set WaveTable header & on-board WT volume (same as FM)
  • Now /VL switch also set CD volume on Creative cards only for now.
  • Fixed some typos and confusing terms in help screen.
  • Added GUS PnP ROM info. ROM name and size is displayed at init time.
    This is informative only. Unisound init GUS PnP as GUS classic compatible.
  • Added proper support for Crystal CS4232 based cards. In previous versions,
    these cards were detected but the init process lacked firmware uploading.

The download link is updated at the end of the first post as usual:
UNISOUND - Universal ISA PnP Sound Card Driver for DOS v0.78b

Special thanks to detalite for exhaustive testing during these days.

-----

FreddyV wrote on 2020-05-27, 16:27:
Hi, This Week end I tested UniSound on my Amstrad PC1512 (8086) It worked with an ESS ES1869, an AZTech board (Don't remember th […]
Show full quote

Hi,
This Week end I tested UniSound on my Amstrad PC1512 (8086)
It worked with an ESS ES1869, an AZTech board (Don't remember the model), a realtech chip and a SB AWE64 Gold

FM and SB output work for all, except the AWE64 having no FM Sound.

Yes, that AWE64 behaviour is normal when AWE64 is plugged in 8-bit slots (read about it in point 4 in UNISOUND.TXT). FM sound is routed through EMU8000. EMU8000 initialization requires full 16 bit connection to work.

Reply 112 of 510, by hard1k

User metadata
Rank Oldbie
Rank
Oldbie

Grrrreat! Thanks a lot! 😀

Fortex, the A3D & XG/OPL3 accelerator (Vortex 2 + YMF744 combo sound card)
AWE64 Legacy
Please have a look at my wishlist (hosted on Amibay)

Reply 113 of 510, by boxpressed

User metadata
Rank Oldbie
Rank
Oldbie
JazeFox wrote on 2020-05-28, 13:10:

[*] Added proper support for Crystal CS4232 based cards. In previous versions,
these cards were detected but the init process lacked firmware uploading.

Special thanks to detalite for exhaustive testing during these days.

The new version works great with my Everex card now, even better than the retail drivers that came with the card. Thanks to both of you!

Reply 114 of 510, by boxpressed

User metadata
Rank Oldbie
Rank
Oldbie

Update: the GM music doesn't work on Doom, but the sound effects do. GM music works on Duke3D, Descent, Tyrian, and Dune 2. Not sure if I'm doing something wrong, but someone may want to double check with their CS4232.

Reply 115 of 510, by detalite

User metadata
Rank Newbie
Rank
Newbie

the GM music doesn't work on Doom, but the sound effects do

Just in case i checked Doom switching back and forth betwen FM and GM, and seems to work properly every time. Same on Settlers 2, Monkey Island 2 and HoMM 2.
It's hard to tell where is the problem.

Reply 117 of 510, by boxpressed

User metadata
Rank Oldbie
Rank
Oldbie
boxpressed wrote on 2020-05-28, 20:56:

OK, probably an issue on my end.

I think the problem was that I was using the shareware version. I installed Ultimate Doom, and now the GM is working.

Pretty sure it was the shareware version because I didn't get GM from the CS4232 or an AZT2320.

Reply 118 of 510, by Fox Mulder

User metadata
Rank Newbie
Rank
Newbie

JazeFox; I wanted to thank you for sharing your tool with the community, it's so useful.

It works with all my ISA PnP cards. I can quickly initialize my AWE64 CT4520 and even my SB32 CT3930 and SB16s CT2230 and CT2290, so that's really nice.

I have this Aztech AT-3500 that still doesn't work. Attached are the results of DUMP.EXE and some pictures, in case you are interested in adding support for it.

Cheers.

Attachments

  • Filename
    AZT3005.ZIP
    File size
    12.28 KiB
    Downloads
    23 downloads
    File license
    Public domain
  • 01.jpg
    Filename
    01.jpg
    File size
    1.03 MiB
    Views
    712 views
    File license
    Public domain
  • 02.jpg
    Filename
    02.jpg
    File size
    807.79 KiB
    Views
    712 views
    File license
    Public domain
  • 03.jpg
    Filename
    03.jpg
    File size
    724.41 KiB
    Views
    712 views
    File license
    Public domain

Reply 119 of 510, by MKT_Gundam

User metadata
Rank Member
Rank
Member

1- Is possible the software uninstall the soundcard?
2- Does the software have a limit to detect sound cards?
3- The Reverb/Chorus configuration of AWE/SB32 cards are present? Also the Mt32 mode.
4- UNISOUND works on FreeDOS too?

Retro rig 1: Asus CUV4X, VIA c3 800, Voodoo Banshee (Diamond fusion) and SB32 ct3670.
Retro rig 2: Intel DX2 66, SB16 Ct1740 and Cirrus Logic VLB.