VOGONS


First post, by whitepawn

User metadata
Rank Newbie
Rank
Newbie

Hi,
I recently resurrected a SBC (PC420-G2 Single board computer manual and Troubleshooting) with Cyrix DX2-66 cpu and 16 Mb RAM.Used XTIDE on an intel network card (Intel S82595FX and 3com 3C905B XTIDE Boot Problem) and installed Windows 98 SE on 8Gb hard drive.Everything went somoothly and system booted fine, except sound card.Also i have a trident graphics card if relevant.

While i was installing windows, Es1868f was plugged in system.I tought windows didn't recognize it properly so i run "add new hardware wizard" in control panel but windows unable to find any new device.Then i moved to another Es1868f card also same issue.I decided maybe Es1868f is not compatible with Ali chipset and tried Amlogic ALS120.Also same issue windows couldn't find it at all.

Here is some photos of system and sound cards:

IMG_20210328_121944.jpg
Filename
IMG_20210328_121944.jpg
File size
591.37 KiB
Views
56 views
File license
Fair use/fair dealing exception
IMG_20210328_122122.jpg
Filename
IMG_20210328_122122.jpg
File size
557.01 KiB
Views
56 views
File license
Fair use/fair dealing exception
IMG_20210328_122310.jpg
Filename
IMG_20210328_122310.jpg
File size
986.29 KiB
Views
56 views
File license
Fair use/fair dealing exception
IMG_20210328_122352.jpg
Filename
IMG_20210328_122352.jpg
File size
1.1 MiB
Views
56 views
File license
Fair use/fair dealing exception
IMG_20210328_122356.jpg
Filename
IMG_20210328_122356.jpg
File size
918.81 KiB
Views
56 views
File license
Fair use/fair dealing exception

Things i have tried:

[*]Tried with my other socket 3 SBC (PSC-486 VER:C Jumper or manual information needed) no sound cards detected.
[*]With my socket 7 system all sound cards works fine
[*]Tried different ISA sockets no luck.
[*]Measured ISA Backplane( AR-MB6)voltages from ISA card all 12v -12v 5v -5v are fine.
[*]Checked for IRQ conflicts in checkit and windows nothing found.

Any suggestions?