VOGONS


Reply 880 of 1035, by vutt

User metadata
Rank Member
Rank
Member

@polpo Is there technical reason why v1.2 download package is missing dedicated adlib only uf2 file?
There are number of MB onboard sound chips like ensoniq and via with decent SBPro/16 fx sound while FM is based on shitty TSR emulation. Would be cool if PicoGUS could cover FM part.

Last edited by vutt on 2024-05-23, 18:23. Edited 1 time in total.

Reply 881 of 1035, by polpo

User metadata
Rank Member
Rank
Member
vutt wrote on 2024-05-23, 18:15:

@polpo Is there technical reason why v1.2 download package is missing dedicated adlib only uf2 file?

I removed the Adlib firmware because it was subsumed by the SB firmware. If you need the SB firmware to act as if it were an Adlib-only card, you can disable the SB port by using the /p 0 option in pgusinit.

Reply 882 of 1035, by vutt

User metadata
Rank Member
Rank
Member
polpo wrote on 2024-05-23, 18:20:
vutt wrote on 2024-05-23, 18:15:

@polpo Is there technical reason why v1.2 download package is missing dedicated adlib only uf2 file?

I removed the Adlib firmware because it was subsumed by the SB firmware. If you need the SB firmware to act as if it were an Adlib-only card, you can disable the SB port by using the /p 0 option in pgusinit.

Ok I missed that part in documentation. Thanks!

Reply 883 of 1035, by tobiasrieper

User metadata
Rank Newbie
Rank
Newbie
tobiasrieper wrote on 2024-05-23, 16:05:

I am interested in one of these cards, would these be better than my current ESS1868 cards? I currently use that and an ewave. I love playing Duke 3d, Doom and Raptor.

PicoGUS should work great with all of those games and the MIDI soundtrack will be better in the GUS mode (some people do like the FM versions better, though...).
[/quote]

Hmm just wondering if it's a worthy upgrade over my ESS. I presume I can use my ewave as well? That's what will be usimg to play my MIDI tracks. Looks like a great product! Does the GUS pico sound different for sounds? I'm just curious, thanks! 😀

Reply 884 of 1035, by dreamblaster

User metadata
Rank Oldbie
Rank
Oldbie

I now have PicoGUS in stock, shipping from Belgium
pre-orders are shipped.
https://www.serdashop.com/PicoGUS

tobiasrieper wrote on 2024-05-23, 18:35:

I presume I can use my ewave as well?

Yes, PicoGUS will work fine with E-Wave

Visit http://www.serdashop.com for retro sound cards, video converters, ...
DreamBlaster X2, S2, S2P, HDD Clicker, ... many projects !
New X2GS SE & X16GS sound card : https://www.serdashop.com/X2GS-SE ,
Thanks for your support !

Reply 885 of 1035, by tobiasrieper

User metadata
Rank Newbie
Rank
Newbie
dreamblaster wrote on 2024-05-25, 16:38:
I now have PicoGUS in stock, shipping from Belgium pre-orders are shipped. https://www.serdashop.com/PicoGUS […]
Show full quote

I now have PicoGUS in stock, shipping from Belgium
pre-orders are shipped.
https://www.serdashop.com/PicoGUS

tobiasrieper wrote on 2024-05-23, 18:35:

I presume I can use my ewave as well?

Yes, PicoGUS will work fine with E-Wave

Awesome... only bad thing is I'll be tempted to get the Dreamblaster XGS!!! 😁

Reply 886 of 1035, by MadMac_5

User metadata
Rank Newbie
Rank
Newbie
tobiasrieper wrote on 2024-05-25, 19:56:

Awesome... only bad thing is I'll be tempted to get the Dreamblaster XGS!!! 😁

I mean, it would save shipping for when you inevitably crack and buy the X2GS, right? I know that my journey to buying my own X2GS went something like this:

  • "Oh cool, LGR has a review of a new wavetable module on his Blerbs channel! It sounds a lot like a Sound Canvas, pretty cool!"
  • "Nah, I don't need one, I already have a Sound Blaster 16, a SB Live, and a Vortex 2 for my 440BX retro PC."
  • "OK, maybe it would be nice to have a GS wavetable device to put on the headers on the SB16 or Vortex 2. But it's so expensive, especially with the conversion from CAD to Euros!"
  • "Whoops, I ordered it."
  • "Now I'm buying a Chill and Phil to use it with my sound cards without a wavetable header."

Reply 887 of 1035, by snipe3687

User metadata
Rank Newbie
Rank
Newbie
MadMac_5 wrote on 2024-05-26, 04:09:
I mean, it would save shipping for when you inevitably crack and buy the X2GS, right? I know that my journey to buying my own X2 […]
Show full quote
tobiasrieper wrote on 2024-05-25, 19:56:

Awesome... only bad thing is I'll be tempted to get the Dreamblaster XGS!!! 😁

I mean, it would save shipping for when you inevitably crack and buy the X2GS, right? I know that my journey to buying my own X2GS went something like this:

  • "Oh cool, LGR has a review of a new wavetable module on his Blerbs channel! It sounds a lot like a Sound Canvas, pretty cool!"
  • "Nah, I don't need one, I already have a Sound Blaster 16, a SB Live, and a Vortex 2 for my 440BX retro PC."
  • "OK, maybe it would be nice to have a GS wavetable device to put on the headers on the SB16 or Vortex 2. But it's so expensive, especially with the conversion from CAD to Euros!"
  • "Whoops, I ordered it."
  • "Now I'm buying a Chill and Phil to use it with my sound cards without a wavetable header."

You’ve just described every retro device purchase I’ve made over the last 7 years with the addition of “ok now I’ve got everything I could ever want. I don’t need to buy anything else!”

Reply 888 of 1035, by ricardo8a

User metadata
Rank Newbie
Rank
Newbie

Hi all,

Just got my picogus V2 from JCM, but think my card is bricked - pgusinit just shows no found error- and trying bootsel with micro USB gives no further prompt in win, Linux.

Any ideas? Much appreciated and just amazed of reviews on PicoGus, so much potential 😍

Reply 889 of 1035, by Shreddoc

User metadata
Rank Oldbie
Rank
Oldbie
ricardo8a wrote on 2024-05-28, 00:27:

Hi all,

Just got my picogus V2 from JCM, but think my card is bricked - pgusinit just shows no found error- and trying bootsel with micro USB gives no further prompt in win, Linux.

Any ideas? Much appreciated and just amazed of reviews on PicoGus, so much potential 😍

Just to be sure, we should first check that you are performing the bootsel procedure correctly. Perhaps you already know this, from experience with other Picos/etc. But if not, then : be sure to have the bootsel button already pressed and held down as you plug in the MicroUSB cable. Keep the button held down, and ordinarily, a file explorer window should pop up within a few seconds.

Also, if possible, perhaps try a different cable, and/or verify the one you are using, to rule out a faulty cable as the cause.

With that out of the way, the real troubleshooting can begin. Though it would be nice if it were this easy 😀 😀

Reply 890 of 1035, by ricardo8a

User metadata
Rank Newbie
Rank
Newbie
Shreddoc wrote on 2024-05-28, 00:53:
Just to be sure, we should first check that you are performing the bootsel procedure correctly. Perhaps you already know this, […]
Show full quote
ricardo8a wrote on 2024-05-28, 00:27:

Hi all,

Just got my picogus V2 from JCM, but think my card is bricked - pgusinit just shows no found error- and trying bootsel with micro USB gives no further prompt in win, Linux.

Any ideas? Much appreciated and just amazed of reviews on PicoGus, so much potential 😍

Just to be sure, we should first check that you are performing the bootsel procedure correctly. Perhaps you already know this, from experience with other Picos/etc. But if not, then : be sure to have the bootsel button already pressed and held down as you plug in the MicroUSB cable. Keep the button held down, and ordinarily, a file explorer window should pop up within a few seconds.

Also, if possible, perhaps try a different cable, and/or verify the one you are using, to rule out a faulty cable as the cause.

With that out of the way, the real troubleshooting can begin. Though it would be nice if it were this easy 😀 😀

Hi,

1st many thanks for all help! great community 😀

Problem persist - I first hold for 3 to 10 seconds bootsel while pluging USB micro to PC and then release bootsel with cable connected to PC USB port, nothing happens.

lsusb shows no hint, nada in linux mint.

I have read that pico bootsel buttons are prone to be damaged, but think this is unlikely this case - new unit, does a click when pushed, feels properly working when released...

On cable I am afraid I have tried all USB micro at home - did read of issue of most cables being charge only, but do have some that are good to transfer, at least to transfer data to my old trusty kindle. I am plugging the card to an always on, always plugged PC (I have checked that USB ports work and do not have applied any power mgmt thing). I have also tried with both USB 3 and USB 2 port on PC side - with no luck.

My skills on electronics are really poor (have soldered in the past and understand basics but tried to avoid it - guess this will help me improve these skills) but think have fair PC hardware/software knowledge 😀

Reply 891 of 1035, by kikendo

User metadata
Rank Member
Rank
Member

Is there a Discord server or any other way I can get help with this card? It's not performing as expected and I would appreciate some guidance.

Some examples:
I can never get Doom or Doom II to make any sound even after using the recommended settings. Blood doesn't work and neither does Duke Nukem 3D.
Fast Tracker II would play music just in all sort of weird frequencies.
I tried installing the Windows drivers for Ultrasound and I couldn't get it showing up.
I know Cubic Player is listed as not working, but I tried open Cubic Player and all I get is a high pitched noise when playing modules.

Reply 892 of 1035, by appiah4

User metadata
Rank l33t++
Rank
l33t++

Hey @polp, will there ever be a v1.x revision that lets you use USB peripherals without needing external power? I have the parts to build a second 1.x and I am holding off just in case this is a possibility..

Retronautics: A digital gallery of my retro computers, hardware and projects.

Reply 893 of 1035, by Ensign Nemo

User metadata
Rank Oldbie
Rank
Oldbie
kikendo wrote on 2024-05-28, 12:48:
Is there a Discord server or any other way I can get help with this card? It's not performing as expected and I would appreciate […]
Show full quote

Is there a Discord server or any other way I can get help with this card? It's not performing as expected and I would appreciate some guidance.

Some examples:
I can never get Doom or Doom II to make any sound even after using the recommended settings. Blood doesn't work and neither does Duke Nukem 3D.
Fast Tracker II would play music just in all sort of weird frequencies.
I tried installing the Windows drivers for Ultrasound and I couldn't get it showing up.
I know Cubic Player is listed as not working, but I tried open Cubic Player and all I get is a high pitched noise when playing modules.

It's worth pointing out that Discord chats are essentially hidden from the rest of the internet. That's fine for stuff like gaming, but I think most people would prefer that tech support discussions be available for the public. This way other people with the same problem can find help. It can also cut down on duplicated tech support work. Maybe the GitHub page would be a better option?

https://github.com/polpo/picogus

Reply 894 of 1035, by Shreddoc

User metadata
Rank Oldbie
Rank
Oldbie
appiah4 wrote on 2024-05-28, 12:56:

Hey @polp, will there ever be a v1.x revision that lets you use USB peripherals without needing external power? I have the parts to build a second 1.x and I am holding off just in case this is a possibility..

The v1.2 hardware (Github link) includes "Jumper to apply power to micro USB-B connector on Pico to allow USB HID devices to be used". I believe this does what you are asking, though I am not certain as I have not tried it myself.

Be aware there are some slight BOM changes between 1.1 and 1.2 hardware. The following was my working list of changes, from when I did my own orders, but do double-check for yourself, as it's annoying to have to do yet-another Mouser order just for the 1 thing I forgot! 😀

Extra things I needed to buy, going from v1.1 to v1.2 =

* C1 and C2 are now surface mount
* R1, R2, R3, R4 are changed
* R5, R6 are added
* New chip U10 is added, a SOT-6
* Optional : A cheaper U2, and a slightly improved U5 (though the v1.1 components may still be used here)
* Optional : Either use the pre-built DAC boards, as per v1.1, or add additional components (and different back plate, re: hole location) to do chipdown DAC

Reply 895 of 1035, by Linoleum

User metadata
Rank Newbie
Rank
Newbie
kikendo wrote on 2024-05-28, 12:48:
Is there a Discord server or any other way I can get help with this card? It's not performing as expected and I would appreciate […]
Show full quote

Is there a Discord server or any other way I can get help with this card? It's not performing as expected and I would appreciate some guidance.

Some examples:
I can never get Doom or Doom II to make any sound even after using the recommended settings. Blood doesn't work and neither does Duke Nukem 3D.
Fast Tracker II would play music just in all sort of weird frequencies.
I tried installing the Windows drivers for Ultrasound and I couldn't get it showing up.
I know Cubic Player is listed as not working, but I tried open Cubic Player and all I get is a high pitched noise when playing modules.

Can you share your hardware setup, autoexec and config.sys settings? Maybe in a separate thread if you prefer... Quick tip: I personally load ultrinit.exe on top of pgusinit.exe and it somehow fixed few problems (with doom namely).

#1: Sempron 3000+, 1Gb, HD3650 AGP, SB Audigy 2 ZS
#2: P4 1.8Ghz, 512Mb, Voodoo3 3000, SB Live!
#3: P3 866Mhz, 384Mb, Riva TNT2 AGP, SB Live!
#4: P233 MMX, 64Mb, ATI Rage II+, SB 32
#5: P100, 32Mb , S3 Virge, Sb16, Mt32-Pi & PicoGus v2.0

Reply 896 of 1035, by polpo

User metadata
Rank Member
Rank
Member
ricardo8a wrote on 2024-05-28, 00:27:

Hi all,

Just got my picogus V2 from JCM, but think my card is bricked - pgusinit just shows no found error- and trying bootsel with micro USB gives no further prompt in win, Linux.

Any ideas? Much appreciated and just amazed of reviews on PicoGus, so much potential 😍

If it's not detected in DOS and bootsel doesn't work at all, that does point to the card being bad. I'd contact JCM to see if you can get a replacement.

appiah4 wrote on 2024-05-28, 12:56:

Hey @polp, will there ever be a v1.x revision that lets you use USB peripherals without needing external power? I have the parts to build a second 1.x and I am holding off just in case this is a possibility..

Like Shreddoc said, on the v1.2 board, putting a cap on the "USBPWR" jumper will apply power to the USB port on the Pico.

kikendo wrote on 2024-05-28, 12:48:
Is there a Discord server or any other way I can get help with this card? It's not performing as expected and I would appreciate […]
Show full quote

Is there a Discord server or any other way I can get help with this card? It's not performing as expected and I would appreciate some guidance.

Some examples:
I can never get Doom or Doom II to make any sound even after using the recommended settings. Blood doesn't work and neither does Duke Nukem 3D.
Fast Tracker II would play music just in all sort of weird frequencies.
I tried installing the Windows drivers for Ultrasound and I couldn't get it showing up.
I know Cubic Player is listed as not working, but I tried open Cubic Player and all I get is a high pitched noise when playing modules.

There is a Discord but it's mostly focused around development of the PicoGUS and other retro projects that use the Pico/RP2040 like the PicoMEM. I agree with Ensign Nemo that public posts here on Vogons or in the GitHub issues are more publicly available and discoverable. As for your issues, that all sounds really bad (except for Windows - the Win9x drivers aren't supported, and the Win3.x drivers are kind of a mess to install). Did you DIY or did you buy a board? What chipset do you have?

Reply 897 of 1035, by kikendo

User metadata
Rank Member
Rank
Member
polpo wrote on 2024-05-29, 17:28:

I agree with Ensign Nemo that public posts here on Vogons or in the GitHub issues are more publicly available and discoverable.

I agree about discoverability of issues and shared experiences, but:
- I didn't think polluting the Github repository with issues pertaining to my particular configuration is constructive at all, i think of that area as a place to report actual bugs on the picogus itself or its software.
- Forums are great and all but some (many) times, I just want to talk in realtime with a person about problems, here's where something like Discord comes to be useful and preferable.

As for your issues, that all sounds really bad (except for Windows - the Win9x drivers aren't supported, and the Win3.x drivers are kind of a mess to install). Did you DIY or did you buy a board? What chipset do you have?

I have a 440BX machine, and I got the card from you, just purchased one from your latest batch that came up on Tindie. Let me know how I can help, I still think it's probably due to my misconfiguration rather than a problem with the card.
Would love to know how to report this better and publicly, filling up this thread with my problems also seems counter-productive but if this is what you would prefer, i'll go ahead and reply with more details.

Reply 898 of 1035, by duboisea

User metadata
Rank Newbie
Rank
Newbie

I am able to use my PicoGUS with the SoundBlaster and MPU-401 firmwares, but not Gravis Ultrasound. Anyone have debugging advice?

```
SET ULTRASND=220,1,1,5,1
SET ULTRADIR=C:\ULTRASND
pgusinit.exe /f pg-gus.uf2
```

```
PicoGUS detected: Firmware version: picogus-gus v1.2.0
Hardware: PicoGUS v2.0

USB Joy...
Wavtable...
GUS-like card detected on port 220...
Audio buffer size set to 4 samples
DMA interval set to default behavior
Running in GUS mode on port 220
PicoGUS initalized!
```

I can't get GUS to work in doom

Running `ultrinit` returns `Could not locate an Ultrasound` and then the computer deadlocks

Reply 899 of 1035, by MadMac_5

User metadata
Rank Newbie
Rank
Newbie
duboisea wrote on 2024-05-29, 20:42:
I am able to use my PicoGUS with the SoundBlaster and MPU-401 firmwares, but not Gravis Ultrasound. Anyone have debugging advice […]
Show full quote

I am able to use my PicoGUS with the SoundBlaster and MPU-401 firmwares, but not Gravis Ultrasound. Anyone have debugging advice?

```
SET ULTRASND=220,1,1,5,1
SET ULTRADIR=C:\ULTRASND
pgusinit.exe /f pg-gus.uf2
```

```
PicoGUS detected: Firmware version: picogus-gus v1.2.0
Hardware: PicoGUS v2.0

USB Joy...
Wavtable...
GUS-like card detected on port 220...
Audio buffer size set to 4 samples
DMA interval set to default behavior
Running in GUS mode on port 220
PicoGUS initalized!
```

I can't get GUS to work in doom

Running `ultrinit` returns `Could not locate an Ultrasound` and then the computer deadlocks

It looks like there's a typo in your SET ULTRASND line. It should read:

SET ULTRASND=220,1,1,5,5 instead of 220,1,1,5,1.

Try changing that and see if it works!