First post, by ratsflif

User metadata
Rank Newbie

I've been playing through a bunch of old Sierra adventure games enjoying some midi music when I ran into an issue with Space Quest 4 and 5 both muting the line in volume levels on my ess audio drive 1869.

I run the essvol.exe command in the autoexec.bat and have it set all the volume levels to 10 (wave, CD, Line, Synth, PC Speaker) on the computer start up and it works great until I play Space Quest 4 or 5 with General Midi or MT32 for music selected along with soundblaster for sounds.

When the game loads the Audioblast.drv it sets all the volume levels to 0 except the main volume which changes to 8.

I run my midi modules sound output back into the line in on the sound card to get mixed in with the game sounds and noticed the midi screen showing notes being played but no music. That's when I discovered the issue.

If I run the game with only midi and no soundblaster support than it works fine and doesn't adjust the volume levels and I hear the music.

I just ordered an external audio mixer which will fix my issue but thought the behavior was strange that the games were muting different audio sources when the games soundblaster driver is loaded.

This is on a Pentium 90 running dos 6.22

Reply 1 of 3, by Joseph_Joestar

User metadata
Rank l33t

Known issue with ESS cards and certain Sierra games.

It can be fixed via MIDITo.

PC#1: Pentium MMX 166 / Soyo SY-5BT / S3 Trio64V+ / Voodoo1 / OPTi 82C930 / AWE64 Gold / SC-155
PC#2: AthlonXP 1700+ / Abit KT7A / Voodoo3 / Audigy1 / Vortex2
PC#3: Athlon64 3400+ / Asus K8V-MX / 5900XT / Audigy1
PC#4: i5-3350P / MSI Z77A-G43 / GTX 650Ti / X-Fi