VOGONS


First post, by matti157

User metadata
Rank Newbie
Rank
Newbie

I bought a Creative branded Voodoo2 12mb. I installed the drivers from the CD plus update for Windows 95

I have 2 problems: The games are very slow, unplayables. Even the 3dfx logo that starts before the game is very lagging

If I start 3dmark instead the benchmarks are seen with white textures. See this video https://youtu.be/ThRGD1eLbow

My pc is a Pentium MMX 233 with 64mb sdram

Any ideas? Is it fair that Windows only gives me 4mb of VRAM on voodoo? screenshots

64-ADE231-ADD7-46-B3-BEE1-C195537-D9-D20.jpg
341-D2693-9861-4-FA2-951-D-0142-F50-B329-A.jpg
8937-B4-AB-A663-4-CAD-ADE4-93-C3-AE10-F47-F.jpg

Thanks

Reply 2 of 9, by Gmlb256

User metadata
Rank Oldbie
Rank
Oldbie
thepirategamerboy12 wrote on 2021-11-10, 03:41:

Perhaps try reference drivers instead of the vendor ones.

https://www.philscomputerlab.com/drivers-for-voodoo-2.html

I recall that the OP tried different drivers but on DOS where GTA was running unusually slow.

The card seems likely to be defective as I see only one TMU working according to the 3Dfx hardware profile, it should display 8MB for the texture memory if both TMU are working. Perhaps it should be checked with a Glide diagnostic tool called MOJO.EXE for better information.

Reply 3 of 9, by Aebtdom

User metadata
Rank Member
Rank
Member

What kind of CPU are cpu are you using?
And try a fastvoodoo driver, because your textures are really bad in 3dm99.

AMD XP2400+, 768MB DDR 333, GA-7VRXP KT333
Nvidia Geforce 3 Ti200 64MB @ 250/500Mhz
3Dfx Voodoo 2 12MB SLI
SATA 150 TXII + 80GB WD SATA, 40GB WD IDE, Creative SB Live
Win98 SE Dx9.0c, IIyama Vision Master 1451 19"

Reply 4 of 9, by matti157

User metadata
Rank Newbie
Rank
Newbie

I tried the latest reference driver, but 3dmark99 refuses to start with these drivers

DCFFB7CA-3DD5-460A-8C75-E93CF6A2552A.jpeg
Filename
DCFFB7CA-3DD5-460A-8C75-E93CF6A2552A.jpeg
File size
1.81 MiB
Views
262 views
File license
Public domain

Attached the mojo output

My cpu is a pentium mmx 233

Any ideas?

Attachments

  • Filename
    SST.log
    File size
    1.66 KiB
    Downloads
    1 download
    File license
    Public domain
  • Filename
    MOJO.TXT
    File size
    1.04 KiB
    Downloads
    6 downloads
    File license
    Public domain
  • Filename
    SSTV2.log
    File size
    1.75 KiB
    Downloads
    1 download
    File license
    Public domain

Reply 6 of 9, by Hoping

User metadata
Rank Member
Rank
Member
Gmlb256 wrote on 2021-11-10, 05:11:
thepirategamerboy12 wrote on 2021-11-10, 03:41:

Perhaps try reference drivers instead of the vendor ones.

https://www.philscomputerlab.com/drivers-for-voodoo-2.html

I recall that the OP tried different drivers but on DOS where GTA was running unusually slow.

The card seems likely to be defective as I see only one TMU working according to the 3Dfx hardware profile, it should display 8MB for the texture memory if both TMU are working. Perhaps it should be checked with a Glide diagnostic tool called MOJO.EXE for better information.

Yes, something is not right, the voodoo2 has two TMUs, no multitexturing with one. Maybe missing components, or bent pins in the best scenario.

Reply 9 of 9, by LubieCipy

User metadata
Rank Newbie
Rank
Newbie

Can you upolad foto of the card? From the second screenshot you can see that only one TMU is functioning. First, let's see if the card looks good physically