VOGONS


First post, by B24Fox

User metadata
Rank Member
Rank
Member

Hey all!

Has anybody ever encountered issues with a Banshee, where it would seem to work perfectly on Win98, but wouldn't work under XP?? (on the same machine?!)

I have a 1st generation Banshee with a "1001"-type chipset (Chaintech Desperado AGP-3F10) with [1.00.03-ET] BIOS, that puts out a completely garbled desktop in WinXP. Sometimes a black screen. And sometimes you can see a hint of the icons (with no text) on a black background.
Only time it starts is when the desktop is set to 16 colors.

The driver i'm using is a win2k driver: "17 May 2000 - 3dfx Voodoo Banshee V1.02.02b 1517k ZIP Beta Release" -- downloaded from http://falconfly.3dfx.pl/banshee.htm.

***Thing is that, other banshees (both "1001" & "3001" chipsets, *LaterEdit--and with same bios ver.*) work fine on this machine with the same WinXP, and with the same exact driver.
So i'm really baffled by this card that ONLY seems to work on Win98.

Here's a picture from the net, of the card in question:

Chaintech-Desperado-3F10-1Front.jpg
Filename
Chaintech-Desperado-3F10-1Front.jpg
File size
274.81 KiB
Views
383 views
File license
Fair use/fair dealing exception

Thanks!

L.E.
Also is there a difference between the older "1001" and newer "3001" chipsets?

Reply 1 of 6, by B24Fox

User metadata
Rank Member
Rank
Member

...so ...i can boot XP in "VGA Mode", and it starts in 16 colors; and i can see the card is installed fine. No exclamation mark, no detected conflicts.
But as soon as i set the color mode to 256 or above, the screen goes black with the mouse cursor on top. And if i give it the 15 seconds to automatically revert back cu the previous seting (16color), the OS comes back to life. So the system doesn't actually freeze. Just the screen becomes severely corrupted or black.

Today i've desoldered every elecrolytic cap from the board, and tested them with an ESR meter. They all check out fine.

Also tried the older [V1.02.01b] driver (instead of V1.02.01b), and it behaves the same.

I don't understand HOW can this card work perfectly on Win98 😕
I just dread some hidden defect that 98 might be covering up..

Reply 3 of 6, by B24Fox

User metadata
Rank Member
Rank
Member

Unbelievable!! Banshee Evolution 0.9 win2k driver freakin' works!!!
Thank you so much aaronkatrini !!

I was now able to run "Video Memory stress Test v1.7.116" , and the card's memory tests OK!
So i dunno WHAT is up with this card.. It's just fussy I guess..

Reply 5 of 6, by B24Fox

User metadata
Rank Member
Rank
Member

You're right for sure! But I was just afraid of maybe hidden defects that might not immediately be apparent in 98., but are revealed in XP

In any case, after careful thinking and consideration, I think I'll be choosing another card to keep.. Although i absolutely loved how this one looked and the almost pristine condition it's in, the Chaintech one has lower spec memory (10ns), electrolytic capacitors, and this driver weirdness...
So the choice remains between a Skywell & a Sparkle.

I've open a new thread here: Please HELP me choose btwn these 2 Voodoo Banshees
Your two cents would be greatly appreciated 😀

Reply 6 of 6, by B24Fox

User metadata
Rank Member
Rank
Member

HA! I think I've unraveled the mistery of why this Chaintech card stood out from the bunch!

It's the only card (that i ever tested) that has the oldest version (of 3) chip variants to have been put on the Banshee:
"500-0013-03" [1001]

Others are:
"500-0013-04" [1001]
"500-0013-04" [3001]

https://www.techpowerup.com/gpu-specs/3dfx-banshee.g941

Now it's kinda starting to get back it's appeal as a collection piece! 🤣