VOGONS

Common searches


First post, by ArcadEd

User metadata
Rank Newbie
Rank
Newbie

I've been having a blast building a Win98/Dos machine. Running into little snags here and there and this forum has been so amazing in getting me through each snag. Now I have almost everything working but ran into an issue I couldn't find an answer here.

My only example of this issue is with Shadow Warrior as I am not sure of any other games I have that use the actual CD for the music in the game.
My issue is this. Music does not pass through to my speakers when playing Shadow Warrior. Original CD
1. Yes, I have the audio cable connected from the CDRom to the Awe64
2. Yes, audio pass through works fine in windows when I put in a music CD.
3. Yes, music is playing in shadow warrior when I plug in headphone into the CD Rom.

I just seems like the pass through to the AWE64 from the CDRom isn't working in either Dos or maybe just in Shadow Warrior.

Like I mentioned above, I have sound and music working in every other game. Even Rise of the Triad (thanks to this forum).

Thanks so much for any help.

Reply 1 of 7, by darry

User metadata
Rank l33t
Rank
l33t
ArcadEd wrote on 2021-06-11, 04:24:
I've been having a blast building a Win98/Dos machine. Running into little snags here and there and this forum has been so amaz […]
Show full quote

I've been having a blast building a Win98/Dos machine. Running into little snags here and there and this forum has been so amazing in getting me through each snag. Now I have almost everything working but ran into an issue I couldn't find an answer here.

My only example of this issue is with Shadow Warrior as I am not sure of any other games I have that use the actual CD for the music in the game.
My issue is this. Music does not pass through to my speakers when playing Shadow Warrior. Original CD
1. Yes, I have the audio cable connected from the CDRom to the Awe64
2. Yes, audio pass through works fine in windows when I put in a music CD.
3. Yes, music is playing in shadow warrior when I plug in headphone into the CD Rom.

I just seems like the pass through to the AWE64 from the CDRom isn't working in either Dos or maybe just in Shadow Warrior.

Like I mentioned above, I have sound and music working in every other game. Even Rise of the Triad (thanks to this forum).

Thanks so much for any help.

What CD-ROM drive are you using and are you sure that the connector being used on the drive is actually an analogue audio out ? Also does its pinout match what the AWE64 expects ?
I ask this because Windows may well be using direct digital transfer of audio DATA through the IDE bus (which is not an option in DOS) .

Also, did you check that the CD audio input is enabled in the AWE64's DOS mixer application ( mixerset , AFAICR) ?

Reply 2 of 7, by Jorpho

User metadata
Rank l33t++
Rank
l33t++

Try using a DOS audio CD player (like from https://dosprograms.info.tt/sound.htm ) to play the CD instead. If that works, then it's probably some kind of mixer problem exclusive to Shadow Warrior.

Reply 3 of 7, by ArcadEd

User metadata
Rank Newbie
Rank
Newbie
darry wrote on 2021-06-11, 04:32:
What CD-ROM drive are you using and are you sure that the connector being used on the drive is actually an analogue audio out ? […]
Show full quote
ArcadEd wrote on 2021-06-11, 04:24:
I've been having a blast building a Win98/Dos machine. Running into little snags here and there and this forum has been so amaz […]
Show full quote

I've been having a blast building a Win98/Dos machine. Running into little snags here and there and this forum has been so amazing in getting me through each snag. Now I have almost everything working but ran into an issue I couldn't find an answer here.

My only example of this issue is with Shadow Warrior as I am not sure of any other games I have that use the actual CD for the music in the game.
My issue is this. Music does not pass through to my speakers when playing Shadow Warrior. Original CD
1. Yes, I have the audio cable connected from the CDRom to the Awe64
2. Yes, audio pass through works fine in windows when I put in a music CD.
3. Yes, music is playing in shadow warrior when I plug in headphone into the CD Rom.

I just seems like the pass through to the AWE64 from the CDRom isn't working in either Dos or maybe just in Shadow Warrior.

Like I mentioned above, I have sound and music working in every other game. Even Rise of the Triad (thanks to this forum).

Thanks so much for any help.

What CD-ROM drive are you using and are you sure that the connector being used on the drive is actually an analogue audio out ? Also does its pinout match what the AWE64 expects ?
I ask this because Windows may well be using direct digital transfer of audio DATA through the IDE bus (which is not an option in DOS) .

Also, did you check that the CD audio input is enabled in the AWE64's DOS mixer application ( mixerset , AFAICR) ?

Ahh, I didn't even think that windows would be using trickery!!!

It's the only cable I have so I am not sure. I always thought there universal so I didn't think anything of it. It's the one that has the black clippy plug on each end. I did notice the awe64 has the white plug as well so I ordered a cable that matched up just in case. Funny thing is, I used to build these for a living back in the mid to late 90s 🤣.

I will check the dos application, I wasn't aware of that.

I'll find out the brand of the CDrom.

thanks!

Reply 4 of 7, by ArcadEd

User metadata
Rank Newbie
Rank
Newbie
Jorpho wrote on 2021-06-11, 04:43:

Try using a DOS audio CD player (like from https://dosprograms.info.tt/sound.htm ) to play the CD instead. If that works, then it's probably some kind of mixer problem exclusive to Shadow Warrior.

OK, testing with the DOS cd player it does not work from the pass through as well. Just from the headphone jack in the front.

The CDrom drive is a Lite-On LTN486S 48x Max

I'm not sure how to work with the setmixer app yet so reading up on it. Seems weird for that to be shutoff by default though, no?

Reply 5 of 7, by ArcadEd

User metadata
Rank Newbie
Rank
Newbie

I figured it out. Thanks to mixerset. The CD audio volume was turned all the way down 😀.

New question. How do I get what I change in Mixerset to save after a reboot? Right now it's not.

Thanks so much Jorpho and darry!!

Ed

Reply 6 of 7, by darry

User metadata
Rank l33t
Rank
l33t
ArcadEd wrote on 2021-06-11, 05:09:
OK, testing with the DOS cd player it does not work from the pass through as well. Just from the headphone jack in the front. […]
Show full quote
Jorpho wrote on 2021-06-11, 04:43:

Try using a DOS audio CD player (like from https://dosprograms.info.tt/sound.htm ) to play the CD instead. If that works, then it's probably some kind of mixer problem exclusive to Shadow Warrior.

OK, testing with the DOS cd player it does not work from the pass through as well. Just from the headphone jack in the front.

The CDrom drive is a Lite-On LTN486S 48x Max

I'm not sure how to work with the setmixer app yet so reading up on it. Seems weird for that to be shutoff by default though, no?

Based on pictures of the drive, the only 4-pin header it has is identified as analogue audio out . Pinout is RGGL, which is standard, AFAICR .

I honestly do not remember the AWE64 mixer defaults .