VOGONS

Common searches


First post, by Gonduron

User metadata
Rank Newbie
Rank
Newbie

System:
- 486 with MS DOS 6.22
- Adaptec AVA-2825 SCSI controller
- Plextor PX-83CS SCSI CD-ROM drive
- Iomega ZIP-100 SCSI internal drive

Target:
Just for ease of mind, I would like to have drive letters assigned this way:
- Plextor CD-ROM drive on D:
- Iomega ZIP drive on E:

Problem:
- Right now, it's the other way round: CD drive gets assigned E:, and ZIP drive D:

Troubleshooting:
- In config.sys, the Adaptec ASPIDISK.SYS reserves drive letter D: for the ZIP drive
- In config.sys, the Adaptec ASPI2DOS.SYS does not reserve any drive letter for the CD drive
- Re-ordering those two lines does not help.
- In autoexec.bat, MSCDEX assigns drive letter E: to the CD drive

Question:
1) Is there a way to tell ASPIDISK.SYS that I want to reserve drive letter E: for the ZIP drive, not D:?
2) Is there a way to tell ASPI2DOS.SYS that I want to reserve drive letter D: for the CD drive?
3) Is there a way to create a dummy drive in config.sys, such as with the SUBST command (which unfortunately cannot be run inside config.sys).

Thank you for any hints 😀

My "Pixeli": Intel 486DX4-100 -- Asus VL/I-486SV2GX4 -- 16 MB -- Diamond Stealth64 S3 Vision868 2 MB VLB -- AWE64 Gold -- Roland LAPC-I and SCC-1 -- Adaptec AVA-2825 -- IBM 1 GB SCSI-2 -- Plextor 8x -- Teac 3,5" + 5,25" -- EIZO S2133

Reply 1 of 2, by akula65

User metadata
Rank Oldbie
Rank
Oldbie

When I build a system, I usually make the CD-ROM drive drive letter something close to the end of the alphabet. Here are some notes from an old build:

Edit the AUTOEXEC.BAT file and make the following change: […]
Show full quote

Edit the AUTOEXEC.BAT file and make the following change:

OLD: LH C:\CDROM\MSCDEX /D:MSCD000
NEW: LH C:\CDROM\MSCDEX /D:MSCD000 /L:Q

This change will make the CD-ROM Drive to be Q:. Reboot to enable the new drivers.

It's a no-brainer if you want to use an unused drive letter, but with your situation I'm not sure what would happen if you try to change the drive letter using MSCDEX. Did you try changing the drive letter to D:, i.e:

LH C:\CDROM\MSCDEX /D:MSCD000 /L:D

The load high (LH) is not absolutely necessary, and the designation after the /D is almost certainly something different for you.