VOGONS

Common searches


Metal Gear Solid PC

Topic actions

First post, by avatar_58

User metadata
Rank Oldbie
Rank
Oldbie

I'm trying to get Metal Gear Solid working but it always defaults to "Software Mode" stating that my card does not support certain features (which it does not list). I have a Geforce 6800 GT so I thought maybe the game has a list of cards and if yours doesn't match it locks in software mode.

Is there a way to fake this game out? I tried stealing the video config from a working install but it just resets itself and redetects the card as unsupported.

I was wondering if maybe there was a way to fake my device id or something to get this game running. I tried PCanalyze but for some reason MGS won't run with this program in the background.

Any thoughts?

Reply 1 of 62, by HunterZ

User metadata
Rank l33t++
Rank
l33t++

I had this game lying around but never installed it until just now. It seems to work fine on my ATI Radeon 9800 Pro with the latest Catalyst drivers (5.7). It might help that I have the Microsoft Application Compatability Toolkit 4.0 installed, although I don't see an entry for MGS in it.

You're probably not missing much by running in software mode. Keep in mind that it was originally designed for the PSX, which is worse than any Win9x software renderer I've seen and runs at 320x240 (or so). Even with hardware acceleration on my Radeon, the game looks like ass due to super-low-res textures and 16-bit color rendering (I wish there was a way to override that!)

I can't think of anything that might help, except maybe:
- make sure you have the latest video drivers and directx installed
- set your video driver options to defaults, or at least make sure they aren't forcing anything
- turn on any video driver options that look like they might be there to make old games work (e.g. table fog)

You could also try installing the ACT and also play around with running in Win98 compatability mode (I'm assuming you're running XP).

Good luck.

Reply 2 of 62, by avatar_58

User metadata
Rank Oldbie
Rank
Oldbie

For some reason the game won't even start in any compatiblity mode except windows 2000 (which would end up having the same issues as xp) 😳

For my video card drivers I've tried many different versions of Forceware but none of them help. Right now I'm using ones from TweaksRUs (77.62 Type 3) as they were recommended by someone. The latest official nvidia drivers don't help either. I've toyed with a few settings in driver panel but nothing really seems to help.

Also I have to turn off ninja/water effects or else the game crashes when I die (and the screen with the "Snake snake SNAAAKE" comes up). So basically the game is butchered 😢

I'm attempting to also get the PSX version running via ePSXe but am having sound issues only with this game. It seems I'm cursed. No version wants to work for me..... 😖

Reply 3 of 62, by HunterZ

User metadata
Rank l33t++
Rank
l33t++

Yeah the PSX version uses some hard-to-emulate sound features. I'd recommend checking out Pete's SPU plugins.

It sounds to me like nVidia isn't doing as good a job as ATI of maintaining compatability with older versions of Direct3D. You could try playing with your video acceleration slider (Display Properties->Settings->Advanced->Troubleshoot->Hardware acceleration) and the DirectX features enable/disable buttons in dxdiag (Start->Run->dxdiag)

I'd also definitely recommend installing the MSACT 4.0 (or whatever the newest version is), as it may sneak in some hacks to get it working for you.

Reply 4 of 62, by avatar_58

User metadata
Rank Oldbie
Rank
Oldbie

I downloaded it and now I need .NET and microsoft's site is really slow today... 😳 Oh well, just have to wait. Hopefully there is something useful to run this game.

Reply 6 of 62, by HunterZ

User metadata
Rank l33t++
Rank
l33t++

Just install it (and maybe reboot for good measure), then try running MGS again. I think it applies its settings automatically for applications it knows about.

Reply 7 of 62, by avatar_58

User metadata
Rank Oldbie
Rank
Oldbie

Well it didn't help. I think this only helps for applications that don't like xp...and thats not really an issue here (many people have MGS running perfectly in xp) I need a solution for the video card... 😢

Reply 8 of 62, by HunterZ

User metadata
Rank l33t++
Rank
l33t++

Yeah, unfortunately it looks like you may be out of luck. You could maybe buy an old PCI video card for around #30 that's compatable with the game, but that's probably a bit extreme.

Reply 9 of 62, by avatar_58

User metadata
Rank Oldbie
Rank
Oldbie

Yeah, a little. 😊

Too bad there is no way to fake my card's id..... 😒 I would have thought simply making the game think I have an older geforce would have enabled hardware support. There has to be a utility somewhere....

Reply 10 of 62, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

try 3D-Analyze: http://www.tommti-systems.de/start.html

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 11 of 62, by HunterZ

User metadata
Rank l33t++
Rank
l33t++

Hmm that program looks pretty complicated. The emulate DirectX 8.1 caps might be a good option to try, along with setting the device ID to a Radeon 9800 Pro (since it's listed and we know it works)

Reply 12 of 62, by avatar_58

User metadata
Rank Oldbie
Rank
Oldbie

Sorry I made a typo earlier...I did try 3danalyze and MGS refuses to run when its in the background (even without changing a single option and just clicking run)

However thats exactly the type of program I need...however I need one that works 😅

Reply 13 of 62, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

DX-Tweaker

http://nonatainment.de/Portal/DesktopDefault.aspx

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 15 of 62, by avatar_58

User metadata
Rank Oldbie
Rank
Oldbie

Nice! 😎

However I can't seem to get it to do anything. I even tried enabling "Grayscale" post processing to make sure it was actually working but the game came up in colour 😢

When I changed my video card id it was detected as a 6800 still....

Maybe I'm doing something wrong? I just clicked the ID changer checkbox and then clicked "Active" and then "Start" to run the game. It went into the game and it nothing changed detection wise.

I tried a few other settings but it doesnt seem to even be working at all....

Reply 16 of 62, by HunterZ

User metadata
Rank l33t++
Rank
l33t++

So you actually set up a profile within the utility that points to the game's EXE file, and then you're using the utility to launch the game?

I haven't tried it so I have no idea what to do.

Reply 18 of 62, by cmw

User metadata
Rank Newbie
Rank
Newbie

Try download the special modified Omega Drivers for nVidia cards.

http://www.omegadrivers.net/nvidia/win2k_xp.php

It may just work fine then (aswell as most certainly every other game you might posess^^). And just ignore that Microsoft Hardware Quality Labs whining about uncertified drivers.

Reply 19 of 62, by HunterZ

User metadata
Rank l33t++
Rank
l33t++

Hmm that's interesting. It could certainly be related, since I didn't get that error.

If you run DXDIAG and bring up the DirectX Files tab, are there any issues listed?