VOGONS


First post, by pokeswithastick

User metadata
Rank Newbie
Rank
Newbie

I am running qemu on a Windows 11 host with whpx turned on. On one laptop running a 10th Intel Core i9 CPU everything works great but the exact same guest image copied over to another laptop with an 11th Gen Intel Core i5 does strange things when launching executables inside the win98 guest. The top error dialog is from launching 7zip and the bottom one is from launching Winzip. Other programs like explorer also error out.

Screenshot 2022-04-30 104830.png
Filename
Screenshot 2022-04-30 104830.png
File size
15.28 KiB
Views
364 views
File license
CC-BY-4.0

Has anyone seen anything similar before? On very rare occasions the guest behaves itself on the 11th gen laptop (maybe 1 boot out of 10). Running with whpx acceleration turned off is also fine.

I'm running qemu 6.2.0 compiled using an msys environment. Starting arguments and output is

$ ./qemu-system-i386 -L pc-bios -rtc base=localtime -no-hpet -no-reboot -drive file=../vmimgs/w98.qcw -drive file=../vmimgs/d.qcw -device VGA -usb -M pc,accel=whpx,kernel-irqchip=off -device ac97 -netdev user,id=net0 -device rtl8139,netdev=net0 -cdrom ../vmimgs/Win98Soft.iso
Windows Hypervisor Platform accelerator is operational

Thanks.

Reply 1 of 4, by pokeswithastick

User metadata
Rank Newbie
Rank
Newbie

Ok I sort of resolved this first by disabling protected mode drivers in the Win 98 guest. Unfortunately that meant that the CD ROM also disappeared but rather than set that up in DOS I achieved the same result by disabling the primary IDE channel in System -> Devices. That had the same effect of forcing Windows to using 16 bit mode disk drivers and virtual memory but left the CDROM working on the secondary channel.

That made me think it might have been an IDE controller issue so I tried a fresh install using SCSI disks but had the same problem which leads me to think that it is something to do with virtual memory.

Performance is ok for what I am using it for (retro gaming) so I will leave it like this.

Reply 2 of 4, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Try using tcg or older versions of qemu and see if that fixes it.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 3 of 4, by doshea

User metadata
Rank Member
Rank
Member

I was having intermittent issues with Windows 98 installation and reboots under Qemu 6.1.0 hanging which I noticed seemed to be correlated with how much else my machine (3rd generation Core i7) was doing. I imagined it might be due to timing issues in the guest so I tried options to Qemu like '-rtc base=localtime,clock=vm -icount shift=7' and they seemed to make things reliable, although I can't remember if that completely unlocks the guest's clock from the host's, which you probably don't want if you're gaming.

I might be wrong but I imagine that you're running Windows 98 on a much faster virtual system than any physical system that was imagined at the time it was originally written, so there's probably a good chance that you're going to hit timing bugs/race conditions in it.