VOGONS


Good value Win98 Graphic Card

Topic actions

Reply 60 of 67, by Ozzuneoj

User metadata
Rank Oldbie
Rank
Oldbie
cyclone3d wrote on 2021-03-09, 05:59:

Anybody else remember the video card driver file mixing that was done back in the day to get the best possible performance from the cards?

Oh man... I had totally forgotten about that until you mentioned it. 🤣

I don't remember the details, but I remember reading about it and dabbling in it in my early days with nvidia. Most likely it led to me reinstalling Windows out of desperation after hours of dealing with blue-screens, while shouting "We've tampered in God's domain!"

Now for some blitting from the back buffer.

Reply 61 of 67, by pixel_workbench

User metadata
Rank Member
Rank
Member
cyclone3d wrote on 2021-03-09, 03:27:

What kind of problems were you seeing with the Quadro FX 1300?

I'm wondering if the same problems would be seen with the Geforce PCX cards (official PCIe FX cards)

What specific games have issues with the newer drivers?

Here are some of my test notes. Quadro FX1300, Asus A8V-XE, A64 4000, Win 98, DX9, no audio.

* With 61.76 driver:
Blood2 demo - black screen on launch. Missing UI after blindly starting new game.
Tomb Raider 2 demo - no text in game save/load/exit menu.
Serious Sam demo - black screen on launch, texture corruption after you blindly start a new game.
NFS 3 demo - most graphics are missing during gameplay.
GLQuake - menu text missing, texture corruption.
Quake 2 - texture corruption, menu text not visible.
NFS 5 - most graphics are missing.
Descent 3 demo - blurry text in DX mode. OpenGL mode results in graphic corruption and LCD out of range on launch.
Half Life, Unreal, NOLF - ok, but BSOD if AA + AF forced in the driver.
Populous The Beginning demo - distorted or blurry text. This affects all NV cards after GF4 that don't have texel center alignment, with all driver I tested.
Midtown Madness demo - screen corruption from pedestrians. Affects all Geforce cards, with all driver I tested.

* With inf modded 82.69 driver:
TR2 - same as before.
Blood 2 demo - same as before, but in game UI now flickers.
Serious Sam demo - menu ok, but severe lag if changing resolution. In game some textures are black.
Quake2 - ok, but severe lag if changing video resolution.
Unreal - severe lag in 32bit color.
NFS3 demo - lockup on launch.
NFS 5 - crash to desktop.
NOLF - texture corruption.
Half Life, GLQuake - ok.

* With inf modded 56.64 driver
Half Life - severe lag and artifacts.
GLQuake - severe lag and missing textures.
Windows explorer was also generally unresponsive and crashed often, so didn't test further.

* Inf modded 77.72 driver:
Blood 2 demo - same as before.
Unreal - lagging badly in 32bit color.
Descent 3 - same problems as before.
NFS 3 demo - text and graphics not rendered.
NFS 5 - text and graphics not rendered.
NOLF - corrupt textures.
Half Life, Serious Sam, GLQuake, Quake 2 - ok.

* With 66.94 driver:
Blood 2 demo, TR2 demo - same problems as before.
NFS 3 demo - no graphics or text rendered.
NFS 5 - no graphics or text rendered.
Unreal - occasional texture corruption. Rebooting seems to fix the problem.
Half Life - sometimes black screen on launch. Ok after reboot.
Descent 3 demo - same problem as before.
NOLF, GLQuake, Quake 2, Serious Sam demo - ok.

Now for comparison, here's my results with a Radeon X600 Pro on the same system, using latest 6.2 Win98 driver:
Populous demo - blurry text, but can be fixed by alternate pixel center in the driver.
GLQuake, Quake 2 - forcing AA not working.
Unreal - forcing AF causes some blending errors on smoke/fog, dispersion pistol flares.
Otherwise, all the games I mentioned for the FX1300 work without problems. Really puts into question the whole mantra of praising Nvidia drivers while bashing Ati drivers.

My Videos
P2 400 unlocked / Asus P3B-F / Voodoo3 3k / MX300 + YMF718

Reply 62 of 67, by mothergoose729

User metadata
Rank Oldbie
Rank
Oldbie

I haven't read about any complaints with ATI drivers around here. The reason they don't get recommended that often is that don't support 8 bit textures for table fog. Increasingly I am coming to believe that really doesn't matter that much.

Reply 63 of 67, by Joseph_Joestar

User metadata
Rank Oldbie
Rank
Oldbie
pixel_workbench wrote on 2021-03-09, 16:56:

Really puts into question the whole mantra of praising Nvidia drivers while bashing Ati drivers.

Isn't the general consensus that any Nvidia drivers newer than 45.23 are suboptimal for Win98?

Which implies that graphics cards that are too new for those drivers probably suffer from some compatibility issues under Win98.

Build #1: Celeron 466 / Abit ZM6 / Voodoo3 / AWE64 / YMF744 / SC-155
Build #2: AthlonXP 1700+ / Abit KT7A / GeForce4 / SBLive / ALS100
Build #3: Athlon64 3700+ / DFI LanParty / 9600GT / X-Fi Titanium

Reply 64 of 67, by Big Pink

User metadata
Rank Member
Rank
Member

Well, balls. I started work on a build using a free LGA775 board I got and obtained an FX1300 to see if I could put it to use running 98 on modern-ish hardware, but it sounds like that works out somewhere between very sub-optimal and awful. At least the Quadro card was dirt cheap.

I thought IBM was born with the world

Reply 65 of 67, by cyclone3d

User metadata
Rank l33t++
Rank
l33t++

Sounds like I need to put together a test system for the PCIe FX cards.

I've got the PCX 5300 and 5750 and the Quadro FX 1300.

There really should be a way to make the cards work just fine in 98SE.

Yamaha YMF modified setupds and drivers
Yamaha XG resource repository - updated November 27, 2018
Yamaha YMF7x4 Guide
AW744L II - YMF744 - AOpen Cobra Sound Card - Install SB-Link Header
Epstein didn't kill himself

Reply 66 of 67, by maverick85

User metadata
Rank Member
Rank
Member
mothergoose729 wrote on 2021-03-09, 17:31:

I haven't read about any complaints with ATI drivers around here. The reason they don't get recommended that often is that don't support 8 bit textures for table fog. Increasingly I am coming to believe that really doesn't matter that much.

likewise. nvidia has issues running in built windows 98 screensavers like 3d flying objects...

ASRock 98
Win98SE Desktop
ASRock 775i65G R2.03
Intel Core 2 Duo E4600
KHX 512MB DDR
Soundblaster 2 ZS + Altec Lansing ADA885
ATi Radeon 9800 Pro 128MB
2 x SATA 120GB HDD's
1 x IDE DVD-RW

Reply 67 of 67, by The Serpent Rider

User metadata
Rank l33t
Rank
l33t
pixel_workbench wrote:

Blood2 demo - black screen on launch. Missing UI after blindly starting new game.

I know this bug. It's easily fixable via RivaTuner. And most likely any other bug related to text or menus in D3D.

Get up, come on get down with the sickness
Open up your hate, and let it flow into me