VOGONS

Common searches


Glide patch

Topic actions

Reply 23 of 246, by gulikoza

User metadata
Rank Oldbie
Rank
Oldbie

Compiled the patch for the first time on x86_64 linux. It worked with just a few minor fixes (OpenGlide was another story...but more on that later) 😀
I'm sorry Rainmak3r, I could not reproduce your RedGuard problems, even a x86_64 build works flawlessly for me (well, actually somewhat less than flawlessly...it crashes 😀) But I've traced the problem to dynrec core. It works fine with normal core, but dynrec core somehow manages to pass invalid texture memory address...

http://www.si-gamer.net/gulikoza

Reply 28 of 246, by amano

User metadata
Rank Newbie
Rank
Newbie

Well. I am not that often in these forums anymore 😒

Is there a chance for this patch to be included in the official dosbox? If not, why not? Maybe with a wrapper included (psvoodoo should be open source)?

Or is this a thing for the future?

Reply 29 of 246, by Zebius

User metadata
Rank Member
Rank
Member

I upgraded my videocard recently and now I have Radeon HD3850 with Catalyst 7.12 drivers, system XP SP2.
Before I owned 6600GT and I could play TR1 with DosBox and Glide patch with no problems.

Now when I try to run a game using Dosbox version from gulikoza's site I receive following popup window:
'Severe problem: OpenGL GL_EXT_abgr extension is required for OpenGlide.'
It appears every time I try to load/save/enter menu, after any movies etc.
Also most of the time all I get trying to play is black screen (music and sounds are OK), sometimes graphics is normal. In DosBox status window I get many messsages: unsupported Glide call grErrorSetCallback.

I tried ykhwong CVS build but it crashes without any warning (exits to desktop) after introduction movies (in Glide mode).

Below is my OpenGLid.log after playing with gulikoza's Dosbox build.

Any hints?

Attachments

  • Filename
    OpenGLid.log
    File size
    24.54 KiB
    Downloads
    1741 downloads
    File license
    Fair use/fair dealing exception

Reply 30 of 246, by gulikoza

User metadata
Rank Oldbie
Rank
Oldbie

It seems ATi has removed this extension in 7.12 drivers!
But a quick check around the source doesn't show it is being used anywhere and TombRider still shows a picture here despite the error.
I will remove the check for GL_EXT_abgr, will see if it works better for you.

http://www.si-gamer.net/gulikoza

Reply 31 of 246, by Zebius

User metadata
Rank Member
Rank
Member
gulikoza wrote:

I will remove the check for GL_EXT_abgr, will see if it works better for you.

Thank you in advance. 😀

Maybe you wonder why I use DosBox with Glide patch instead of VDMsound and dgvooddo/Glidos for TR1? Simply I'd like to write an instruction how to run TR1 on Vista with DosBox for polish TR site. VDMSound doesn't work correctly on Vista so DosBox is the only free alternative to play this game.

Reply 32 of 246, by gulikoza

User metadata
Rank Oldbie
Rank
Oldbie

Does this dll work ok for you?

Attachments

  • Filename
    Glide2x.zip
    File size
    33.59 KiB
    Downloads
    535 downloads
    File license
    Fair use/fair dealing exception

http://www.si-gamer.net/gulikoza

Reply 33 of 246, by Zebius

User metadata
Rank Member
Rank
Member

I get no pop-up window anymore, but unfortunately this is not the end of my problems 🙁

After introduction movies most of the time I get messy picture (see an attachment), sometimes ring menu is OK but loading savegame gives me messy picture again. In fullscreen mode I can usually go back to normal visuals by alt-tabbing.
Sometimes the game just hangs in ring menu when trying to load a savegame. Sometimes I can see just part of the picture in lower part of the screen, the rest is black.

I tried all Dosbox output methods - ddraw, direct3D etc. both fullscreen and window. None of these options works flawlessly.

I also noticed two glitches - I can see many objects through the walls and there is no Lara's shadow.

I don't know what is the reason of this - shitty Catalyst drivers (as I said before on 6600GT I played for a while without major problems) or maybe glide patch needs correcting. Any help would be appreciated.

Thanks anyway. 😀

EDIT: Does glide patch support forcing resolution change? I can't go higher than 640x480.
This message: unsupported Glide call grErrorSetCallback still appears in status window. Do you need any logs or screens of status window to get more details?

Attachments

  • TRGlide.jpg
    Filename
    TRGlide.jpg
    File size
    81.21 KiB
    Views
    5542 views
    File license
    Fair use/fair dealing exception

Reply 34 of 246, by gulikoza

User metadata
Rank Oldbie
Rank
Oldbie

No, the wrapper has to support resolution change. One such wrapper might be available in a little while 😀
The grErrorSetCallback error is nothing to worry about.

One more thing you can try...try using dgVoodoo glide2x.dll. You can also try setting it to Direct3D9 renderer. Seems opengl is pretty broken on 3850 😜

http://www.si-gamer.net/gulikoza

Reply 35 of 246, by Zebius

User metadata
Rank Member
Rank
Member
gulikoza wrote:

One more thing you can try...try using dgVoodoo glide2x.dll. You can also try setting it to Direct3D9 renderer. Seems opengl is pretty broken on 3850 😜

It doesn't work - I get message: Error: failed to load textures to 3dfx board.
I don't know if I'm doing it correctly - I placed dgvoodoo's glide2x.dll and dgvoodoosetup.exe into dosbox folder. Then run dgvoodoosetup to change options (Direct3D9) then I launched Dosbox and the game. But error appears after intro movies no matter what I set in dgvoodoo options. Any hints?

Reply 37 of 246, by Zebius

User metadata
Rank Member
Rank
Member
gulikoza wrote:

This is really weird. Did you test any other 3d stuff (games...), maybe the card is faulty?

The card is OK, I can play all modern games, and even TR1 with dgvoodoo/ VDMSound. Either the card or new Catalyst drivers don't like Glide patch. 😠

Reply 38 of 246, by Zebius

User metadata
Rank Member
Rank
Member

I've made more tests with TR1. I'm able to run it in window usually but it crashes from time to time when loading a game or starting a new one.

Also I tried other wrappers:
- dgvoodoo 1.50beta and beta2 works but it's unplayable due to lots of artifacts (lines, transparent walls etc.)
- psvoodoo crashes after intro movies or gives black screen with music in background
- zeckensack's wrapper crashes after intro movies

I give up, I'll stick with XP anyway where we have VDMsound working very well with TR1.

Reply 39 of 246, by gulikoza

User metadata
Rank Oldbie
Rank
Oldbie

Wait...you use Vista? Must have missed that 😀
Did you try setting SDL_VIDEODRIVER=windib? But it's true, I haven't tested my patch in Vista since I don't use it...

http://www.si-gamer.net/gulikoza