VOGONS


First post, by Braca862

User metadata
Rank Newbie
Rank
Newbie

Hello,

I recently downloaded the ISO of Chasm The Rift and installed it on my computer. Once I click on Chasm.exe, the demo plays, but for some reason, the keyboard does not respond. I press the Esc key to access the menu, but it doesn't work. Even with the patches, I still have this problem. Here are my specs:

Dell XPS t500
Windows 98 Second Edition
512MB RAM
1 Ghz Pentium III
Sound Blaster AWE64 Gold

Can anyone help me with this?

Reply 4 of 11, by dr_st

User metadata
Rank l33t
Rank
l33t

Let's check first if it's a problem with the entire keyboard or just with Escape.

Try jumping directly to the first level by starting the game as follows:

chasm -warp 1

And see if you can move around, shoot, etc.

Reply 5 of 11, by Braca862

User metadata
Rank Newbie
Rank
Newbie
dr_st wrote:
Show quote

Let's check first if it's a problem with the entire keyboard or just with Escape.

Try jumping directly to the first level by starting the game as follows:

chasm -warp 1

And see if you can move around, shoot, etc.

Okay, so here's what I discovered; after entering that command and starting at the first level, it turns out that while the keyboard still doesn't work, my mouse does! I can fire by left clicking, and I can move by pressing on the scroll button. That's just weird.

Reply 7 of 11, by Braca862

User metadata
Rank Newbie
Rank
Newbie
dr_st wrote:

Do you happen to have a game controller plugged in? Maybe for some strange reason the game defaults to it and disables the keyboard?

Nope, no game controllers are plugged into the computer. Is there any config file within the game directory to try to change this?

Reply 8 of 11, by dr_st

User metadata
Rank l33t
Rank
l33t

Not as far as I can see. There is CHASM.CFG, but it is not human-readable.

Let's go back to the basics - is your keyboard PS/2 or USB? Chasm is a weird game; maybe they coded it specifically to work with a PS/2 keyboard only (if that's even possible). And try a different keyboard if you have such an option.

Reply 9 of 11, by Braca862

User metadata
Rank Newbie
Rank
Newbie
dr_st wrote:

Not as far as I can see. There is CHASM.CFG, but it is not human-readable.

Let's go back to the basics - is your keyboard PS/2 or USB? Chasm is a weird game; maybe they coded it specifically to work with a PS/2 keyboard only (if that's even possible). And try a different keyboard if you have such an option.

Yes, my keyboard is PS/2, and its the only one I currently have.

Reply 10 of 11, by dr_st

User metadata
Rank l33t
Rank
l33t

OK, another idea - maybe there is a timing issue that prevents Chasm from accessing the keyboard properly when the CPU is too fast? Can you try to boot into pure DOS and slow the CPU speed with a Slowdown utility (such as MoSlo or Slowdown by Bret Johnson - both can be found online) to something around Pentium/486 speeds?

Reply 11 of 11, by schmatzler

User metadata
Rank Member
Rank
Member
dr_st wrote:

OK, another idea - maybe there is a timing issue that prevents Chasm from accessing the keyboard properly when the CPU is too fast?

I don't think so. The keyboard works fine on my 1.4GHz Tualatin.

@Braca862: Did you install the last patch for the game? It is supposed to fix issues with fast CPU's:
https://web.archive.org/web/20090410053 ... _files.htm