VOGONS


Windows 3.1 in 256 colours

Topic actions

  • This topic is locked. You cannot reply or edit posts.

Reply 22 of 93, by AlecTricity

User metadata
Rank Newbie
Rank
Newbie

Problems on the S3 driver

EMS disabled, FULL core, Win3.11 (not workgroup)

starting on win /b

in 640 mode no cursor appears. There seems to be no "blind" cursor too.
In 386 enhanced tab a popup says "ports not initialised". VMM seems to work though.
in 800 mode the screen is oddly squeezed and unusable.

Using the latest CVS build without mods, pasted into a sofar well-run 0.63 environment.

Installed a clean windows 3.11 from inside DB off old floppies since propagated 3.1 package from [a well-known IRC user] did not work at all.

Reply 24 of 93, by cmw

User metadata
Rank Newbie
Rank
Newbie

I've encountered extremely starnge Win 3.1 Behaviour.

I have CVS dated the 26. 1. running with the Graphics Performance Boost patch. So I've installed Win 3.1 and the SB16 drivers.

Now for dynamic, it basically works (fast), but no keyboard, but as you stated not to set the core to dynamic, this seems ok.

But there is something weird going on. If I set the CPU to simple/normal/full, and the cycles to sth around 7000 (so my CPU usage is ~80-90%; i can type in stuff in notepad without any problems.

Setting the value higher (so my CPU is at 100% will notepad cause to show extreme delay).
So far, this makes sense.

However, I installed Winplay 3 (it's a 16bit mp3player), and if I listen to an mp3, my actual cpu usage will drop by about 30-40%. So at a cycle, where the notepad delay was EXTREME it is still a bit delayed, but MUCH FASTER then before!

On the contrary, if i set the cpu cycles to a value, where notepad used to work fine, the mp3 playback will stuttering around (and notepad will be in a sate of not-respondance, but assuming that the emulated cpu is not capable to decode the mp3 fast enough anymore, this would make sense).

However, how can it be that the actual cpu usage drops, when the emulated cpu should have plenty of work to do with mp3 decoding?

Edit:
I also installed the xing mpeg Player. It's wicked. When I run an mpeg, the cpu load again will drop by extreme 60%. The playback will be slow, but since I've got free ressources now, I can increase cpu cycles up to 40.000! (then my cpu is still at around 90%), the video playback smoothly (though looks crappy because of 256colours).

However, if i turn mpeg off the system will be insanse slow and cpu usage at 100% all the time (If i try to play an mp3 then, it will stuter as hell, i have to crease the cycles back to lik 14000 until mp3 plays smoothly.

This really is a bit odd and may be key to some very nifty speed tweaks.
Afaik, at least video playback works by bypassing the OS and directly send stuff to the cpu or sth..

Reply 28 of 93, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Nope, I can't really remember what the different between 0.63 and 0.65 are as far as Windows compatibility goes since I've been using CVS since then but as AFAIK there's still no share/win32 support and if you use dynamic core with 386 enhanced more then you'll lose keyboard input.

386 enhanced works fine in normal core.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 30 of 93, by mirekluza

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator
cmw wrote:

I have no clue what you did, but with sdl 1.2.9 and CVS from 5th May ~18:00 CET, I'm able to use dynamic core aswell as keyboard. Also, Windows does not crash Dosbox on shutdown. FINE work guys 😀

You have won the first prize... Congratulation... I was wondering who will be the first to find out (it is a deliberate fix from the evening of the 1st May - I knew about it before, because I tested it for one of the developers before it went to the CVS).

Since the cat is out of the bag now:
The dynamic core is now the best one to run Windows 3.x. Both in the terms of speed and compatibility... But you must use the CVS build...

Mirek

Reply 32 of 93, by cmw

User metadata
Rank Newbie
Rank
Newbie

Since there's no precompiled CVS available, and because I'll be late to University because of some stupid party @ Währinger Straße 😉, I took the liberty to upload my .exe for anyone who might like it. But don't expect too much, it's a MINIMAL build, no optimizations, and just support for sdl.dll and sdl_net.dll, no libpng for screenshots and no video capture, also don't expect direct draw to work (don't know about opengl, but i think not 😉 ).

http://unet.univie.ac.at/~a0501414/DOSBox.exe

Edit: Hell, this is so nice, even Freecell works now (couldn't get it to work when i tried it somewhen in... Febrruary...

Allthough note: Dosbox will crash on Windows Shutdown when there's mp3 (or mpg Playback) (in Win 3.11). But who cares, xingMPEG is much faster now, finally i can watch p0rn with it! 😉

Reply 37 of 93, by mirekluza

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator
Qbix wrote:

even more win32s games should work fine.

Wizardry Gold works for the first time in the normal CVS... Actually this was the game I was testing before the fix went to the CVS.
I did not want to speak about this before, because I was told that this fix can be scraped if it slows down things etc. (the main focus of the DOSBOX are DOS games).
Since QBIX wrote the above mentioned, I guess I can confirm that several win32s application were tested and they work.
FreeCell used to work before, so the fact that it does work now is nothing new. But for example Wizardry Gold did not.

Mirek

Reply 38 of 93, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

if anyone cares, here are two screenshots of benchmarks done with the last Norton Utilites for Dos/Windows 3.11 (I think it was 8.0).
The one that says in German "Dieses System" means of course "This system".
Both were done running on recent CVS, with dynamic core and cycles auto. My system is a P4 2.66 GHZ, 1 GB RAM. Also this built is using the svga patch and was running on 1024x768, so the bench could even go higher.

Attachments

  • nortonbench1.jpg
    Filename
    nortonbench1.jpg
    File size
    53.16 KiB
    Views
    14211 views
    File license
    Fair use/fair dealing exception
  • nortonbench2.jpg
    Filename
    nortonbench2.jpg
    File size
    73 KiB
    Views
    14211 views
    File license
    Fair use/fair dealing exception

Reply 39 of 93, by iamthejake2000

User metadata
Rank Newbie
Rank
Newbie

hey, i've tried everything posted here and i still can't run windows 3.1 in 256 colors. i installed the s3 driver, 640x480 256 colors, and with several cvs builds and the official 0.65 release, i can't get windows 3.1 to run in 386 enhanced mode, that is opening it with the win command and the /3 switch. when i do that the screen goes black with a flashing dos text cursor and nothing happens then. i've tried every core, ems on and off, i think i've pretty much tried everything. any help is appreciated.

OldDoom.com, my Doom (1 & 2) site.