VOGONS


DOSBox ECE (for Windows & Linux)

Topic actions

Reply 1081 of 1085, by CrossBow777

User metadata
Rank Member
Rank
Member
ripsaw8080 wrote on 2020-06-29, 21:45:

Mixer behavior depends on sbtype= and/or sbmixer= settings.

More detail here.

Then why does it not do it on regular DOSBox .74 or my SVM build I also use from time to time?

g883j7-2.png
Midi Modules: MT-32 (OLD), MT-200, MT-90, SD-20

Reply 1082 of 1085, by ripsaw8080

User metadata
Rank DOSBox Author
Rank
DOSBox Author

I can only guess that it's due to different settings, e.g. you use sbtype=sb1/sb2 or sbmixer=false in those cases where Dune 2 is not affecting your mixer settings. Perhaps there is some confusion as to which .conf file is being used. You can check the current settings by typing "sbtype" and "sbmixer" at the prompt.

At my place, with default settings (meaning sbtype=sb16 and sbmixer=true) in official 0.74(-3) and SVN, Dune 2 (US floppy version 1.07) is changing the mixer settings. As you can see in the linked thread, the user there was encountering the described behavior.

Reply 1083 of 1085, by jaygame1

User metadata
Rank Newbie
Rank
Newbie
MT_ wrote on 2020-03-06, 12:09:
Yesterplay80 wrote on 2020-02-21, 15:42:
Srandista wrote on 2020-02-21, 15:05:

What was the last version with Pixel perfect scaling? r4301?

Yup.

Hi, Yesterplay80. Given that for many users like me,is the most/only interesting feature of DOSBox ECE compared with the regular official DOSBox, it would probably make sense to add a direct link to the latest build of DOSBox ECE that had pixel-perfect scaling, to the page of DOSBox ECE (dosboxece.yesterplay.net/en/ ). Thanks.

ECE no longer has pixel-perfect scaling!?

Reply 1084 of 1085, by igermi

User metadata
Rank Newbie
Rank
Newbie

I am using dosbox ece to run grand prix 2. I have a steering wheel and pedals for this game, and for a few years now I have been using it with the "timed = false" option because with cycles "auto" it makes the game play at the correct speed but the steering wheel drifts and acts up. If I reduce the number of cycles from "cycles auto" to say, "cycles 10000" the game runs EXTREMELY slow but the steering wheel does not get super Jittery and drifty.

Is there something I can do to make TIMED = true work? I get an awesome HUGE resolution with my steering wheel when I have it set to timed=true, compared to timed=false.

I've tried different settings with the cycles. 80000, 50000, and 30000. All three of these were too jittery with the timed = true setting.

EDIT: I THINK I FIXED IT.

I was using an older version of ECE (4205) I downloaded the new one (4356) and it does not jitter on TIMED = TRUE with cycles at "AUTO".

Thanks guys- sorry for the wild goose chase!

Reply 1085 of 1085, by Yesterplay80

User metadata
Rank Member
Rank
Member
jaygame1 wrote on 2020-07-04, 21:32:

ECE no longer has pixel-perfect scaling!?

It has, via the shader support that came with regular DOSBox. But it doesn't contain Ant_222's pixel perfect patch any longer, because he's focusing on dosbox-staging and his patch didn't apply to DOSBox SVN any more.

My full-featured DOSBox SVN builds (without debugger) for Windows: Vanilla DOSBox and DOSBox ECE (Enhanced Community Edition)