VOGONS


Win9x + VDMSound **ALPHA**

Topic actions

Reply 200 of 204, by mard

User metadata
Rank Newbie
Rank
Newbie

Hey all. I took alpha3 for a spin on my Windows 98SE running natively on ThinkPad T42 2374. (I wrote a post about running W98SE on this configuration here).

Links to VCREDIST.EXE in OP are not working anymore and aren't archived. I am pretty sure I only had to install Visual C++ 2005 Redistributable x86 beforehand (link courtesy of Microsoft and archive.org).

The only issue is that after I'm done with it and run VXDSBOOM.EXE to terminate it, the integrated card becomes unavailable/undetectable to DOS games and I need to reboot the OS to get it working again.
SBPro/SB16 MIDI also doesn't sound quite right and it misses notes in my games (in games with RAD Miles driver at least), but Adlib MIDI works well.
Some games are hit or miss, for example I still couldn't run Earth 2140' due to its terrible sound code.
Despite these shortcomings, it seems to work exactly as described. Thanks for your work.

Reply 202 of 204, by darry

User metadata
Rank l33t
Rank
l33t
cambalinho wrote on 2021-06-19, 20:27:

vdmsound can be executed on MS-DOS?

Not under actual real-mode DOS . It must be run under Windows . See
https://en.m.wikipedia.org/wiki/VDMSound and https://sourceforge.net/projects/vdmsound/

Reply 203 of 204, by vico

User metadata
Rank Newbie
Rank
Newbie

It doesn't work for me on my Windows 98 with my AC-97. After installing, add SET BLASTER = A220 I7 D1 H5 P330 T6 to DOSDRV, run DOSDRV, games like Fatal Racing make horrible noise or the system becomes unstable with a blue screen error related to VXDSOUND.VXD.

I'm testing with VDMSound.win9x.bin.alpha3, does anyone know if there is any workaround for VDMSound Alpha to work on Windows 98?

Reply 204 of 204, by ludicrous_peridot

User metadata
Rank Newbie
Rank
Newbie

Well, I was trying VDMSound for MIDI specifically to route game's GM into one of Windows 98 MIDI devices using an updated build from this thread (packaged by @Deemster I think). It has not worked for me, neither with SB Audigy 1 VxD nor with Vortex 1. Issues you are describing sound different, so wondering if you tried that updated package.

Also the updated versions in this thread seem to do away with VXDSBOOM and are claimed to unload upon DOS sessoon termination.

One small issue I had some success with was getting rid of the "tip of the day" error by following this guide.

GA-G41M-Combo G41/ICH7/rev2.0 - Core 2 Quad Q9550 2.83GHz - 8Gb DDR3 1033
Radeon RX570 8Gb - Yamaha YMF744B-R PCI - X3MB Buran MPU-401
WDC 80Gb IDE ~ Win 98 SE - TOSHIBA 3Tb SATA ~ Win 10 Pro 64bit - Pioneer SATA BD-ROM/DVD+RW