VOGONS


Win9x + VDMSound **ALPHA**

Topic actions

Reply 200 of 203, by mard

User metadata
Rank Newbie
Rank
Newbie

Hey all. I took alpha3 for a spin on my Windows 98SE running natively on ThinkPad T42 2374. (I wrote a post about running W98SE on this configuration here).

Links to VCREDIST.EXE in OP are not working anymore and aren't archived. I am pretty sure I only had to install Visual C++ 2005 Redistributable x86 beforehand (link courtesy of Microsoft and archive.org).

The only issue is that after I'm done with it and run VXDSBOOM.EXE to terminate it, the integrated card becomes unavailable/undetectable to DOS games and I need to reboot the OS to get it working again.
SBPro/SB16 MIDI also doesn't sound quite right and it misses notes in my games (in games with RAD Miles driver at least), but Adlib MIDI works well.
Some games are hit or miss, for example I still couldn't run Earth 2140' due to its terrible sound code.
Despite these shortcomings, it seems to work exactly as described. Thanks for your work.

Reply 202 of 203, by darry

User metadata
Rank l33t
Rank
l33t
cambalinho wrote on 2021-06-19, 20:27:

vdmsound can be executed on MS-DOS?

Not under actual real-mode DOS . It must be run under Windows . See
https://en.m.wikipedia.org/wiki/VDMSound and https://sourceforge.net/projects/vdmsound/

Reply 203 of 203, by vico

User metadata
Rank Newbie
Rank
Newbie

It doesn't work for me on my Windows 98 with my AC-97. After installing, add SET BLASTER = A220 I7 D1 H5 P330 T6 to DOSDRV, run DOSDRV, games like Fatal Racing make horrible noise or the system becomes unstable with a blue screen error related to VXDSOUND.VXD.

I'm testing with VDMSound.win9x.bin.alpha3, does anyone know if there is any workaround for VDMSound Alpha to work on Windows 98?