VOGONS


Peixoto's patches for a few old games

Topic actions

Reply 800 of 802, by VCC

User metadata
Rank Newbie
Rank
Newbie
Peixoto wrote on 2020-11-18, 15:43:
VCC wrote on 2020-11-17, 20:49:
Peixoto wrote on 2020-11-17, 12:29:
Two options: […]
Show full quote

Two options:

1 ) Open the "Tomb raider II - Arsunt.ini" file with a text editor and add the line:
args=-gold

2) Use the add game button, and on the arguments field enter -gold

Thanks this seems to have done the trick. It crashed at first but running the game again got it going. Oddly enough though texture swapping seems to turn off whenever I start a new game in the expansion (It was working on the main menu)

What do you mean with that? Did you try to replace textures and it didn't work ? Texture packs made for TR 2 don't work with golden mask, those are different textures

Ah well that would explain it. I figured they would be using the same textures!

I have another question about another Tomb Raider problem I have been having for quite a long time if it's not too much trouble as well. In the classic Tomb Raider games, they all seem to stutter and drop frames occasionally if you run them on Windows 7 or later, and i've tried nearly everything, including full hardware changes, dgvoodoo and your patch itself. In the myriad of things I tried the only thing that worked was playing on Windows XP, which got rid of the problem entirely, and using Nvidia Profile Inspector to set the Frame Limit to 30.5, which reduced the long periods of slowdown but still left the microstuttering. I'm tempted to try a virtual machine even or install XP on a partition just to get things to work, but that would bring its own new host of problems.

Thanks for your help and sorry if this is the wrong place to put this!

Reply 801 of 802, by Peixoto

User metadata
Rank Member
Rank
Member
VCC wrote on 2020-11-18, 16:48:
Ah well that would explain it. I figured they would be using the same textures! […]
Show full quote
Peixoto wrote on 2020-11-18, 15:43:
VCC wrote on 2020-11-17, 20:49:

Thanks this seems to have done the trick. It crashed at first but running the game again got it going. Oddly enough though texture swapping seems to turn off whenever I start a new game in the expansion (It was working on the main menu)

What do you mean with that? Did you try to replace textures and it didn't work ? Texture packs made for TR 2 don't work with golden mask, those are different textures

Ah well that would explain it. I figured they would be using the same textures!

I have another question about another Tomb Raider problem I have been having for quite a long time if it's not too much trouble as well. In the classic Tomb Raider games, they all seem to stutter and drop frames occasionally if you run them on Windows 7 or later, and i've tried nearly everything, including full hardware changes, dgvoodoo and your patch itself. In the myriad of things I tried the only thing that worked was playing on Windows XP, which got rid of the problem entirely, and using Nvidia Profile Inspector to set the Frame Limit to 30.5, which reduced the long periods of slowdown but still left the microstuttering. I'm tempted to try a virtual machine even or install XP on a partition just to get things to work, but that would bring its own new host of problems.

Thanks for your help and sorry if this is the wrong place to put this!

I've noticed this problem as well, all the classic take around 1 millisecond to render a frame o a modern computer and still they seem to slow down some times: try this http://mion.faireal.net/BES/

Reply 802 of 802, by VCC

User metadata
Rank Newbie
Rank
Newbie
Peixoto wrote on 2020-11-18, 19:10:
VCC wrote on 2020-11-18, 16:48:
Ah well that would explain it. I figured they would be using the same textures! […]
Show full quote
Peixoto wrote on 2020-11-18, 15:43:

What do you mean with that? Did you try to replace textures and it didn't work ? Texture packs made for TR 2 don't work with golden mask, those are different textures

Ah well that would explain it. I figured they would be using the same textures!

I have another question about another Tomb Raider problem I have been having for quite a long time if it's not too much trouble as well. In the classic Tomb Raider games, they all seem to stutter and drop frames occasionally if you run them on Windows 7 or later, and i've tried nearly everything, including full hardware changes, dgvoodoo and your patch itself. In the myriad of things I tried the only thing that worked was playing on Windows XP, which got rid of the problem entirely, and using Nvidia Profile Inspector to set the Frame Limit to 30.5, which reduced the long periods of slowdown but still left the microstuttering. I'm tempted to try a virtual machine even or install XP on a partition just to get things to work, but that would bring its own new host of problems.

Thanks for your help and sorry if this is the wrong place to put this!

I've noticed this problem as well, all the classic take around 1 millisecond to render a frame o a modern computer and still they seem to slow down some times: try this http://mion.faireal.net/BES/

Yeah that's the stuff, hitching and sometimes slowdown on modern operating systems!

I gave that program a try and it did not seem to fix the problem, it ended up making the sound and FMVs very choppy though