VOGONS

Common searches


First post, by caltrop

User metadata
Rank Newbie
Rank
Newbie

The README is a bit vague as anything else I found.

This right?
serial1=directserial realport:ttyUSB0

How do you configure it to COM1?

I went thru !@#$% getting it enabled in Linux.

lsusb
Bus 003 Device 003: ID 0c45:6321 Microdia
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 2478:2008 Tripp-Lite U209-000-R Serial Port
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

sudo modprobe usbserial vendor=0x2748 product=0x2008

dmesg (exerpt)
[ 4249.477757] usb 4-3: reset full-speed USB device number 2 using ohci-pci
[ 4249.682348] pl2303 4-3:1.0: pl2303 converter detected
[ 4249.704530] usb 4-3: pl2303 converter now attached to ttyUSB0

Reply 1 of 11, by caltrop

User metadata
Rank Newbie
Rank
Newbie

Well I guess no one knew the answer.

So here's the FIX!

lsusb exerpt: Bus 004 Device 002: ID 2478:2008 Tripp-Lite U209-000-R Serial Port
dmesg exerpt: USB Serial support registered for pl2303
dosbox: serial1=directserial realport:ttyUSB0

Everything loads but it is not working.

Found a fix... 😀
$ sudo chmod 666 /dev/ttyUSB0

But I fear that I will have to do this everytime I boot up the system &
plug the USB Serial Adapter in...

Now I can use the USB Serial Port with DOSBox and communicate with my venerable HP48GX.

Everytime I do something with another OS in Linux I... 😠

Reply 2 of 11, by dougdahl

User metadata
Rank Member
Rank
Member

(This should only help with the sudo chmod 666 /dev/ttyUSB0 part)
At https://forums.linuxmint.com/viewtopic.php?t=135914
they mention that if you want to have access to that /dev file as a user after a reboot you need to run

sudo adduser (your user name e.g USER in my case) dialout

as that will give you as a user access to the serial ports.

Reply 3 of 11, by gdjacobs

User metadata
Rank l33t++
Rank
l33t++

To be a little more general, double check the group ownership of the device node using 'ls -l', then ensure your user is added to the appropriate group as above.

All hail the Great Capacitor Brand Finder

Reply 4 of 11, by caltrop

User metadata
Rank Newbie
Rank
Newbie

this is also in the attachment:

a bit problematic with some programs I am using

one program works with another or both separately
one can be a shell to the other

PDL -> PDLKERM

when one is run the other no longer can access the serial adapter
one requires the 'mode' command to configure the port 'com1'

a restart is required to get one or the other working

Attachments

  • Filename
    DOSBox_PDL.zip
    File size
    1.17 MiB
    Downloads
    25 downloads
    File comment
    additional issues
    File license
    Fair use/fair dealing exception

Reply 5 of 11, by caltrop

User metadata
Rank Newbie
Rank
Newbie

everything is working now
the 'chmod' alone fixed things

but there is more as mentioned in the previous post

this all relates to the HP48GX & the DOS PDL Programmers Utility
and KERMIT

this has been a fun adventure as are all my Linux endeavours

Reply 8 of 11, by caltrop

User metadata
Rank Newbie
Rank
Newbie

here we go again...

it's 2021 and I now have Mint Mate 20.1 and...

the USB Serial Adapter I was using in Mint 18.1 is NOT working in 20.1, it was a headache back then and worse now

and the Bluetooth is also having issues but that's not DOSBox

what is it with Linux Mint and adapters?

I'll post more when I get back on the computer and WiFi...

but so far it is a MYSTERY...🤔

Reply 9 of 11, by _Rob

User metadata
Rank Member
Rank
Member

It is possible that the dialup group no longer exists in a modern distribution. You may want to do a search for "udev permissions for ttyUSB0" on how to automatically give permissions when the device is plugged in.
e.g. , https://superuser.com/questions/431843/config … for-dev-ttyusb0

Another way is to check the permissions of the device.

ls -l /dev/ttyUSB0

Reply 10 of 11, by caltrop

User metadata
Rank Newbie
Rank
Newbie

here we are in Mint Mate 20.1 & DOSBox 0.74-3 reported DOS 6.22

and Serial support is still spotty

sometimes it works, most times not

DOSBox
serial1=directserial realport:ttyUSB0
serial2=directserial realport:ttyUSB1
serial3=disabled
serial4=disabled

USB Serial Adapters
Bus 001 Device 010: ID 2478:2008 Tripp-Lite U209-000-R Serial Port
Bus 001 Device 007: ID 2478:2008 Tripp-Lite U209-000-R Serial Port

/dev/ttyUSB0, UART: 16654, Port: 0x0000, IRQ: 0
/dev/ttyUSB1, UART: 16654, Port: 0x0000, IRQ: 0

unfortunately the Linux System will not alow configuration of the adapters

Sun May 16 07:18:41
~
$ setserial /dev/ttyUSB0 irq 4
Cannot set serial info: Inappropriate ioctl for device

Reply 11 of 11, by _Rob

User metadata
Rank Member
Rank
Member

@caltrop I'm not talking about running setserial. I'm talking about the permissions of the /dev/ttyUSB0 device.

But speaking of setserial, what does this output:

setserial -G /dev/ttyUSB0

Can you run the following command and provide the output:

ls -l /dev/ttyUSB*

I don't have any USB serial adapters myself, but on my Fedora installation there is still a "dialout" group, which should also exist on your Linux Mint installation. And I suspect that if I where to add my user to that group, I could use any supported serial device. e.g. something along the lines of:

sudo usermod -a -G dialout caltrop

You can check which groups your user is a member of by running:

groups